Subject: [Ips] iSER PDU-specific qualifiers

From: "Eddy Quicksall" <[email-masked]>
Date: Fri, 24 Mar 2006 12:40:48 -0500

Would it make sense to add a PDU-specific qualifier called PDUDescriptor to each item under "7.3 iSCSI PDUs"?

Eddy

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: Mike Ko <[email-masked]>
Date: Fri, 24 Mar 2006 09:44:36 -0800

What is the intent of PDUDescriptor?

Mike
To:     <[email-masked]>
cc:      
Subject:        [Ips] iSER PDU-specific qualifiers

Would it make sense to add a PDU-specific qualifier called PDUDescriptor 
to each item under "7.3 iSCSI PDUs"?
 
Eddy

---

From: "Eddy Quicksall" <[email-masked]>
Date: Fri, 24 Mar 2006 13:55:41 -0500

It would point to the PDU.
  ----- Original Message ----- 
  From: Mike Ko 
  To: Eddy Quicksall 
  Cc: [email-masked] 
  Sent: Friday, March 24, 2006 12:44 PM
  Subject: Re: [Ips] iSER PDU-specific qualifiers

  Mike 
  To:        <[email-masked]> 
  cc:         

  Eddy 

------------------------------------------------------------------------------

---

From: Mike Ko <[email-masked]>
Date: Fri, 24 Mar 2006 11:08:46 -0800

Eddy,

As stated in the iSER draft, when "The iSCSI Layer requests the iSER Layer 
to process the iSCSI PDU by invoking the appropriate Operational 
Primitive", "BHS and the optional AHS of the iSCSI PDU as defined in 
[RFC3720] MUST qualify each of the invocations."  In addition, 
PDU-specific qualifers are used where needed.  The iSER layer has all the 
information it needs to process the PDU.  So no, I don't think it makes 
sense to add a PDUDescriptor qualifier.

Mike
To:     "Mike Ko" <[email-masked]>
cc:     <[email-masked]> 
Subject:        Re: [Ips] iSER PDU-specific qualifiers

----- Original Message ----- 
From: Mike Ko 
To: Eddy Quicksall 
Cc: [email-masked] 
Sent: Friday, March 24, 2006 12:44 PM
Subject: Re: [Ips] iSER PDU-specific qualifiers

Mike 
To:        <[email-masked]> 
cc: 

Eddy