Subject: [Ips] Question regarding iSNS Mibs

From: sajjan rao <[email-masked]>
Date: Wed, 8 Mar 2006 16:02:00 -0800 (PST)

Hi,

I am new to the subject of iSNS and MIBs.My reading of
draft 8 of the iSNS MIB document has me confused. Is
an iSNS client required to implement this MIB?  The
introduction implies that it does. But section 3.2
‘iSNS MIB structure’ seems to indicate that the iSNS
MIB has no sections which are required to be
implemented by an iSNS client.  Section 3.4 is titled
‘Multiple Client and Server Instances’. But the text
under this section refers only to multiple instances
of servers.

Under the description for IsnsSrvrDscvryMthdID, the
following are mentioned – isnsSrvrDscvryMthdId and
isnsClntInstDiscMcgrp. I couldn’t find details on both
anywhere in the document. Can somebody clarify?

Thanks,
Sajjnu

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: "Scott Kipp" <[email-masked]>
Date: Mon, 20 Mar 2006 12:56:41 -0700

Sajjnu,

Thanks for reviewing the iSNS MIB.  You have basically found some text that was not properly updated when we revised the MIB in this 8th revision.  The iSNS client is not required to implement this MIB.  Here are some clarifications that should make this clear:

1) The current introduction is:
2.  Introduction

The iSNS protocol can be used by IP based storage devices for dynamic registration and discovery of storage devices in the network [RFC 471].  It has the capability to group devices into storage Discovery Domains.  The iSNS MIB is designed to allow SNMP to be used to monitor and manage iSNS servers and Clients to provide iSNS capabilities.

The last sentence needs to change so that the iSNS client is not implemented and iSNS servers are no longer managed by the MIB.  The resulting text should be:

2.  Introduction

The iSNS protocol can be used by IP based storage devices for dynamic registration and discovery of storage devices in the network [RFC 471].  It has the capability to group devices into storage Discovery Domains.  The iSNS MIB is designed to allow SNMP to be used to monitor iSNS servers to provide iSNS capabilities.

2) Section 3.4 is currently:

3.4  Multiple Client and Server Instances

This section name should be changed to:

3.4  Multiple Server Instances

3) In IsnsSrvrDscvryMthdId, the description follows:

IsnsSrvrDscvryMthdId ::= TEXTUAL-CONVENTION
    STATUS         current
    DESCRIPTION
"This bitamp is used to indicate the iSNS Server discovery
 methods that are supported and enabled on an iSNS Server.
 The options are DHCP, SLP, multicast group iSNS heartbeat,
 broadcast group iSNS heartbeat, configured server list, and
 other.  The iSNS Server may also support additional discovery
 methods not indicated.  The bitmap also is used to indicate
 the type of discovery being used by an iSNS Client instance.
 If being used, the configured server list for a specific iSNS
 client is specified in isnsClntSrvrCfgTable table.  If used,
 the multicast group is specified in isnsClntInstDiscMcGrp."

The last two sentences should be removed since they refer to the iSNS Client.

4)
isnsInstInfo                OBJECT-TYPE
    SYNTAX                  SnmpAdminString (SIZE (0..80))
    MAX-ACCESS              accessible-for-notify
    STATUS                  current
    DESCRIPTION
"Textual information about the iSNS Server or client
 notification.  An example is: iSNS Client Started, or iSNS
 Server Started, information that would be included in the
 appropriate notification."

should be:

snsInstInfo                OBJECT-TYPE
    SYNTAX                  SnmpAdminString (SIZE (0..80))
    MAX-ACCESS              accessible-for-notify
    STATUS                  current
    DESCRIPTION
"Textual information about the iSNS Server notification.  An example is: iSNS
 Server Started, information that would be included in the
 appropriate notification."

I think this should clear up the confusion.  Thanks for finding this.

If anyone disagrees with the following changes, please let me know or I will incorporate them

Sincerely,
Scott Kipp

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, March 10, 2006 10:00 AM
To: [email-masked]
Subject: Ips Digest, Vol 23, Issue 6

Send Ips mailing list submissions to
	[email-masked]

To subscribe or unsubscribe via the World Wide Web, visit
	https://www1.ietf.org/mailman/listinfo/ips
or, via email, send a message with subject or body 'help' to
	[email-masked]

You can reach the person managing the list at
	[email-masked]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of Ips digest..."

Today's Topics:

   1. Question regarding iSNS Mibs (sajjan rao)

----------------------------------------------------------------------

Message: 1
Date: Wed, 8 Mar 2006 16:02:00 -0800 (PST)
From: sajjan rao <[email-masked]>
Subject: [Ips] Question regarding iSNS Mibs
To: [email-masked]
Message-ID: <[email-masked]>
Content-Type: text/plain; charset=iso-8859-1

Hi,

I am new to the subject of iSNS and MIBs.My reading of
draft 8 of the iSNS MIB document has me confused. Is
an iSNS client required to implement this MIB?  The
introduction implies that it does. But section 3.2
'iSNS MIB structure' seems to indicate that the iSNS
MIB has no sections which are required to be
implemented by an iSNS client.  Section 3.4 is titled
'Multiple Client and Server Instances'. But the text
under this section refers only to multiple instances
of servers.

Under the description for IsnsSrvrDscvryMthdID, the
following are mentioned - isnsSrvrDscvryMthdId and
isnsClntInstDiscMcgrp. I couldn't find details on both
anywhere in the document. Can somebody clarify?

Thanks,
Sajjnu

------------------------------

End of Ips Digest, Vol 23, Issue 6
**********************************

SPECIAL NOTICE

All information transmitted hereby is intended only for the use of the
addressee(s) named above and may contain confidential and privileged
information. Any unauthorized review, use, disclosure or distribution
of confidential and privileged information is prohibited. If the reader
of this message is not the intended recipient(s) or the employee or agent
responsible for delivering the message to the intended recipient, you are
hereby notified that you must not read this transmission and that disclosure,
copying, printing, distribution or use of any of the information contained
in or attached to this transmission is STRICTLY PROHIBITED.

Anyone who receives confidential and privileged information in error should
notify us immediately by telephone and mail the original message to us at
the above address and destroy all copies.  To the extent any portion of this
communication contains public information, no such restrictions apply to that
information. (gate01)