Subject: [Ips] MPA alignment

From: "Eddy Quicksall" <[email-masked]>
Date: Mon, 17 Apr 2006 14:55:01 -0400

It is preferable to have TCP sender to align MPA header where a TCP segment begins and to keep the MPA FPDU within a TCP segment, so that the receiver hardware doesn't need to temporarily buffer the FPDU for the CRC checking.  

Does anyone know of any software or hardware that is not an FPDU alignment sender?
Does anyone have a feel for the likelihood of software or hardware to not align FPDU's on a TCP segment?

Eddy

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: Mike Ko <[email-masked]>
Date: Mon, 17 Apr 2006 23:16:45 -0700

Eddy,

If your question is about MPA behavior in general, then it should be 
directed to the rddp forum.

Assuming your question is related to iSER, then if iWARP is implemented in 
software and uses the existing TCP/IP stack, then it cannot guarantee that 
FPDU's will be aligned with TCP segments.  For the general case where 
iWARP is implemented in an RNIC with an integrated TCP/IP stack, then it 
is to the RNIC vendor's advantage to optimize his product's performance 
and therefore FPDU's should be aligned with TCP segments.  However, the 
receiver can still receive FPDU's which are not aligned with TCP segments 
if there are resegmenting middleboxes somewhere in the connection path.

Mike 
To:     <[email-masked]>
cc:      
Subject:        [Ips] MPA alignment

It is preferable to have TCP sender to align MPA header where a TCP 
segment begins and to keep the MPA FPDU within a TCP segment, so that the 
receiver hardware doesn?t need to temporarily buffer the FPDU for the CRC 
checking. 
 
Does anyone know of any software or hardware that is not an FPDU alignment 
sender?
Does anyone have a feel for the likelihood of software or hardware to not 
align FPDU's on a TCP segment?
 
Eddy_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: "Eddy Quicksall" <[email-masked]>
Date: Tue, 18 Apr 2006 08:47:40 -0400

Thanks,

Here is my feeling on this. If one were to use a standard TCP/IP stack (that does copying) then it is a bit silly to use iSER. If one were to use a software implementation and write/modify the stack to get the desired effects of DDP then he will probably heed to the alignment notes in the spec. So if one were to support misaligned segments using a slower method then it would be OK.

Eddy
  ----- Original Message ----- 
  From: Mike Ko 
  To: Eddy Quicksall 
  Cc: [email-masked] 
  Sent: Tuesday, April 18, 2006 2:16 AM
  Subject: Re: [Ips] MPA alignment

  Eddy, 

  If your question is about MPA behavior in general, then it should be directed to the rddp forum. 

  Assuming your question is related to iSER, then if iWARP is implemented in software and uses the existing TCP/IP stack, then it cannot guarantee that FPDU's will be aligned with TCP segments.  For the general case where iWARP is implemented in an RNIC with an integrated TCP/IP stack, then it is to the RNIC vendor's advantage to optimize his product's performance and therefore FPDU's should be aligned with TCP segments.  However, the receiver can still receive FPDU's which are not aligned with TCP segments if there are resegmenting middleboxes somewhere in the connection path. 

  Mike   
  To:        <[email-masked]> 
  cc:         

    

------------------------------------------------------------------------------