Subject: [Ips] DDP message interleaving

From: "Ben Sum" <[email-masked]>
Date: Wed, 19 Apr 2006 14:09:17 -0400

Is sender ever multiplexing messages?  Considering following message:

Message1:     

FPDU frame MSN = 0, MO = 0, L = 0, T= 0 

FPDU frame MSN = 0, MO = 1000, L = 1, T= 0 
Message2:      

FPDU frame T = 1, TO = 0, L = 0 
FPDU frame T = 1, TO = 1000, L = 1 
 
Can the sender transmit as following: 
1)       FPDU frame MSN = 0, MO = 0, L = 0, T = 0 
2)       FPDU frame T = 1, TO = 0, L = 0 
3)       FPDU frame MSN = 0, MO = 1000, L = 1, T = 0 
4)       FPDU frame T = 1, TO = 1000, L = 1

Regards,

Ben

Want to help me make miracles?

www.active.com/donate/tntga/tntgabsum

Any content within this email is provided "AS IS" for informational
purposes only.  No contract will be formed between the parties by virtue
of this email.  

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: "Caitlin Bestler" <[email-masked]>
Date: Thu, 20 Apr 2006 15:25:01 +0000

> -----Original Message-----
> From: Ben Sum [mailto:[email-masked]]
> Sent: Wednesday, April 19, 2006 06:09 PM
> To: [email-masked]
> Subject: [Ips] DDP message interleaving
> 

There are two issues here: what you should accept,
and what you should send.

On the receive side, if you are processing the
incoming packets optimally you will not even notice
this type of anomolous ordering. A receiver definitely
SHOULD NOT add extra steps to attempt to detect something
of this nature.

On the other hand this is definitely something that
a sender SHOULD NOT send, possibly MUST NOT send.

The DDP spec clarifies that the DDP layer segments
messages and submits them to the LLP. It is clear
that the DDP layer MUST submit all of the segments
for a message in sequence and non-interleaved.

What is not clear is if the LLP layer MUST assign
these segments successive LLP sequences, or if it
can interleave in ways that do change the sequence
of L flags or the fact that the L flag is the last
segment of the message.

Nobody has identified a reason why a MPA layer would
do such a thing, and assigning the expected TCP
sequencing is at the minimum an implied SHOULD.
But this is not explicitly a constraint. The SCTP
Adaptation, which is under the exact same constraints
as the MPA/TCP adaptation explicitly recognizes that
SCTP stacks are allowed to re-order Data Chunks in
order to optimize transmission. IF DDP does not impose
a MUST behavior on SCTP, then it does not impose it
on MPA/TCP. But SCTP has a valid "SHOULD trumping" 
reason for reordering packets, MPA/TCP does not.