Subject: [Ips] Targets that don't want to support discovery

From: "Eddy Quicksall" <[email-masked]>
Date: Thu, 27 Apr 2006 14:50:28 -0400

Appendix D says:
   A system that contains targets MUST support discovery sessions on
   each of its iSCSI IP address-port pairs, and MUST support the
   SendTargets command on the discovery session

Suppose I have targets A, B and C. I want target A to be the only target that can support discovery. Login to targets B and C will be redirected by A.

This is fine except for the fact that once the redirection occurs the initiator has the address of B and C and could open a discovery session to B or C.

I'm thinking that I could have B and C redirect to A for any discovery session hence A would become the only target to support discovery (but that would "break the law").

I'm wondering how the community thinks this should be handled.

Eddy

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: William Studenmund <[email-masked]>
Date: Thu, 27 Apr 2006 16:09:04 -0700

On Apr 27, 2006, at 11:50 AM, Eddy Quicksall wrote:

> Suppose I have targets A, B and C. I want target A to be the only  
> target that can support discovery. Login to targets B and C will be  
> redirected by A.
>
> This is fine except for the fact that once the redirection occurs  
> the initiator has the address of B and C and could open a discovery  
> session to B or C.
>
> I'm thinking that I could have B and C redirect to A for any  
> discovery session hence A would become the only target to support  
> discovery (but that would "break the law").
>

I have a feeling that that'd be breaking the rules.

Why do you want to do this?

Another option is that while ports B and C should support discovery  
sessions, they don't have to do it very efficiently. It's fine if  
they use some sort of proxy to internally route the commands to A for  
processing. So only A is very smart, but discovery works everywhere.

Take care,

Bill