Subject: [Ips] [iSER] Connection_Handle question

From: "Eddy Quicksall" <[email-masked]>
Date: Tue, 23 May 2006 14:21:48 -0400

Generally when an upper layer is going to use a lower layer, the lower layer gives a handle (many times via an open call).

In the primitives the Connection_Handle is passed as an input qualifier. But I don't see any primitive that returns the Connection_Handle. Am I missing that?

Eddy

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: "Eddy Quicksall" <[email-masked]>
Date: Thu, 25 May 2006 13:51:28 -0400

I think I found the answer in the definition of "Connection Handle". Am I correct that the iSCSI and iSER layers both must understand the handle since both must access the TCP/IP stack. For example if it is sockets, the handle may be the "socket"; or if it is a proprietary scheme the handle may be a pointer to a structure that is understood by both the iSER and iSCSI layers.

Eddy
  ----- Original Message ----- 
  From: Eddy Quicksall 
  To: [email-masked] 
  Sent: Tuesday, May 23, 2006 2:21 PM
  Subject: [Ips] [iSER] Connection_Handle question

  Eddy

------------------------------------------------------------------------------

---

From: "Mallikarjun C." <[email-masked]>
Date: Fri, 26 May 2006 10:05:38 -0700 (PDT)

Yes, you are correct.

Mallikarjun

--- Eddy Quicksall
<[email-masked]> wrote:

> I think I found the answer in the definition of
> "Connection Handle". Am I correct that the iSCSI and
> iSER layers both must understand the handle since
> both must access the TCP/IP stack. For example if it
> is sockets, the handle may be the "socket"; or if it
> is a proprietary scheme the handle may be a pointer
> to a structure that is understood by both the iSER
> and iSCSI layers.
> 
> Eddy
>   Generally when an upper layer is going to use a
> lower layer, the lower layer gives a handle (many
> times via an open call).
> 
>   In the primitives the Connection_Handle is passed
> as an input qualifier. But I don't see any primitive
> that returns the Connection_Handle. Am I missing
> that?
> 
>   Eddy
> 
> 
>
> https://www1.ietf.org/mailman/listinfo/ips

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com