Subject: [Ips] TargetAddress used in discovery without a SendTargets

From: "Eddy Quicksall" <[email-masked]>
Date: Tue, 23 May 2006 16:50:41 -0400

For a discovery session the initiator is allowed to login without a TargetName. Normally the initiator uses SendTargets to solicit the TargetAddress(s).

But if the SendTargets is not used and there was no TargetName given by the initiator, is it intended that the target could send the TargetAddress/TargetAlias/TargetPortalGroupTag information?

Eddy

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: William Studenmund <[email-masked]>
Date: Wed, 24 May 2006 11:33:49 -0700

On May 23, 2006, at 1:50 PM, Eddy Quicksall wrote:

> For a discovery session the initiator is allowed to login without a  
> TargetName. Normally the initiator uses SendTargets to solicit the  
> TargetAddress(s).
>
> But if the SendTargets is not used and there was no TargetName  
> given by the initiator, is it intended that the target could send  
> the TargetAddress/TargetAlias/TargetPortalGroupTag information?

A discovery session is, as I understand it, intended for SendTargets  
discovery. If the initiator doesn't want to perform SendTargets  
discovery even after starting a discovery session, why do we feel the  
need for the target to do anything?

Take care,

Bill

---

From: "Eddy Quicksall" <[email-masked]>
Date: Thu, 25 May 2006 13:45:08 -0400

I don't. What I asked is if it is "intended that the target could send it".

Eddy
  ----- Original Message ----- 
  From: William Studenmund 
  To: Eddy Quicksall 
  Cc: [email-masked] 
  Sent: Wednesday, May 24, 2006 2:33 PM
  Subject: Re: [Ips] TargetAddress used in discovery without a SendTargets

  A discovery session is, as I understand it, intended for SendTargets discovery. If the initiator doesn't want to perform SendTargets discovery even after starting a discovery session, why do we feel the need for the target to do anything?

  Take care,

  Bill

------------------------------------------------------------------------------

---

From: "Eddy Quicksall" <[email-masked]>
Date: Thu, 25 May 2006 17:43:17 -0400

I realize the confusion ... I was not really clear. Here is the case: the initiator logs in with SessionType=Discovery and does not specify a TargetName but before the login is complete the "target" (which has not been named) sends the TargetName. The spec does not prohibit this. My question is: was this intended?

Eddy
  ----- Original Message ----- 
  From: Eddy Quicksall 
  To: William Studenmund 
  Cc: [email-masked] 
  Sent: Thursday, May 25, 2006 1:45 PM
  Subject: Re: [Ips] TargetAddress used in discovery without a SendTargets

  Eddy
    ----- Original Message ----- 
    From: William Studenmund 
    To: Eddy Quicksall 
    Cc: [email-masked] 
    Sent: Wednesday, May 24, 2006 2:33 PM
    Subject: Re: [Ips] TargetAddress used in discovery without a SendTargets

    Take care,

    Bill

----------------------------------------------------------------------------

---

From: Julian Satran <[email-masked]>
Date: Thu, 25 May 2006 18:02:17 -0400

It does do any harm. TargetName is mandated if you name things to validate 
that you got where you intended but why forbit it if it does no harm.

Julo

"Eddy Quicksall" <[email-masked]> 
25/05/06 17:43

To
"William Studenmund" <[email-masked]>
cc
[email-masked]
Subject
Re: [Ips] TargetAddress used in discovery without a SendTargets

I realize the confusion ... I was not really clear. Here is the case: the 
initiator logs in with SessionType=Discovery and does not specify a 
TargetName but before the login is complete the "target" (which has not 
been named) sends the TargetName. The spec does not prohibit this. My 
question is: was this intended?
 
Eddy
----- Original Message ----- 
From: Eddy Quicksall 
To: William Studenmund 
Cc: [email-masked] 
Sent: Thursday, May 25, 2006 1:45 PM
Subject: Re: [Ips] TargetAddress used in discovery without a SendTargets

I don't. What I asked is if it is "intended that the target could send 
it".
 
Eddy
----- Original Message ----- 
From: William Studenmund 
To: Eddy Quicksall 
Cc: [email-masked] 
Sent: Wednesday, May 24, 2006 2:33 PM
Subject: Re: [Ips] TargetAddress used in discovery without a SendTargets

 
But if the SendTargets is not used and there was no TargetName given by 
the initiator, is it intended that the target could send the 
TargetAddress/TargetAlias/TargetPortalGroupTag information?

A discovery session is, as I understand it, intended for SendTargets 
discovery. If the initiator doesn't want to perform SendTargets discovery 
even after starting a discovery session, why do we feel the need for the 
target to do anything?

Take care,

Bill