Subject: [Ips] Preliminary Montreal meeting info

From: [email-masked]
Date: Tue, 13 Jun 2006 02:47:38 -0400

Final agenda will be published next Monday, June 19th.
Here's the preliminary schedule for the ips meeting and
other meetings in that timeslot.

WEDNESDAY, July 12, 2006 
1510-1610 Afternoon Session II
Room 519A	APP	atompub	Atom Publishing Format and Protocol WG
Room 513C-F	INT	mipshop	Mobility for IP: Performance, Signaling and
Handoff Optimization WG
Room 515	OPS	grow	Global Routing Operations WG
Room 518AB	RTG	pim	Protocol Independent Multicast WG
Room 519B	SEC	isms	Integrated Security Model for SNMP WG
Room 513B	TSV	ips	IP Storage WG

Thanks,
--David
----------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: Praveen Madhavan <[email-masked]>
Date: Fri, 16 Jun 2006 05:37:38 -0700 (PDT)

Hi Folks,
  
 Can any one point me the frame format of  bidirectional command in case of iSCSI & FCP ?.. I was trying to  route bidirectional command recv'd from iSCSI initiator to FC Target.. 
  
  Here is the iSCSI PDU format for bi-direct command recv from initiator
 ------------------------------------------------------------------------------------------------
  |         BHS(48bytes)                                                                     | 
  |        R & W bit set to  ONE,                                                         |
  |        Expected xfer len =  0x200                                                   |   
  |        Total AHS Length =  2(8bytes)                                              |
  |        SCSI CDB = Write(10)  Transfer length = 00 01 ( 512 bytes)  |  
   ------------------------------------------------------------------------------------------------|       
  |        AHS ( 8 bytes)                                                                        | 
  |        Expected Read data length =  0x200(512  bytes)                     |
  --------------------------------------------------------------------------------------------------
  
  Here is the FCP format for bi-direct command that i frame for sending it to target.
  
   ------------------------------------------------------------------------------------------------
  |        FC-Header  (24bytes)                                                           | 
    |------------------------------------------------------------------------------------------------
  |        FCP-Header(36  bytes)                                                         |
  |         R & W bit set to  ONE,                                                        |  
  |        Additional CDB length = 0                                                      |
    |        SCSI CDB = Write(10)  Transfer length = 00 01 ( 512 bytes)   |
  |        FCP_DL  = 0x200 ( 512  bytes)                                              |
  |        FCP_BIDIRECTIONAL_READ_DL =  0x200(512)                      |
   -------------------------------------------------------------------------------------------------|       
  
  Well, I am not quite sure about the CDB values in case Bidir commands..
  Will Bi directional cmds use Write CDB(10) or Read CDB (10) ? ..
  
  How can i control following bidi- operation in case of iSCSI & FCP ?
  1.bidirectional command with read before write operation
  2.bidirectional command with write before read operation
  
  -Praveen

---------------------------------
New Yahoo! Messenger with Voice. Call regular phones from your PC and save big.

---

From: William Studenmund <[email-masked]>
Date: Fri, 16 Jun 2006 12:04:52 -0700

On Jun 16, 2006, at 5:37 AM, Praveen Madhavan wrote:

> Hi Folks,
>
> Can any one point me the frame format of bidirectional command in  
> case of iSCSI & FCP ?.. I was trying to route bidirectional command  
> recv'd from iSCSI initiator to FC Target..
>
> |        BHS 
> (48bytes)                                                              
>        |
> |        R & W bit set to  
> ONE,                                                        |
> |        AHS ( 8  
> bytes)                                                                 
>    |
> |        FC-Header  
> (24bytes)                                                          |
> |        FCP-Header(36  
> bytes)                                                        |
> |         R & W bit set to  
> ONE,                                                       |

No. Read and Write in normal sizes (6, 10, 12, 16) are unidirectional.

Each specific command has either no data phase (test unit ready), has  
at most a data-out phase (Write for instance), at most a data-in  
phase (Read), or is bidirectional.

> 2.bidirectional command with write before read operation

You really don't need to do anything different for BiDi commands,  
other than be able to keep both a Write and a Read residual. As you  
note, the SCSI Command Request will indicate what data phases the  
initiator expects, you need only map them along.

How does the target announce/control data flow in FCP? You need only  
pass that information on to the iSCSI layer. If the FCP target sends  
you data, then you send the initiator a bunch of Data-In PDUs.  
However it is that FCP controls data openings translates into R2Ts to  
the iSCSI initiator.

Take care,

Bill

---

From: "Eddy Quicksall" <[email-masked]>
Date: Mon, 19 Jun 2006 17:16:53 -0400

Is anyone aware of any bidi SCSI commands?

Eddy

----- Original Message ----- 
From: "William Studenmund" <[email-masked]>
To: "Praveen Madhavan" <[email-masked]>
Cc: <[email-masked]>
Sent: Friday, June 16, 2006 3:04 PM
Subject: Re: [Ips] Reg: Bidirectional command format ?

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.1 (Darwin)
> 
> iD8DBQFEkwDZDJT2Egh26K0RAjqYAJ4yfTh+dkihI/Ha0RGhZN5NJ22zUQCfRc1L
> 7fPzAAxZZUa3mX6JsaEMPYs=
> =a55F
> -----END PGP SIGNATURE-----
>

---

From: Paul von Behren <[email-masked]>
Date: Mon, 19 Jun 2006 15:26:47 -0600

> Is anyone aware of any bidi SCSI commands?

Look at the OSD command set (on the T10 site).  I think all the OSD 
commands are bidi.  I think that's the only command set now with bidi 
commands.

Paul

>
> Eddy
>
> ----- Original Message ----- From: "William Studenmund" 
> <[email-masked]>
>> Each specific command has either no data phase (test unit ready), 
>> has  at most a data-out phase (Write for instance), at most a 
>> data-in  phase (Read), or is bidirectional.
>>
>> However it is that FCP controls data openings translates into R2Ts 
>> to  the iSCSI initiator.
>>
>> Take care,
>>
>> Bill

---

From: Neil Wanamaker <[email-masked]>
Date: Mon, 19 Jun 2006 23:00:04 -0700

At 02:26 PM 6/19/2006, Paul von Behren wrote:

>commands are bidi.  I think that's the only command set now with bidi commands.

Try XDWRITEREAD in SBC-2.

Neil Wanamaker
PMC-Sierra
100-2700 Production Way
Burnaby, BC

>>>-----END PGP SIGNATURE-----

Neil Wanamaker
[email-masked]
512.917.9712