Subject: [Ips] AD review of draft-ietf-ips-iser

From: Lars Eggert <[email-masked]>
Date: Thu, 12 Oct 2006 17:52:55 +0900

Hi,

please find the AD review of draft-ietf-ips-iser-05.txt below. In a  
nutshell: No major issues but a number of comments and nits.  
Depending on the amount of changes needed, an RFC Editor Note may be  
sufficient, or a new revision may be needed.

Lars

---<snip>---

   Has idnits (unused references, etc.) and boilerplate issues (some due
   to boilerplate changes during the too-long AD review - mea culpa).

INTRODUCTION, paragraph 12:
 >    Ko et. al.                Expires April  
2006                         1

   Nit: s/et./et/ everywhere

Section 7.3.12, paragraph 3:
 >    qualified with DataDescriptorReject which defines the Rejct  
buffer.

   Nit: s/Rejct/Reject/

Section 8.1.1.3, paragraph 3:
 >    CmdSN of the PDU sent by the intiator in this category is x,  
the PDU

   Nit: s/intiator/initiator/

Section 8.1.2, paragraph 7:
 >    (Implementatin note:  SCSI task timeout and recovery can be a

   Nit: s/Implementatin/Implementation/

Section 9.1, paragraph 4:
 >         The Opcode field identifies the type of iSER Messages:

   Are there IANA actions required for these type codes? IANA section is
   empty.

Section 13.2, paragraph 2:
 >    [DA] M. Chadalapaka et al., "Datamover Architecture for iSCSI",  
IETF
 >        Internet-draft, draft-ietf-ips-da-02.txt (work in progress),

   Not normative?

 >    [RDDPSEC] J. Pinkerton et al., "DDP/RDMAP Security", IETF Internet
 >        Draft draft-ietf-rddp-security-07.txt (work in progress),  
April
 >        2005

   Not normative?

-- 
Lars Eggert                                     NEC Network Laboratories

---

From: [email-masked]
Date: Thu, 12 Oct 2006 15:09:52 -0400

IPS WG and iSER Authors,

Let's get a new version of this draft, if for no other reason
than Lars *will* use RFC Editor Notes to put the spelling corrections
into the announcement that goes out to the world when the IESG
approves this draft ;-) ... and the authors should take the fact
that most of what Lars found is spelling and punctuation as a
significant backhanded compliment on the quality of this draft!

The [RDDPSEC] reference should be changed to normative, but the
[DA] reference needs to remain informative as the iSER draft is
supposed to be self-contained, and the DA draft will be published
as Informational.

Make sure the new version passes the idnits checker at:
	http://tools.ietf.org/tools/idnits/
*before* submitting it - an initial run of the checker on the
current draft will indicate what boilerplate updates are needed.

Thanks,
--David
----------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

> -----Original Message-----
> From: Lars Eggert [mailto:[email-masked]] 
> Sent: Thursday, October 12, 2006 4:53 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: AD review of draft-ietf-ips-iser
> 
> Hi,
> 
>  >    Ko et. al.                Expires April  2006
1
buffer.
>  >    CmdSN of the PDU sent by the intiator in this category is x, the
PDU
IETF
April
>    Not normative?

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips