Subject: RE: [Ips] Portal group discovery

From: "Dan Bar Dov" <[email-masked]>
Date: Tue, 3 Oct 2006 12:00:46 +0200

Let me try to explain how it can and does happen.
 
Our iSCSI target device is a "gateway" (or router). It provides FC SAN 
targets to iSCSI SAN. The iSCSI target name is generated from the FC WWNN.
 
When there are more then one such routers in the iSCSI SAN, it is possible and normal
for two (or more) iSCSI routers to expose the same FC target. This is not by mistake,
rather, it allows fail-over between such routers, where the initiator uses the multiple portals
for failover.
 
Given such a configuration, how does the initiator discover it?
option 1: the routers have "cluster awareness", one router can combine information from the whole
router cluster for sendTargets response.
option 2: the initiator is configured with multiple discovery addresses - one per router.
 
If option 2 is used, then the initiator needs to combine information discovered in discrete sendTargets
responses and produce portal groups.
 
My question relates specifically to that situation - it is not clear from the iSCSI spec, if such failover 
between portals (with the same pgt) discovered in discrete sendTargets responses is allowed.
 
Thanks,
Dan

________________________________

	From: Julian Satran [mailto:[email-masked]] 
	Sent: Friday, September 29, 2006 8:05 AM
	To: William Studenmund
	Cc: Dan Bar Dov; [email-masked]
	Subject: Re: [Ips] Portal group discovery

	This is not supposed to happen (getting partial data in a session) 
	If it happens it can be the result of a reconfiguration (between the two discovery sessions). 
	
	Julo 

	
William Studenmund <[email-masked]> 

29/09/06 05:31 

To
Dan Bar Dov <[email-masked]> 
cc
[email-masked] 
Subject
Re: [Ips] Portal group discovery

	-----BEGIN PGP SIGNED MESSAGE-----
	Hash: SHA1
	
	On Sep 28, 2006, at 7:59 AM, Dan Bar Dov wrote:
	
	> Is it allowed for an initiator to create a single portal group from  
	> information
	> collected from two (or more) sendTargets discovery sessions?
	
	I don't think you need two or more SendTargets discovery sessions.  
	You are supposed to hear about all portals in one SendTargets  
	response, so it's supposed to all be there.
	
	If you had very separate off-load cards, I could see that not being  
	followed. But then chances are you can't have a session span said  
	cards anyway. :-)
	
	Take care,
	
	Bill
	-----BEGIN PGP SIGNATURE-----
	Version: GnuPG v1.4.1 (Darwin)
	
	iD8DBQFFHIV8DJT2Egh26K0RAtMRAJ0aABo+mr7HRWRf5ClX44sB15uSAACglrL7
	oBLBpnH9PMvBjyu4RS+9dcc=
	=3dI5
	-----END PGP SIGNATURE-----
	
	_______________________________________________
	Ips mailing list
	[email-masked]
	https://www1.ietf.org/mailman/listinfo/ips

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: "Sandars, Ken" <[email-masked]>
Date: Tue, 3 Oct 2006 04:00:01 -0700

Dan,
 
The RFC is very clear about this. In your option 2 scenario, each router
which provides a path to the target MUST advertise an unique Target
Portal Group Tag (TPGT). The simplest reason is that you have no way to
join connections on different routers into the same iSCSI session.
 
The way you achieve this is implementation-specific.
 
HTH,
Ken

From: Dan Bar Dov [mailto:[email-masked]] 
Sent: Tuesday, 3 October 2006 20:01
To: [email-masked]
Cc: William Studenmund; John Hufferd; Julian Satran
Subject: RE: [Ips] Portal group discovery

Our iSCSI target device is a "gateway" (or router). It provides FC SAN 
targets to iSCSI SAN. The iSCSI target name is generated from the FC
WWNN.
 
When there are more then one such routers in the iSCSI SAN, it is
possible and normal
for two (or more) iSCSI routers to expose the same FC target. This is
not by mistake,
rather, it allows fail-over between such routers, where the initiator
uses the multiple portals
for failover.
 
Given such a configuration, how does the initiator discover it?
option 1: the routers have "cluster awareness", one router can combine
information from the whole
router cluster for sendTargets response.
option 2: the initiator is configured with multiple discovery addresses
- one per router.
 
If option 2 is used, then the initiator needs to combine information
discovered in discrete sendTargets
responses and produce portal groups.
 
My question relates specifically to that situation - it is not clear
from the iSCSI spec, if such failover 
between portals (with the same pgt) discovered in discrete sendTargets
responses is allowed.
 
Thanks,
Dan

	This is not supposed to happen (getting partial data in a
session) 
	If it happens it can be the result of a reconfiguration (between
the two discovery sessions). 
	
	Julo 

	

29/09/06 05:31 

To

	-----BEGIN PGP SIGNED MESSAGE-----
	Hash: SHA1

	> collected from two (or more) sendTargets discovery sessions?
	
	I don't think you need two or more SendTargets discovery
sessions.  
	You are supposed to hear about all portals in one SendTargets  
	response, so it's supposed to all be there.
	
	If you had very separate off-load cards, I could see that not
being  
	followed. But then chances are you can't have a session span
said  
	cards anyway. :-)
	
	Take care,
	
	Bill

---

From: Julian Satran <[email-masked]>
Date: Wed, 4 Oct 2006 21:03:36 +0200

Dan,

The portal groups have to share more than a target name - they'll have to 
have some common state (the CmdSN etc.).
If behind the routers there is only the "real" FC target I don't see how 
you can build a portal out of several routers. If the target function is 
in the "real target" it might as well know who all its front-ends are.

Julo

"Dan Bar Dov" <[email-masked]> 
03/10/06 12:00

To
<[email-masked]>
cc
"John Hufferd" <[email-masked]>, Julian Satran/Haifa/IBM@IBMIL, 
"William Studenmund" <[email-masked]>
Subject
RE: [Ips] Portal group discovery

 
When there are more then one such routers in the iSCSI SAN, it is possible 
and normal
for two (or more) iSCSI routers to expose the same FC target. This is not 
by mistake,
rather, it allows fail-over between such routers, where the initiator uses 
the multiple portals
for failover.
 
option 2: the initiator is configured with multiple discovery addresses - 
one per router.

My question relates specifically to that situation - it is not clear from 
the iSCSI spec, if such failover 
between portals (with the same pgt) discovered in discrete sendTargets 
responses is allowed.
 
Thanks,
Dan

This is not supposed to happen (getting partial data in a session) 
If it happens it can be the result of a reconfiguration (between the two 
discovery sessions). 

Julo 

To

Take care,

Bill

---

From: "Eddy Quicksall" <[email-masked]>
Date: Fri, 13 Oct 2006 17:24:47 -0400

Dan,

I see your failover problem similar to failover to a simple FC drive. It has two SCSI ports and, using dual loops, the initiator can fail over from one port to the other. If you expose two different TPGs then you similate exactly this method because a TPG is simply a SCSI Port.

Eddy
  ----- Original Message ----- 
  From: Julian Satran 
  To: Dan Bar Dov 
  Cc: [email-masked] ; William Studenmund ; John Hufferd 
  Sent: Wednesday, October 04, 2006 3:03 PM
  Subject: RE: [Ips] Portal group discovery

  Dan, 

  The portal groups have to share more than a target name - they'll have to have some common state (the CmdSN etc.). 
  If behind the routers there is only the "real" FC target I don't see how you can build a portal out of several routers. If the target function is in the "real target" it might as well know who all its front-ends are. 

  Julo 

        "Dan Bar Dov" <[email-masked]> 
        03/10/06 12:00 
       To <[email-masked]>  
              cc "John Hufferd" <[email-masked]>, Julian Satran/Haifa/IBM@IBMIL, "William Studenmund" <[email-masked]>  
              Subject RE: [Ips] Portal group discovery 

    
    
  When there are more then one such routers in the iSCSI SAN, it is possible aFrom [email-masked] Fri Oct 13 17:38:17 2006
From: "Eddy Quicksall" <[email-masked]>
To: "Dan Bar Dov" <[email-masked]>,
	"Julian Satran" <[email-masked]>
Subject: Re: [Ips] Portal group discovery
Date: Fri, 13 Oct 2006 17:24:47 -0400
Cc: [email-masked], William Studenmund <[email-masked]>,
	John Hufferd <[email-masked]>

This is a multi-part message in MIME format.
Dan,

I see your failover problem similar to failover to a simple FC drive. It has two SCSI ports and, using dual loops, the initiator can fail over from one port to the other. If you expose two different TPGs then you similate exactly this method because a TPG is simply a SCSI Port.

Eddy
  ----- Original Message ----- 
  From: Julian Satran 
  To: Dan Bar Dov 
  Cc: [email-masked] ; William Studenmund ; John Hufferd 
  Sent: Wednesday, October 04, 2006 3:03 PM
  Subject: RE: [Ips] Portal group discovery

  Dan, 

  The portal groups have to share more than a target name - they'll have to have some common state (the CmdSN etc.). 
  If behind the routers there is only the "real" FC target I don't see how you can build a portal out of several routers. If the target function is in the "real target" it might as well know who all its front-ends are. 

  Julo 

        "Dan Bar Dov" <[email-masked]> 
        03/10/06 12:00 
       To <[email-masked]>  
              cc "John Hufferd" <[email-masked]>, Julian Satran/Haifa/IBM@IBMIL, "William Studenmund" <[email-masked]>  
              Subject RE: [Ips] Portal group discovery 

    

    

  Thanks, 
  Dan 

------------------------------------------------------------------------------

  Julo 

              To Dan Bar Dov <[email-masked]>  
              cc [email-masked]  
              Subject Re: [Ips] Portal group discovery 

  -----BEGIN PGP SIGNED MESSAGE-----
  Hash: SHA1

  Take care,

  Bill

  -----END PGP SIGNATURE-----

------------------------------------------------------------------------------

---

From: "Eddy Quicksall" <[email-masked]>
Date: Fri, 13 Oct 2006 17:23:27 -0400

Dan,

Eddy
  ----- Original Message ----- 
  From: Julian Sat all be 
  there.<BR><BR>If you had very separate off-load cards, I could see that not 
  being &nbsp;<BR>followed. But then chances are you can't have a session span 
  said &nbsp;<BR>cards anyway. :-)<BR><BR>Take care,<BR><BR>Bill<BR>-----BEGIN 
  PGP SIGNATURE-----<BR>Version: GnuPG v1.4.1 
  (Darwin)<BR><BR>iD8DBQFFHIV8DJT2Egh26K0RAtMRAJ0aABo+mr7HRWRf5ClX44sB15uSAACglrL7<BR>oBLBpnH9PMvBjyu4RS+9dcc=<BR>=3dI5<BR>-----END 
  PGP 
  SIGNATURE-----<BR><BR>_______________________________________________<BR>Ips 
  mailing 
  list<BR>[email-masked]<BR>https://www1.ietf.org/mailman/listinfo/ips</FONT></TT><FONT 
  size=3><BR></FONT><BR>
  <P>
  <HR>

  <P></P>_______________________________________________<BR>Ips mailing 
  list<BR>[email-masked]<BR>https://www1.ietf.org/mailman/listinfo/ips<BR></BLOCKQUOTE></BODY></HTML>

------=_NextPart_000_003A_01C6EEEC.7B5B9590--

--=======93954614=
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

--=======93954614=--

---

From: "Eddy Quicksall" <[email-masked]>
Date: Fri, 13 Oct 2006 17:23:27 -0400

Dan,

Eddy
  ----- Original Message ----- 
  From: Julian Satran 
  To: Dan Bar Dov 
  Cc: [email-masked] ; William Studenmund ; John Hufferd 
  Sent: Wednesday, October 04, 2006 3:03 PM
  Subject: RE: [Ips] Portal group discovery

  Dan, 

  Julo 

       

    

    
    
  Thanks, 
  Dan 

  Julo 

              

  -----BEGIN PGP SIGNED MESSAGE-----
  Hash: SHA1

  Take care,

  Bill