Subject: RE: [Ips] Portal group discovery

From: "Dan Bar Dov" <[email-masked]>
Date: Tue, 3 Oct 2006 13:04:42 +0200

It is true that you cannot run two active connections in the 
same session when going through two routers.
However, is it not possible to have a single active connection, 
and fail-over to a new (or a standby) connection ?
 
Dan

________________________________

	From: Sandars, Ken [mailto:[email-masked]] 
	Sent: Tuesday, October 03, 2006 1:00 PM
	To: Dan Bar Dov; [email-masked]
	Cc: William Studenmund; John Hufferd; Julian Satran
	Subject: RE: [Ips] Portal group discovery

	Dan,
	 
	The RFC is very clear about this. In your option 2 scenario, each router which provides a path to the target MUST advertise an unique Target Portal Group Tag (TPGT). The simplest reason is that you have no way to join connections on different routers into the same iSCSI session.
	 
	The way you achieve this is implementation-specific.
	 
	HTH,
	Ken

________________________________

	From: Dan Bar Dov [mailto:[email-masked]] 
	Sent: Tuesday, 3 October 2006 20:01
	To: [email-masked]
	Cc: William Studenmund; John Hufferd; Julian Satran
	Subject: RE: [Ips] Portal group discovery

	Let me try to explain how it can and does happen.
	 
	Our iSCSI target device is a "gateway" (or router). It provides FC SAN 
	targets to iSCSI SAN. The iSCSI target name is generated from the FC WWNN.
	 
	When there are more then one such routers in the iSCSI SAN, it is possible and normal
	for two (or more) iSCSI routers to expose the same FC target. This is not by mistake,
	rather, it allows fail-over between such routers, where the initiator uses the multiple portals
	for failover.
	 
	Given such a configuration, how does the initiator discover it?
	option 1: the routers have "cluster awareness", one router can combine information from the whole
	router cluster for sendTargets response.
	option 2: the initiator is configured with multiple discovery addresses - one per router.
	 
	If option 2 is used, then the initiator needs to combine information discovered in discrete sendTargets
	responses and produce portal groups.
	 
	My question relates specifically to that situation - it is not clear from the iSCSI spec, if such failover 
	between portals (with the same pgt) discovered in discrete sendTargets responses is allowed.
	 
	Thanks,
	Dan

________________________________

		From: Julian Satran [mailto:[email-masked]] 
		Sent: Friday, September 29, 2006 8:05 AM
		To: William Studenmund
		Cc: Dan Bar Dov; [email-masked]
		Subject: Re: [Ips] Portal group discovery

		This is not supposed to happen (getting partial data in a session) 
		If it happens it can be the result of a reconfiguration (between the two discovery sessions). 
		
		Julo 

		
William Studenmund <[email-masked]> 

29/09/06 05:31 

To
Dan Bar Dov <[email-masked]> 
cc
[email-masked] 
Subject
Re: [Ips] Portal group discovery	

		-----BEGIN PGP SIGNED MESSAGE-----
		Hash: SHA1
		
		On Sep 28, 2006, at 7:59 AM, Dan Bar Dov wrote:
		
		> Is it allowed for an initiator to create a single portal group from  
		> information
		> collected from two (or more) sendTargets discovery sessions?
		
		I don't think you need two or more SendTargets discovery sessions.  
		You are supposed to hear about all portals in one SendTargets  
		response, so it's supposed to all be there.
		
		If you had very separate off-load cards, I could see that not being  
		followed. But then chances are you can't have a session span said  
		cards anyway. :-)
		
		Take care,
		
		Bill
		-----BEGIN PGP SIGNATURE-----
		Version: GnuPG v1.4.1 (Darwin)
		
		iD8DBQFFHIV8DJT2Egh26K0RAtMRAJ0aABo+mr7HRWRf5ClX44sB15uSAACglrL7
		oBLBpnH9PMvBjyu4RS+9dcc=
		=3dI5
		-----END PGP SIGNATURE-----
		
		_______________________________________________
		Ips mailing list
		[email-masked]
		https://www1.ietf.org/mailman/listinfo/ips

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: William Studenmund <[email-masked]>
Date: Tue, 3 Oct 2006 08:28:19 -0700

> and fail-over to a new (or a standby) connection ?

The problem is that putting both routers in the same Target Portal  
Group (TPG) means exactly that the initiator CAN have two active  
connections, in the same session, through the two portals.

So why do you want them in the same portal group? Why not just give  
each router a different TPG and be done with it?

Take care,

Bill