Subject: [Ips] target opcodes allowed for discovery sessions

From: "Paul Hughes" <[email-masked]>
Date: Mon, 20 Nov 2006 21:11:14 -0700

Is a target allowed to send an Asynchronous Message PDU to request a
logout of a discovery session?

Is a target allowed to send a NOP-In PDU to an initiator on a connection
that's part of a discovery session?  If so, should I assume that the TTT
must be 0xFFFFFFFF since the initiator isn't allowed to send a NOP-Out
PDU on a discovery session?

Thanks,
Paul

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: Julian Satran <[email-masked]>
Date: Tue, 21 Nov 2006 09:38:08 +0200

As I re-read the draft I can't find any text that forbids a target to send 
NOP-IN in a discovery session.
But that was definitely not the intent and don't be surprised if some 
initiator will drop your session.
Also Mallikarjun may want to mention this oversight in the implementation 
guide.

Julo

"Paul Hughes" <[email-masked]> 
21/11/06 06:11

To
"IP Storage Mailing List \(E-mail\)" <[email-masked]>
cc

Subject
[Ips] target opcodes allowed for discovery sessions

must be 0xFFFFFFFF since the initiator isn't allowed to send a NOP-Out PDU 
on a discovery session?

---

From: "Eddy Quicksall" <[email-masked]>
Date: Tue, 21 Nov 2006 11:46:37 -0500

When I look at 3.3 it says the target must reject all other requests. But I don't think a NOP-out is a request. Is there another part of the draft that says the initiator can't send a NOP-out during discovery?

Eddy
  ----- Original Message ----- 
  From: Julian Satran 
  To: Paul Hughes 
  Cc: IP Storage Mailing List (E-mail) 
  Sent: Tuesday, November 21, 2006 2:38 AM
  Subject: Re: [Ips] target opcodes allowed for discovery sessions

  As I re-read the draft I can't find any text that forbids a target to send NOP-IN in a discovery session. 
  But that was definitely not the intent and don't be surprised if some initiator will drop your session. 
  Also Mallikarjun may want to mention this oversight in the implementation guide. 

  Julo 

        "Paul Hughes" <[email-masked]> 
        21/11/06 06:11 
       To "IP Storage Mailing List \(E-mail\)" <[email-masked]>  
              cc  
              Subject [Ips] target opcodes allowed for discovery sessions 

  Is a target allowed to send an Asynchronous Message PDU to request a logout of a discovery session? 
  Is a target allowed to send a NOP-In PDU to an initiator on a connection that's part of a discovery session?  If so, should I assume that the TTT must be 0xFFFFFFFF since the initiator isn't allowed to send a NOP-Out PDU on a discovery session? 

  Thanks, 
  Paul 

------------------------------------------------------------------------------

---

From: "Sandars, Ken" <[email-masked]>
Date: Tue, 21 Nov 2006 13:23:13 -0800

Hello Gentlemen,

Section 12.21 SessionType states for a discovery session:

The only requests a target accepts in this type of session are a text
request with a SendTargets key and a logout request with reason "close
the session".

I can't find any text to prevent the target from sending a Nop-In or an
Async Message. I do remember a long discussion about whether to allow
the AM to request logout, but thought the answer was a loud "no, keep it
simple, drop the connection".

Cheers
Ken

________________________________

From: Eddy Quicksall [mailto:[email-masked]] 
Sent: Wednesday, 22 November 2006 03:47
To: Paul Hughes; Julian Satran
Cc: IP Storage Mailing List (E-mail)
Subject: Re: [Ips] target opcodes allowed for discovery sessions

When I look at 3.3 it says the target must reject all other requests.
But I don't think a NOP-out is a request. Is there another part of the
draft that says the initiator can't send a NOP-out during discovery?
 
Eddy

	----- Original Message ----- 
	From: Julian Satran <mailto:[email-masked]>  
	To: Paul Hughes <mailto:[email-masked]>  
	Cc: IP Storage Mailing List (E-mail) <mailto:[email-masked]>  
	Sent: Tuesday, November 21, 2006 2:38 AM
	Subject: Re: [Ips] target opcodes allowed for discovery sessions

	As I re-read the draft I can't find any text that forbids a
target to send NOP-IN in a discovery session. 
	But that was definitely not the intent and don't be surprised if
some initiator will drop your session. 
	Also Mallikarjun may want to mention this oversight in the
implementation guide. 
	
	Julo 

	21/11/06 06:11 

		To
		
		Subject

	Is a target allowed to send an Asynchronous Message PDU to
request a logout of a discovery session? 

	Is a target allowed to send a NOP-In PDU to an initiator on a
connection that's part of a discovery session?  If so, should I assume
that the TTT must be 0xFFFFFFFF since the initiator isn't allowed to
send a NOP-Out PDU on a discovery session? 

	Thanks, 
	Paul 

	________________________________