Subject: [Ips] New name for IG draft

From: "Mallikarjun C." <[email-masked]>
Date: Wed, 27 Dec 2006 20:51:30 -0800 (PST)

Lars and all,

I agree with Lars' review comment below, and would like to change the name of the current (iSCSI Implementer's Guide) to "iSCSI Corrections and Clarifications".  Please comment.

There were some issues with I-D publication process the last time I wanted to change the name of a file name for a post-00 revision.  I had to revert back to the original name (whatever I had for -00 revision).  I do not know if the trick is to change the title of the draft as Lars proposes but leave the file name (draft-ietf-ips....) unchanged.  David and/or Lars, please advise.

I had also updated the draft to cite RFC 3721 normatively, as Lars suggested below.

Thanks.

Mallikarjun

----- Original Message ----
From: Lars Eggert <[email-masked]>
To: Mallikarjun C. <[email-masked]>
Cc: [email-masked]
Sent: Thursday, December 14, 2006 1:14:52 AM
Subject: Re: [Ips] ips WG Last Call: iSCSI Implementer's Guide

Hi,

On Dec 11, 2006, at 18:34, Mallikarjun C. wrote:
> As far as volunteers for reviewing, we could request the  
> contributors at the end of the document to review.  David may have  
> already reviewed, based on his comments.  Julian Satran had some  
> offline feedback for me on TMF topics.  As the editor of the  
> document, I was sure that each of the topics were discussed in  
> detail (or at least clearly noted) on the list before I included  
> them in the doc.  Hope that gives you some reassurance.

it does, and I trust the WG to organize sufficient reviews.

>> whether it is merely the original text that can be
>> misunderstood or if there is a technical error in the original text.
>> (It already does in some cases.)
>
> Yes, I'd appreciate if you could point out where you think  
> additional clarifications could help.

I think I'd mostly like to see stronger language on "this section  
contains only a clarification of section X of RFC Y" vs. "this  
section replaces section X of RFC Y."

>> OK, so this document not only updates 3720, but also 3721, 3722 and
>> 3723? That needs to be stated in the document header and abstract.
>> (Also, 3721 needs to be normatively cited in this case.)
>
> We could.  My intent was to make it clear that this document  
> prevails whenever a subtle interpretation in future of one of these  
> RFCs differs from what's in this document.  Now that we are nearing  
> the end of the work on this document, we could delete some although  
> I personally am tempted to leave it this way....from what I can  
> think of today though, this doc updates 3720 and 3721, but does not  
> update 3722 and 3723.

I'd argue for being very clear about which sections of which RFCs  
this document clarifies/replaces and which are only cited for  
information. (Where things are being clarified or replaced, those  
RFCs need to be cited normatively.)

> 3721 is not a standards-track RFC and I wasn't sure if it needs to  
> be normatively cited as such.   But I could if that's the right  
> thing to do.

It is, see above. Any RFC (independent of its type) that is being  
clarified or replaced needs to be a normative reference. Please check  
if this introduces and downrefs according to RFC3967 that we need to  
handle.

>> Suggest to find a better title, because implementer's guides don't
>> typically update the base specification in a normative way. (Maybe
>> "iSCSI Corrections and Implementer's Guide" or something like that?)
>
> FIne by me.  How about "iSCSI Corrections, Clarifications,  
> Additions and Implementation Guidance", or is it too long?  If it  
> is, we could try "iSCSI Changes Based on Implementers' Experience"  
> or something like it.

The first is a bit too long, and I don't like the second :-)

"iSCSI Corrections and Clarifications?"

Lars

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: Lars Eggert <[email-masked]>
Date: Thu, 28 Dec 2006 11:40:53 +0200 (EET)

Hi,

there is no need to change the file name to change the title of the draft.

Lars
-- 
NEW EMAIL: [email-masked]
NEW MOBILE: +358 50 48 24461
NEW JABBER: [email-masked]

> -----Original Message-----
> From: ext Mallikarjun C.
> Received: Thu Dec 28 06:53:20 EET 2006
> To: IPS
> Subject: [Ips] New name for IG draft
> 
> Lars and all,
>