Subject: RE: [Ips] T10 data protection and iSCSI

From: "Robert Snively" <[email-masked]>
Date: Tue, 9 Jan 2007 09:04:43 -0800

T10 data protection simply changes slightly the content and length of
the data
fields sent to and received from the storage device.  It also modifies
the behavior of some commands, depending on the checking level
selected for the data protection mechanism.  That is described in the
T10 standard SBC-2 (and SBC-3, now in development).
 
It has no effect on the iSCSI protocol itself and is completely
independent
of RFC 3720.
 
Bob

________________________________

From: Vishal Study [mailto:[email-masked]] 
Sent: Monday, January 08, 2007 7:35 PM
To: ips
Subject: [Ips] T10 data protection and iSCSI

Hi:
 
What is relation between T10 data protection mechanism and iSCSI
protocol?

I couldn't find any reference to T10 data protection inside RFC 3720.

Pardon my ignorance if this is stupid question...I am quite new to the
storage area.
 
Thanks,
Vishal.
_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: "Vishal Study" <[email-masked]>
Date: Tue, 9 Jan 2007 12:42:11 -0800

Hi:

Thanks everyone for the guidance and pointers.

To summarize, T10 is a mechanism to ensure the integrity of data
read/written from/to the storage device. iSCSI is just *a* transport
mechanism to carry the data between initiator and target.

A followup question:
I understand that T10 mechanism adds extra 8 bytes to 512 byte block.
This operation is done before data is actually written to the storage
device (at the target in iSCSI terminology). Is this understanding
correct?

Thanks again,
Vishal.

On 1/9/07, Robert Snively <[email-masked]> wrote:
>
> T10 data protection simply changes slightly the content and length of the
> data
> It has no effect on the iSCSI protocol itself and is completely independent
> of RFC 3720.
>
> Bob
> What is relation between T10 data protection mechanism and iSCSI protocol?
>