Subject: [Ips] T10 data protection and iSCSI

From: "Vishal Study" <[email-masked]>
Date: Mon, 8 Jan 2007 19:34:53 -0800

Hi:

What is relation between T10 data protection mechanism and iSCSI protocol?

I couldn't find any reference to T10 data protection inside RFC 3720.

Pardon my ignorance if this is stupid question...I am quite new to the
storage area.

Thanks,
Vishal.
_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: "Eddy Quicksall" <[email-masked]>
Date: Tue, 9 Jan 2007 13:59:08 -0500

Being new to the storage area this can be very confusing at first. SCSI can be transported by many different types of transports. In fact more than one transport can be used to a single SCSI device. iSCSI is a transport layer and is described in RFC 3720. Most of what you read in SAM, SPC, SBC, etc are not related to the transport and hence you will generally not find references in RFC 3720 regarding those issues. Some will be related in which case you will see a reference to the appropriate transport protocol.

When reading the SCSI documents (not the transport documents) you will see a term "Service Delivery Subsystem". That includes what I call the transport layer.

Eddy
  ----- Original Message ----- 
  From: Vishal Study 
  To: ips 
  Sent: Monday, January 08, 2007 10:34 PM
  Subject: [Ips] T10 data protection and iSCSI

  Hi:

  Pardon my ignorance if this is stupid question...I am quite new to the storage area.

  Thanks,
  Vishal.

------------------------------------------------------------------------------