Subject: [Ips] Device Identification VPD Page for iSCSI Targets

From: "RAM SUNEE" <[email-masked]>
Date: Mon, 8 Jan 2007 07:20:21 -0800

All,

Can anyone please clarify me regarding, Device Identification VPD usage for
iSCSI Target.
What values should an iSCSI Target use for PROTOCOL_IDENTIFIER, ASSOCIATION
fields of Device Identification VPD response page.
I have noticed that iSCSI Targets are reportng to Initiators as "SCSI Disk
Device",is it correct behavior?
Isn't it supposed to be that iSCSI Target needs to report to Initiator as
"iSCSI Disk Device"

-RAM

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: "Eddy Quicksall" <[email-masked]>
Date: Mon, 8 Jan 2007 11:05:29 -0500

Referring to Table 296 of spc4r07a it seems the value should be 5 meaning 
iSCSI.

Eddy

---

From: <[email-masked]>
Date: Mon, 8 Jan 2007 10:11:16 -0600

The PROTOCOL_IDENTIFIER should be 5h if the identifier in the descriptor
is an iSCSI protocol specific identifier.

Thanks,
 
Jacob Cherian
Dell Inc.
Ph: (512) 723 3247

-----Original Message-----
From: Eddy Quicksall [mailto:[email-masked]] 
Sent: Monday, January 08, 2007 10:05 AM
To: RAM SUNEE; [email-masked]
Subject: Re: [Ips] Device Identification VPD Page for iSCSI Targets

Referring to Table 296 of spc4r07a it seems the value should be 5
meaning 
iSCSI.

Eddy

----- Original Message ----- 
From: "RAM SUNEE" <[email-masked]>
To: <[email-masked]>
Sent: Monday, January 08, 2007 10:20 AM
Subject: [Ips] Device Identification VPD Page for iSCSI Targets

> All,
>
> Can anyone please clarify me regarding, Device Identification VPD
usage 
> for

---

From: "RAM SUNEE" <[email-masked]>
Date: Mon, 8 Jan 2007 23:21:46 -0800

What about ASSOCIATION field. Is it supposed to be Logical Unit,Target port
or Target Device ??

-----Original Message-----
From: Eddy Quicksall [mailto:[email-masked]]
Sent: Monday, January 08, 2007 8:05 AM
To: RAM SUNEE; [email-masked]
Subject: Re: [Ips] Device Identification VPD Page for iSCSI Targets

Eddy

---

From: "Eddy Quicksall" <[email-masked]>
Date: Tue, 9 Jan 2007 12:28:09 -0500

This is more of a T10 question but my take is this: The ASSOCIATION field is 
simply used to show which entity the DESIGNATOR field is associated with. It 
has nothing to do with the PROTOCOL IDENTIFIER. You may get several 
Designators, one for each type. For iSCSI the PROTOCOL IDENTIFIER would 5 
for ASSOCIATION values of 01b or 10b when the PIV bit is set.

Eddy

---

From: "Elliott, Robert (Server Storage)" <[email-masked]>
Date: Wed, 10 Jan 2007 14:13:58 -0600

The Device Identification VPD page includes lots of identifiers.

1. ASSOCIATION=00b identifiers are related to the logical unit.  Since a
target device could have target ports of many protocols (e.g., iSCSI and
Fibre Channel), a logical unit is not considered to be tied to any protocol.
PIV=0 and the PROTOCOL IDENTIFIER field is considered reserved.  The same
set is reported regardless of the target port being used by the INQUIRY
command.

The VPD page should include one of these:
a) NAA identifer
b) EUI-64 based identifier
c) SCSI name string identifier containing "<iSCSI name starting with
iqn>,L,0x<16 digits>"
d) SCSI name string identifier not starting with iqn (e.g. "naa.6nnnn...")

2. ASSOCIATION=01b identifiers are related to the target port through which
the INQUIRY command is being run.  These are protocol-specific, so PIV=1 and
PROTOCOL IDENTIFIER=5h if the INQUIRY command is coming through an iSCSI
target port.

If it is an iSCSI target port, the VPD page should include both:
a) SCSI name string identifer containing "<iSCSI name>,t,0x<TPGT>"
b) Relative Target Port identifier containing an index 1..n for each target
port in the target device.

3. ASSOCIATION=10b identifiers are related to the target device; the same
set is reported regardless of the target port being used by the INQURIY
command.  Each protocol is allowed to contribute a target device name.

The VPD page should include:
a) SCSI name string identifier containing "<iSCSI name>"

It is valid to use either PIV=0 or to use PIV=1 and PROTOCOL IDENTIFIER=5h.
PIV=1 is probably better if the target device has ports using multiple
protocols and chooses to report a different target device name for each
protocol.  PIV=0 is probably better if it reports one common target device
name (which could be done in an iSCSI/FC combination target device if the
iSCSI name uses "naa." format).

--
Rob Elliott, [email-masked]
Hewlett-Packard Industry Standard Server Storage Advanced Technology
https://ecardfile.com/id/RobElliott

> Sent: Tuesday, January 09, 2007 11:28 AM
> > What about ASSOCIATION field. Is it supposed to be Logical 
> Unit,Target 
> > port
> > or Target Device ??
> >
> >
> >> Can anyone please clarify me regarding, Device 
> Identification VPD usage
> >> for
> >> iSCSI Target.
> >> I have noticed that iSCSI Targets are reportng to 
> Initiators as "SCSI 
> >> Disk