Subject: RE: [Ips] Use of TargetAddress conflict

From: [email-masked]
Date: Thu, 18 Jan 2007 17:14:48 -0500

I am aware this section is refering to SendTargets usage. Are you sure that bit of text did slip in there when someone was thinking about TargetName being used in the login? 
 
Dan

-----Original Message-----
From: Eddy Quicksall [mailto:[email-masked]]
Sent: Thursday, January 18, 2007 4:02 PM
To: Sullivan, Daniel; [email-masked]
Subject: Re: [Ips] Use of TargetAddress conflict

This is in response to the SendTargets command.

----- Original Message ----- 
From: [email-masked] 
To: [email-masked] ; [email-masked] 
Sent: Thursday, January 18, 2007 3:57 PM
Subject: RE: [Ips] Use of TargetAddress conflict

Is this trying to cover the case where TargetName is returned in reponse to a login? During login you don't have to return the TargetAddress.
 
Dan

-----Original Message-----
From: Eddy Quicksall [mailto:[email-masked]]
Sent: Thursday, January 18, 2007 3:27 PM
To: [email-masked]
Subject: [Ips] Use of TargetAddress conflict

Is there a conflict in wording here? Is the TargetAddress required?
 
Appendix D says "A target record begins with the TargetName text key, followed by a list of TargetAddress text keys". This implies that a TargetAddress must accompany each TargetName.
 
But a few paragraphs down it says "Each target record returned includes zero or more TargetAddress fields".

Eddy

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: "Eddy Quicksall" <[email-masked]>
Date: Thu, 18 Jan 2007 18:29:33 -0500

I remember when we were working on this. At that time some people didn't want to send the target address if it was already known by the initiator. In my target, I have an option to suppress the target address for cases when the target is behind a NAT device and hence I don't know "my address". So far every initiator I've tested with has handled it.

But today when I was going over the text it seemed to be questionable and I figured I would ask. If people think it is questionable text then I would ask Mallikarjun if he would clear it up in the implementation guide.

Eddy
  ----- Original Message ----- 
  From: [email-masked] 
  To: [email-masked] ; [email-masked] 
  Sent: Thursday, January 18, 2007 5:14 PM
  Subject: RE: [Ips] Use of TargetAddress conflict

  Dan

      ----- Original Message ----- 
      From: [email-masked] 
      To: [email-masked] ; [email-masked] 
      Sent: Thursday, January 18, 2007 3:57 PM
      Subject: RE: [Ips] Use of TargetAddress conflict

      Dan
        -----Original Message-----
        From: Eddy Quicksall [mailto:[email-masked]]
        Sent: Thursday, January 18, 2007 3:27 PM
        To: [email-masked]
        Subject: [Ips] Use of TargetAddress conflict

        Eddy

---

From: "Sandars, Ken" <[email-masked]>
Date: Thu, 18 Jan 2007 20:02:59 -0800

Hi Eddy,
 
I think it's clear that sending a SendTargets response containing a
target record with just the TargetName kvp is legal. While the utility
of such a response is questionable there are numerous reasons why a
target may choose to do this; you've already stated one.
 
I agree with Paul and don't see any need for the IG / C&C doc to expand
this.
 
Cheers
Ken

________________________________

From: Eddy Quicksall [mailto:[email-masked]] 
Sent: Friday, 19 January 2007 10:30
To: [email-masked]; [email-masked]
Subject: Re: [Ips] Use of TargetAddress conflict

I remember when we were working on this. At that time some people didn't
want to send the target address if it was already known by the
initiator. In my target, I have an option to suppress the target address
for cases when the target is behind a NAT device and hence I don't know
"my address". So far every initiator I've tested with has handled it.
 
But today when I was going over the text it seemed to be questionable
and I figured I would ask. If people think it is questionable text then
I would ask Mallikarjun if he would clear it up in the implementation
guide.
 
Eddy

	----- Original Message ----- 
	From: [email-masked] 
	To: [email-masked] ; [email-masked] 
	Sent: Thursday, January 18, 2007 5:14 PM
	Subject: RE: [Ips] Use of TargetAddress conflict

	I am aware this section is refering to SendTargets usage. Are
you sure that bit of text did slip in there when someone was thinking
about TargetName being used in the login? 
	 
	Dan

		-----Original Message-----
		From: Eddy Quicksall
[mailto:[email-masked]]
		Sent: Thursday, January 18, 2007 4:02 PM
		To: Sullivan, Daniel; [email-masked]
		Subject: Re: [Ips] Use of TargetAddress conflict

			----- Original Message ----- 
			From: [email-masked] 
			To: [email-masked] ; [email-masked]

			Is this trying to cover the case where
TargetName is returned in reponse to a login? During login you don't
have to return the TargetAddress.
			 
			Dan

				-----Original Message-----
				From: Eddy Quicksall
[mailto:[email-masked]]
				Sent: Thursday, January 18, 2007 3:27 PM
				To: [email-masked]
				Subject: [Ips] Use of TargetAddress
conflict

				Is there a conflict in wording here? Is
the TargetAddress required?
				 
				Appendix D says "A target record begins
with the TargetName text key, followed by a list of TargetAddress text
keys". This implies that a TargetAddress must accompany each TargetName.
				 
				But a few paragraphs down it says "Each
target record returned includes zero or more TargetAddress fields".

				Eddy