Subject: [Ips] Multiple IQNs for a single iSCSI initiator (for XEN)

From: Erez Zilber <[email-masked]>
Date: Wed, 04 Apr 2007 08:56:00 +0200

Hi,

We'd like to run an iSCSI initiator on XEN on dom0. It will login for
each VM with a different IQN. The LUs for each VM will be visible for
that VM only. My questions are:

    * We didn't find anything against that in the iSCSI spec. Is it
      really ok to do that?
    * This question is for the open-iscsi community - what is required
      in order to implement that in open-iscsi? Is there any plan to do
      that?

Thanks,
-- 

____________________________________________________________

Erez Zilber | 972-9-971-7689

Software Engineer, Storage Team

Voltaire – _The Grid Backbone_

__

www.voltaire.com <http://www.voltaire.com/>

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: Julian Satran <[email-masked]>
Date: Wed, 4 Apr 2007 13:19:55 +0300

Erez,

Not only it is allowed, it the way authors have envisioned separation 
through masking in iSCSI.
Unfortunately the mechanism is coarse grain and does not extend to 
applications (at least not in the common OSs) but it is available today.

Julo

Erez Zilber <[email-masked]> 
04/04/07 09:56

To
[email-masked], [email-masked]
cc
Eli Dorfman <[email-masked]>
Subject
[Ips] Multiple IQNs for a single iSCSI initiator (for XEN)

Hi,

Thanks,
-- 

Voltaire ? _The Grid Backbone_

__