Subject: [Ipsec] Issues regarding Traffic Selectors

From: khan wadood <[email-masked]>
Date: Sun, 31 Oct 2004 15:18:19 +0000 (GMT)

hi,

i have some issues regarding Traffic Selectors..

1- Is there any need for Traffic Selectors in
Transport mode ?? 

2- There is no 1 to 1 mapping between Traffic Selector
and SA in IKEv2, it seems to me that it is many to 1
mapping between Traffic Selectors and SA, is it so ??

3- If so then how we get the selector value for an SA
??

For example, if we send two TS's in IKE_AUTH exchange.

First TS agreed:
address range: 10.2.16.0 - 10.2.16.255
port: 0 - 65535 
Protocol ID: 0

second TS agreed:
address range: 10.2.0.0 - 10.2.255.255
port: 0 - 65535 
Protocol ID: 0

Both TS's maps to single SA (am i missing some
action??). Now, how selector will select the
respective SA from SAD ?? it might be confused ?? or
we have to repeat the SA entry with respect to each
selector.

thanks in advance

wadood 

________________________________________________________________________
Yahoo! India Matrimony: Find your life partner online
Go to: http://yahoo.shaadi.com/india-matrimony

_______________________________________________
Ipsec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipsec

---

From: "Srinivasa Rao Addepalli" <[email-masked]>
Date: Sun, 31 Oct 2004 13:16:31 -0800

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
khan wadood
Sent: Sunday, October 31, 2004 7:18 AM
To: [email-masked]
Subject: [Ipsec] Issues regarding Traffic Selectors

hi,

Transport mode ?? 

> Yes. Think of multi-homing scenarios.

> Yes, if you put it that way.

??

First TS agreed:

port: 0 - 65535 

Protocol ID: 0

second TS agreed:

port: 0 - 65535 

Protocol ID: 0

selector.

> Note that there is only one SPI, meaning that there is only one SA. It is
local implementation matter on how this can be stored. 

thanks in advance

wadood 

Ipsec mailing list

[email-masked]