Subject: [IPsec] New WG Last Call for draft-ietf-ipsecme-dh-checks

From: Paul Hoffman <[email-masked]>
Date: Sat, 20 Apr 2013 07:41:56 -0700

Greetings again. The authors of the DH checks draft have submitted a significantly-revised draft based on the input of the WG Last Call. See http://www.ietf.org/rfcdiff?url2=draft-ietf-ipsecme-dh-checks-02 for the difference.

Based on the amount of new material, I want to have another (albeit shorter) WG Last Call for this new version of the draft. Please send comments to the WG by Monday, April 29. Note that if you did not participate in the earlier WG Last Call, you are strongly urged to do so now: the more review we get for our WG drafts, the better. Having said that, it would be useful to hear from those who commented in the first WG Last Call to say whether the changes are sufficient.

--Paul Hoffman

---

From: Michael Richardson <[email-masked]>
Date: Sun, 21 Apr 2013 16:13:57 -0400

>>>>> "Paul" == Paul Hoffman <[email-masked]> writes:
    Paul> Greetings again. The authors of the DH checks draft have
    Paul> submitted a significantly-revised draft based on the input of
    Paul> the WG Last Call. See
    Paul> http://www.ietf.org/rfcdiff?url2=draft-ietf-ipsecme-dh-checks-02
    Paul> for the difference.

I don't see my suggested text for section 2.2, or any change to the text.

At this point, I understand what section 2.2 is trying to say
sufficiently well that I can't really tell if the existing text is clear
enough for me.

    Paul> Based on the amount of new material, I want to have another
    Paul> (albeit shorter) WG Last Call for this new version of the
    Paul> draft. Please send comments to the WG by Monday, April

The additional material seems clear enough to me.

-- 
]               Never tell me the odds!                 | ipv6 mesh networks [ 
]   Michael Richardson, Sandelman Software Works        | network architect  [ 
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Johannes Merkle <[email-masked]>
Date: Mon, 22 Apr 2013 13:58:30 +0200

> Based on the amount of new material, I want to have another (albeit shorter) WG Last Call for this new version of the draft. Please send comments to the WG by Monday, April 29. Note that if you did…

Please include draft-merkle-ikev2-ke-brainpool as informative reference and include in Section 2.3 a reference to it.
Our draft defines new elliptic curves for IKEv2 for which the checks specified in Section 2.3 are applicable and is
about to be published as RFC (RFC Ed Queue). This means that our draft will update the registry before your draft does.

Otherwise, our draft would have to wait for your draft to be published which would introduce a considerable delay. For
this reason, IANA has requested from us to resolve the current deadlock.

-- 
Johannes

---

From: Tero Kivinen <[email-masked]>
Date: Mon, 22 Apr 2013 15:15:35 +0300

Paul Hoffman writes:
> Based on the amount of new material, I want to have another (albeit
> shorter) WG Last Call for this new version of the draft. Please send
> comments to the WG by Monday, April 29. Note that if you did not
> participate in the earlier WG Last Call, you are strongly urged to
> do so now: the more review we get for our WG drafts, the better.
> Having said that, it would be useful to hear from those who
> commented in the first WG Last Call to say whether the changes are
> sufficient. 

Seems good for me.
-- 
[email-masked]

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 22 Apr 2013 10:16:42 -0700

> this reason, IANA has requested from us to resolve the current deadlock.

I'm confused. Could you send a copy of the message from IANA asking for you to "resolve the current deadlock"? I don't see any deadlock at all, so this might best be done by simply telling IANA to not block yours.

This is not to say that draft-ietf-ipsecme-dh-checks should not list the eventual RFC for draft-merkle-ikev2-ke-brainpool; it should. However, us adding that to the current draft should have no effect on IANA.

As shepherd for draft-ietf-ipsecme-dh-checks, I'm willing to deal with IANA on this.

--Paul Hoffman