Subject: Re: [IPsec] Signature authentication in IKEv2

From: Johannes Merkle <[email-masked]>
Date: Mon, 15 Apr 2013 14:01:47 +0200

Tero Kivinen wrote on 12.03.2013 20:56:
> In the meeting I did not remember what was the name the PKIX had for
> the signature blob, and in my slides written at midnight Sunday
> evening, I said SubjectPublicKeyInfo, so here I am to provide some
> correct information...
> 
> So the thing is what is both in the signatureAlgorithm and
> SubjectPublicKeyInfo, i.e. the AlgorithmI?dentifier:
> 
>    AlgorithmIdentifier  ::=  SEQUENCE  {
>         algorithm               OBJECT IDENTIFIER,
>         parameters              ANY DEFINED BY algorithm OPTIONAL  }
> 
> 
> I.e where there algorithm is the OID we currently have in the
> draft-kivinen-ipsecme-signature-auth, and the parameters is the one is
> required to get the RSASSA-PSS to work.
> 
> Anybody has objection to do it this way?
> 

I agree with your proposal.

It has become quiet around this draft. I really think, it is an important simplification of IKEv2 in the long tun. When
can we expect the new revision?

-- 
Johannes

---

From: Tero Kivinen <[email-masked]>
Date: Mon, 15 Apr 2013 16:51:36 +0300

Johannes Merkle writes:
> It has become quiet around this draft. I really think, it is an
> important simplification of IKEv2 in the long tun. When 

Last week I would have said by the Thursday of last week, but then I
ended up wasting more than a day trying to get the xml2rfc working
(and trying the new version, and accidently updating my desktop etc),
so I only managed to put out the first 2 of my drafts. I will try to
update this tomorrow... 
-- 
[email-masked]