Subject: Re: [IPsec] One comment to this draft//Fwd: I-D Action: draft-ietf-ipsecme-ad-vpn-problem-06.txt

From: Vishwas Manral <[email-masked]>
Date: Mon, 3 Jun 2013 08:45:10 -0700

Hi Praveen,

I think the idea is to be able to have QoS in a way that the traffic from
one spoke cannot overwhelm the Hub and lead to issues there. We need to
maintain QoS policies per spoke (or spoke type) on the Hub, as well as to
be able to push some QoS policies to the spokes from the Hub.

Do I make sense?

Thanks,
Vishwas

On Mon, May 6, 2013 at 9:30 AM, Praveen Sathyanarayan <[email-masked]
> wrote:

>  Hi Toby,
>
>  When you say QoS policy, could you elaborate what it really means? I
> mean what kind of information does it need to have or exchanged?
>
>  -- Praveen
>
>   From: Toby Mao <[email-masked]>
> Date: Sunday, May 5, 2013 8:49 AM
> To: Yoav Nir <[email-masked]>
> Cc: IPsecme WG <[email-masked]>, "[email-masked]" <[email-masked]>, Paul
> Hoffman <[email-masked]>
> Subject: Re: [IPsec] One comment to this draft//Fwd: I-D Action:
> draft-ietf-ipsecme-ad-vpn-problem-06.txt
>
>   Hi Yoav.
>
>          The QoS implementations in ADVPN are :
>
> 1.        In the star topology,  the QoS policy is implemented
> individually for each spoke in the hub, all the traffic through the Hub can
> be regulated by QoS policy in the hub.
>
> 2.       In the full mesh topology,  when the two spokes establish the
> direct connection, each spoke should also have the QoS policy for each
> other. The QoS policy can be obtained from the Hub, or other control device
> ,  which has the individual QoS policy for each spoke.
>
> I think your understanding is the same as the QoS implementation in the
> full mesh topology.
>
> Toby
>
>
> On Fri, May 3, 2013 at 4:11 AM, Yoav Nir <[email-masked]> wrote:
>
>> Hi Toby.
>>
>>  Let's see if I understand the issue. I'll describe this with an
>> example. Please let me know if I got it.
>>
>>  Suppose we have satellite gateways A, B, C, D, and E. A through D each
>> have a bandwidth of 10 Mb/s, while E has 20 Mb/s.
>>
>>  The center gateway, Z, has plenty of bandwidth and the appropriate QoS
>> policy. So if A, B, and C are simultaneously sending traffic to E through
>> Z, Z will do the QoS magic (maybe by dropping packets or playing with TCP
>> ACKs) to make sure the QoS goals are met.
>>
>>  Now add ADVPN to the mix. A and E discover each other, and are able to
>> bypass Z. Initially A had no IPsec policy about E. There's no reason to
>> think it had a QoS policy about E, and the same is true in the other
>> direction. Unless the QoS policy from Z somehow gets transmitted to the
>> satellites, they may reach congestion and have the QoS targets miss.
>>
>>  So whereas before ADVPN the center gateway could be counted on to
>> handle the QoS (because everything goes through it), as soon as you add
>> ADVPN, that policy has to be enforced on the spokes, or not at all.
>>
>>  I'm not sure whether we can or should solve this issue as part of
>> AD-VPN, but I want to make sure that we understand the issue.
>>
>>  Yoav
>>
>>   On May 2, 2013, at 6:02 PM, Toby Mao <[email-masked]> wrote:
>>
>>
>>  On Sat, Apr 27, 2013 at 10:57 PM, Paul Hoffman <[email-masked]>wrote:
>>
>>> These requirements might be useful to add in the next draft, but they
>>> need to be refined.
>>>
>>> On Apr 26, 2013, at 8:10 PM, Toby Mao <[email-masked]> wrote:
>>>
>>> > The ADVPN solution SHOULD be able to implement Quality of Service
>>> (QoS) to regulate the traffic in the ADVPN topology.
>>>
>>>  Why is this statement needed? Do you see situations where an ADVPN
>>> solution would be *prevented* from implementing some sort of QoS because it
>>> was an ADVPN?
>>>
>>
>>   [Toby]: There is no situation that ADVPN solution could be prevented
>> from implementing Qos. Actually, Qos is crucial on ADVPN, such as sharing
>> network bandwidth, meeting the application latency requirement. Especially
>> in the Hub, for each spoke, the Qos policy should be implemented
>> individually , because different spoke has different link speed and data
>> processing capability. Thus, in the ADVPN solution, the small spoke can not
>> be overrun by hub by sending too much traffic, also the spoke which has
>> large bandwidth cannot hog the hub's resources and starve other spokes. In
>> addition, a unique Qos policy for each spoke in the hub could be cumbersome
>> for administrator, some improvement could be implemented, such as the
>> spokes with the same bandwidth can belong to the same group, the Qos policy
>> can be implemented on a basis of group.
>>
>>>
>>> > ADVPN peer SHOULD NOT send excessive traffic to the other members of
>>> ADVPN.
>>>
>>>  How would you define "excessive"? Where would that measurement be done?
>>
>>
>> [Toby]  The traffic to the ADVPN peer exceeding the actual peer bandwidth
>> can be defined as "excessive". To solve this problem, the other ADVPN peer
>> should apply Qos policy for this ADVPN peer.
>>
>>  > The traffic for each ADVPN peer CAN be measured individually for
>>> shaping and policing.
>>>
>>>  Why is this statement needed? Do you see situations where an ADVPN
>>> solution would be *prevented* from measuring individually?
>>
>>
>> [Toby]  The reason is explained in the first answer.
>>
>>>
>>> --Paul Hoffman
>>
>>
>>
>>
>>  Email secured by Check Point
>>
>> _______________________________________________
>> IPsec mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/ipsec
>>
>>
>>
>
> _______________________________________________
> IPsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipsec
>
>

---

From: Praveen Sathyanarayan <[email-masked]>
Date: Tue, 4 Jun 2013 00:23:02 +0000

HI Vishwas,

I understand the use of QOS and I do think it would be a nice feature. But I am trying to see how this is specific to AD-VPN. I feel this is applicable for regular VPN as well (in Hub and Spoke topology or any type of topology).  AD-VPN is about auto-discovering spokes/gateway/entity and establishing a direct connectivity. To me AD-VPN is, an extension to existing IPSec solution.  So, IMO, QoS requirement should be solved out side of AD-VPN.

What do you think?

-- Praveen

From: Vishwas Manral <[email-masked]<mailto:[email-masked]>>
Date: Monday, June 3, 2013 8:45 AM
To: Praveen Sathyanarayan <[email-masked]<mailto:[email-masked]>>
Cc: Toby Mao <[email-masked]<mailto:[email-masked]>>, Yoav Nir <[email-masked]<mailto:[email-masked]>>, IPsecme WG <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Paul Hoffman <[email-masked]<mailto:[email-masked]>>
Subject: Re: [IPsec] One comment to this draft//Fwd: I-D Action: draft-ietf-ipsecme-ad-vpn-problem-06.txt

Hi Praveen,

I think the idea is to be able to have QoS in a way that the traffic from one spoke cannot overwhelm the Hub and lead to issues there. We need to maintain QoS policies per spoke (or spoke type) on the Hub, as well as to be able to push some QoS policies to the spokes from the Hub.

Do I make sense?

Thanks,
Vishwas

On Mon, May 6, 2013 at 9:30 AM, Praveen Sathyanarayan <[email-masked]<mailto:[email-masked]>> wrote:
Hi Toby,

When you say QoS policy, could you elaborate what it really means? I mean what kind of information does it need to have or exchanged?

-- Praveen

From: Toby Mao <[email-masked]<mailto:[email-masked]>>
Date: Sunday, May 5, 2013 8:49 AM
To: Yoav Nir <[email-masked]<mailto:[email-masked]>>
Cc: IPsecme WG <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Paul Hoffman <[email-masked]<mailto:[email-masked]>>
Subject: Re: [IPsec] One comment to this draft//Fwd: I-D Action: draft-ietf-ipsecme-ad-vpn-problem-06.txt

Hi Yoav.

1.        In the star topology,  the QoS policy is implemented individually for each spoke in the hub, all the traffic through the Hub can be regulated by QoS policy in the hub.

2.       In the full mesh topology,  when the two spokes establish the direct connection, each spoke should also have the QoS policy for each other. The QoS policy can be obtained from the Hub, or other control device ,  which has the individual QoS policy for each spoke.

I think your understanding is the same as the QoS implementation in the full mesh topology.

Toby

On Fri, May 3, 2013 at 4:11 AM, Yoav Nir <[email-masked]<mailto:[email-masked]>> wrote:
Hi Toby.

Let's see if I understand the issue. I'll describe this with an example. Please let me know if I got it.

Suppose we have satellite gateways A, B, C, D, and E. A through D each have a bandwidth of 10 Mb/s, while E has 20 Mb/s.

The center gateway, Z, has plenty of bandwidth and the appropriate QoS policy. So if A, B, and C are simultaneously sending traffic to E through Z, Z will do the QoS magic (maybe by dropping packets or playing with TCP ACKs) to make sure the QoS goals are met.

Now add ADVPN to the mix. A and E discover each other, and are able to bypass Z. Initially A had no IPsec policy about E. There's no reason to think it had a QoS policy about E, and the same is true in the other direction. Unless the QoS policy from Z somehow gets transmitted to the satellites, they may reach congestion and have the QoS targets miss.

So whereas before ADVPN the center gateway could be counted on to handle the QoS (because everything goes through it), as soon as you add ADVPN, that policy has to be enforced on the spokes, or not at all.

I'm not sure whether we can or should solve this issue as part of AD-VPN, but I want to make sure that we understand the issue.

Yoav

On May 2, 2013, at 6:02 PM, Toby Mao <[email-masked]<mailto:[email-masked]>> wrote:

On Sat, Apr 27, 2013 at 10:57 PM, Paul Hoffman <[email-masked]<mailto:[email-masked]>> wrote:
These requirements might be useful to add in the next draft, but they need to be refined.

On Apr 26, 2013, at 8:10 PM, Toby Mao <[email-masked]<mailto:[email-masked]>> wrote:

> The ADVPN solution SHOULD be able to implement Quality of Service (QoS) to regulate the traffic in the ADVPN topology.

Why is this statement needed? Do you see situations where an ADVPN solution would be *prevented* from implementing some sort of QoS because it was an ADVPN?

 [Toby]: There is no situation that ADVPN solution could be prevented from implementing Qos. Actually, Qos is crucial on ADVPN, such as sharing network bandwidth, meeting the application latency requirement. Especially in the Hub, for each spoke, the Qos policy should be implemented individually , because different spoke has different link speed and data processing capability. Thus, in the ADVPN solution, the small spoke can not be overrun by hub by sending too much traffic, also the spoke which has large bandwidth cannot hog the hub's resources and starve other spokes. In addition, a unique Qos policy for each spoke in the hub could be cumbersome for administrator, some improvement could be implemented, such as the spokes with the same bandwidth can belong to the same group, the Qos policy can be implemented on a basis of group.

> ADVPN peer SHOULD NOT send excessive traffic to the other members of ADVPN.

[Toby]  The traffic to the ADVPN peer exceeding the actual peer bandwidth can be defined as "excessive". To solve this problem, the other ADVPN peer should apply Qos policy for this ADVPN peer.

> The traffic for each ADVPN peer CAN be measured individually for shaping and policing.

Why is this statement needed? Do you see situations where an ADVPN solution would be *prevented* from measuring individually?

--Paul Hoffman

_______________________________________________
IPsec mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ipsec

_______________________________________________
IPsec mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ipsec

---

From: Toby Mao <[email-masked]>
Date: Thu, 6 Jun 2013 23:31:27 +0800

Hi Praveen:

      I agree the primary goal of ADVPN solution is to establish the direct
connectivity in the full mesh topology. However,  in the
 draft-ietf-ipsecme-ad-vpn-problem,  there are some requirements such as
multicast, L3VPN, etc. which seems to “not so important” in the ADVPN, but
also need to be defined . The use of QoS is this case.

    In the current IPsec VPN solution for Hub-Spoke topology and full-mesh
topology, we need to maintain QoS policy per peer. This QoS policy usually
defines the traffic policing, general traffic shaping or rate limit
control. In the Hub-Spoke topology, the QoS policy for the spoke can be
effective because all the traffic go through the hub.

In the ADVPN, if spoke A obtains the spoke B’s information, such as peer
address, route information etc. to establish the direct connectivity, the
QoS policy for this spoke should also  be included if needed. Thus, after
the connection is setup, the traffic from Spoke A to Spoke B can not be
overrun.

The new requirement 15 added in the updated draft is ok for me.

Regard,

Toby

On Tue, Jun 4, 2013 at 8:23 AM, Praveen Sathyanarayan <[email-masked]

>  HI Vishwas,
>
>  I understand the use of QOS and I do think it would be a nice feature.
> But I am trying to see how this is specific to AD-VPN. I feel this is
> applicable for regular VPN as well (in Hub and Spoke topology or any type
> of topology).  AD-VPN is about auto-discovering spokes/gateway/entity and
> establishing a direct connectivity. To me AD-VPN is, an extension to
> existing IPSec solution.  So, IMO, QoS requirement should be solved out
> side of AD-VPN.
>
>  What do you think?
>
>  -- Praveen
>
>   From: Vishwas Manral <[email-masked]>
> To: Praveen Sathyanarayan <[email-masked]>
> Cc: Toby Mao <[email-masked]>, Yoav Nir <[email-masked]>, IPsecme
> WG <[email-masked]>, "[email-masked]" <[email-masked]>, Paul Hoffman <
> [email-masked]>
>
> On Mon, May 6, 2013 at 9:30 AM, Praveen Sathyanarayan <
> [email-masked]> wrote:
>
>>  Hi Toby,
>>
>>> [Toby]  The traffic to the ADVPN peer exceeding the actual peer
>>> bandwidth can be defined as "excessive". To solve this problem, the other
>>> ADVPN peer should apply Qos policy for this ADVPN peer.
>>>