Subject: [IPsec] Fwd: I-D Action: draft-nir-ipsecme-chacha20-poly1305-00.txt

From: Yoav Nir <[email-masked]>
Date: Tue, 21 Jan 2014 16:44:58 +0000

Hi,

Continuing the conversation about "spare algorithms" in case cryptanalytical results are found against AES, I've submitted this document, modeled roughly around AGL's document for TLS with the same algorithms.

Reviews and comments would be greatly appreciated, as well as anyone checking my examples.

Thanks

Yoav

Begin forwarded message:

> From: <[email-masked]>
> Subject: I-D Action: draft-nir-ipsecme-chacha20-poly1305-00.txt
> Date: January 21, 2014 4:08:32 PM GMT+02:00
> To: <[email-masked]>
> Reply-To: <[email-masked]>
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
>        Title           : ChaCha20 and Poly1305 and their use in IPsec
>        Author          : Yoav Nir
> 	Filename        : draft-nir-ipsecme-chacha20-poly1305-00.txt
> 	Pages           : 16
> 	Date            : 2014-01-21
> 
> Abstract:
>   This document describes the use of the ChaCha20 stream cipher in
>   IPsec, as well as the use of the Poly1305 authenticator, both as
>   stand-alone algorithms, and as a combined mode AEAD algorithm.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-nir-ipsecme-chacha20-poly1305/
> 
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-nir-ipsecme-chacha20-poly1305-00
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/

---

From: Yaron Sheffer <[email-masked]>
Date: Tue, 21 Jan 2014 19:24:15 +0200

Hi Yoav,

Thank you for submitting this draft. I am all in favor of having a 
credible "standby algorithm", and I'm hearing that ChaCha20 is a worthy 
candidate.

What worries me in the current instance is that the definition of the 
algorithm is fluffy. This could be old-fashioned of me, but I think an 
SDO should produce standards, i.e. written documents that allow a 
developer to implement an algorithm without having to resort to reverse 
engineering of libraries. (I do applaud the test vectors though).

I would recommend that you (or someone) publish a CFRG document that we 
can use as a normative reference here. With respect, none of the DJB 
documents cited here (and note that the references themselves are kinda 
incomplete) reads as a formal definition of the algorithm.

Thanks,
	Yaron

On 01/21/2014 06:44 PM, Yoav Nir wrote:
> _______________________________________________
> IPsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipsec
>