Subject: [IPsec] I-D Action: draft-ietf-ipsecme-safecurves-01.txt

From: [email-masked]
Date: Mon, 01 Feb 2016 15:18:46 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the IP Security Maintenance and Extensions Working Group of the IETF.

        Title           : Curve25519 and Curve448 for IKEv2 Key Agreement
        Authors         : Yoav Nir
                          Simon Josefsson
	Filename        : draft-ietf-ipsecme-safecurves-01.txt
	Pages           : 5
	Date            : 2016-02-01

Abstract:
   This document describes the use of Curve25519 and Curve448 for
   ephemeral key exchange in the Internet Key Exchange (IKEv2) protocol.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ipsecme-safecurves/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-ipsecme-safecurves-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-ipsecme-safecurves-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Yoav Nir <[email-masked]>
Date: Tue, 2 Feb 2016 01:26:22 +0200

Hi.

Differences in this version:
 - Changed the reference from CFRG draft to RFC 7748
 - A few editorial fixes

The analogous TLS draft (draft-ietf-tls-rfc4492bis) is still waiting for CFRG to complete its work on signatures. 

In my opinion, we don’t have to wait. The CFRG EdDSA draft will provide formats and OIDs (I hope). RFC 7427 allows us to use signatures with only an OID and a format without needing to assign numbers or invent IKE-specific formats. We might want to mention the recommended algorithm (Ed25519 and Ed448, but not the “ph” versions) in RFC 4307bis, but I don’t think we need it here.

Given this, I think it could be time to progress this draft.

Yoav

> On 2 Feb 2016, at 1:18 AM, [email-masked] wrote:
> 
> 
> _______________________________________________
> IPsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipsec