Subject: [IPsec] I-D Action: draft-ietf-ipsecme-safecurves-02.txt

From: [email-masked]
Date: Thu, 04 Aug 2016 14:56:15 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the IP Security Maintenance and Extensions of the IETF.

        Title           : Curve25519 and Curve448 for IKEv2 Key Agreement
        Authors         : Yoav Nir
                          Simon Josefsson
	Filename        : draft-ietf-ipsecme-safecurves-02.txt
	Pages           : 7
	Date            : 2016-08-04

Abstract:
   This document describes the use of Curve25519 and Curve448 for
   ephemeral key exchange in the Internet Key Exchange (IKEv2) protocol.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ipsecme-safecurves/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-ipsecme-safecurves-02

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-ipsecme-safecurves-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Yoav Nir <[email-masked]>
Date: Fri, 5 Aug 2016 01:07:25 +0300

Hi.

New in this version:
 - A few textual changes in the Introduction (suggested by Tero)
 - Numerical example in Appendix A for Curve25519.

I used OpenSSL code to generate the example. I didn’t find similar code for Curve448. Hopefully I will be able to fill this gap before publication. Currently OpenSSL does not support this, but there is an open issue ([1]).

Yoav

[1] https://github.com/openssl/openssl/issues/1398

> On 5 Aug 2016, at 12:56 AM, [email-masked] wrote:
> 
> 
> _______________________________________________
> IPsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipsec

---

From: Tero Kivinen <[email-masked]>
Date: Mon, 8 Aug 2016 15:51:05 +0300

>  - A few textual changes in the Introduction (suggested by Tero)

You seemed to skip my proposed changes for the IANA considerations
section. As an IANA expert, I would be more happy with the actual
table version of the allocations there, as it makes IANAs work easier,
which means there will be less changes for mistakes...

I.e., I would still propose changing the IANA Considerations section
to have the table format of allocations:

  Number   Name          Recipient Tests        Reference
  ------   ----          ---------------        ---------
  TBA1     Curve25519    [RFCxxxx], Sec 3.2     [RFCxxxx]
  TBA2     Curve448      [RFCxxxx], Sec 3.2     [RFCxxxx]

>  - Numerical example in Appendix A for Curve25519.

This is good... Hopefully someone can verify that using some other
code than openssl... 
-- 
[email-masked]

---

From: Yoav Nir <[email-masked]>
Date: Mon, 8 Aug 2016 19:46:20 +0300

> On 8 Aug 2016, at 3:51 PM, Tero Kivinen <[email-masked]> wrote:
> 
> Yoav Nir writes:
>> Hi.
>> 
>> New in this version:

OK.

> code than openssl… 

That would be great. Also, I’m still looking for code I can use for Curve448. OpenSSL won’t have that for release 1.1.0, only the release after that[1].

Yoav