Subject: [IPsec] AD review of draft-ietf-ipsecme-tcp-encaps

From: Kathleen Moriarty <[email-masked]>
Date: Thu, 9 Mar 2017 12:39:14 -0500

Hello,

Thank you for your work on draft-ietf-ipsecme-tcp-encaps.  It's a well
written draft and I just have one question.

Section 7: Why is SHA-1 used?  If this is a result of the protocol and
prior RFCs, please include a reference. And an explanation on list
would be helpful (pointer is fine if this was already discussed.

-- 

Best regards,
Kathleen

---

From: Tommy Pauly <[email-masked]>
Date: Thu, 09 Mar 2017 09:47:48 -0800

Hi Kathleen,

Yes, this is referring to how the existing NAT detection works in IKEv2:

https://tools.ietf.org/html/rfc7296

Section 2.23. NAT Traversal

   o  The data associated with the NAT_DETECTION_SOURCE_IP notification
      is a SHA-1 digest of the SPIs (in the order they appear in the
      header), IP address, and port from which this packet was sent.

We can add a pointer to the section of the RFC.

Thanks,
Tommy

> On Mar 9, 2017, at 9:39 AM, Kathleen Moriarty <[email-masked]> wrote:
> 
> Hello,
> 
> _______________________________________________
> IPsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipsec

---

From: Kathleen Moriarty <[email-masked]>
Date: Thu, 9 Mar 2017 13:48:22 -0500

> We can add a pointer to the section of the RFC.

Great.  Please let me know when that is done and I can start IETF last
call.  Does the WG want me to start that right away or to wait until
after Chicago?  I'm inclined to start it right away and have it on the
first telechat after.

Thanks,
Kathleen

-- 

Best regards,
Kathleen

---

From: Tommy Pauly <[email-masked]>
Date: Sun, 12 Mar 2017 12:11:46 -0700

Hi Kathleen,

I've just posted a new version to fix some minor nits and add a reference for the SHA-1 digest used for NAT detection:
https://www.ietf.org/id/draft-ietf-ipsecme-tcp-encaps-09.txt

>From my perspective, I think starting a IETF last call now make sense.

Thanks!
Tommy

> On Mar 9, 2017, at 10:48 AM, Kathleen Moriarty <[email-masked]> wrote:
> 
> On Thu, Mar 9, 2017 at 12:47 PM, Tommy Pauly <[email-masked] <mailto:[email-masked]>> wrote:
>> Hi Kathleen,
>> 
>> https://tools.ietf.org/html/rfc7296 <https://tools.ietf.org/html/rfc7296>
>>

---

From: Kathleen Moriarty <[email-masked]>
Date: Tue, 28 Mar 2017 12:16:47 -0400

Hi Tommy,

Sorry I dropped the ball.  I can start IETF last call, but since we
are in IETF week, should it be extended a week?

Thanks,
Kathleen

On Sun, Mar 12, 2017 at 3:11 PM, Tommy Pauly <[email-masked]> wrote:
> Hi Kathleen,
>
> I've just posted a new version to fix some minor nits and add a reference
> for the SHA-1 digest used for NAT detection:
> On Mar 9, 2017, at 10:48 AM, Kathleen Moriarty
> <[email-masked]> wrote:
>
> On Mar 9, 2017, at 9:39 AM, Kathleen Moriarty
> <[email-masked]> wrote:
>
> Hello,
>

-- 

Best regards,
Kathleen

---

From: Tero Kivinen <[email-masked]>
Date: Tue, 28 Mar 2017 19:21:03 +0300

> are in IETF week, should it be extended a week?

Yes, I think extending it by a week would be better.
-- 
[email-masked]