Subject: Re: [IPsec] Starting two week working group adoptation call for draft-mglt-ipsecme-implicit-iv

From: Paul Wouters <[email-masked]>
Date: Sun, 2 Apr 2017 16:16:29 -0400 (EDT)

On Thu, 30 Mar 2017, Tero Kivinen wrote:

> As discussed in the meeting, we are starting two week working group
> adoptation call for the draft-mglt-ipsecme-implicit-iv.

No objection to adopting, but also not very excited about it. The document
uses the least unpleasant way of accomplishing its goal.

In section 8, AES-CTR is listed in the text but not in the listing of
new algorithms. I think it should indeed be dropped from the proposal.

Section 8 should also just include the IANA table with the three new
entries, filling with with [TBD]

Maybe a Section clarifying the NIST/FIPS terminology would be useful,
as there is a pretty big mixup with IV, ICV, Nonce and Tag :P

Paul

---

From: "Valery Smyslov" <[email-masked]>
Date: Mon, 3 Apr 2017 08:48:27 +0300

I think it won't be wrong if the document is adopted.
I'm not a big fan of implicit IV, but I agree that it may be useful in some cases.
However there are not always obvious pitfalls that may
make it insecure. I prefer to have these pitfalls been
documented and explained, that's why I support adoption.

Regards,
Valery.

> Please read the draft and send your comments to this list, and also
> tell if you support adoptation of this draft as WG draft.
> 
> The document is available at
> https://datatracker.ietf.org/doc/draft-mglt-ipsecme-implicit-iv/
> --
> [email-masked]
> 
> _______________________________________________
> IPsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipsec