Subject: [IPsec] Preference of ESP over AH in RFC7321bis question.

From: "Dang, Quynh (Fed)" <[email-masked]>
Date: Fri, 11 Aug 2017 14:12:10 +0000

Hi all,

In RFC 7321, we basically said that ESP is preferred over AH. However, that recommendation is not in the current RFC7321bis.

Was that an accidental mistake or because people using AH wanted to remove that recommendation ?

Thank you,

Quynh.

---

From: Daniel Migault <[email-masked]>
Date: Fri, 11 Aug 2017 10:22:55 -0400

Hi Dang,

My understanding is that the usage of AH vs ESP is outside the scope of
recommendations mandatory to implement cryptography. It is mostly a usage
concern. In my view AH and ESP are both mandatory to be implemented and
RFC7321bis limits its scope to the crypto recommendations.

Do you refer to the following text in section 3:

"""

 The IPsec community
   generally prefers ESP with NULL encryption over AH.
"""

Yours,

Daniel

On Fri, Aug 11, 2017 at 10:12 AM, Dang, Quynh (Fed) <[email-masked]>
wrote:

> Hi all,
>
>
> In RFC 7321, we basically said that ESP is preferred over AH. However,
> that recommendation is not in the current RFC7321bis.
>
>
> _______________________________________________
> IPsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipsec
>
>

---

From: "Dang, Quynh (Fed)" <[email-masked]>
Date: Fri, 11 Aug 2017 14:59:42 +0000

Thank you.

Quynh.

________________________________
From: [email-masked] <[email-masked]> on behalf of Daniel Migault <[email-masked]>
Sent: Friday, August 11, 2017 10:22:55 AM
To: Dang, Quynh (Fed)
Cc: [email-masked]
Subject: Re: [IPsec] Preference of ESP over AH in RFC7321bis question.

Hi Dang,

My understanding is that the usage of AH vs ESP is outside the scope of recommendations mandatory to implement cryptography. It is mostly a usage concern. In my view AH and ESP are both mandatory to be implemented and RFC7321bis limits its scope to the crypto recommendations.

"""

 The IPsec community

Yours,

Daniel

On Fri, Aug 11, 2017 at 10:12 AM, Dang, Quynh (Fed) <[email-masked]<mailto:[email-masked]>> wrote:

Hi all,

Thank you,

Quynh.

_______________________________________________
IPsec mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ipsec

---

From: Paul Wouters <[email-masked]>
Date: Fri, 11 Aug 2017 11:05:59 -0400 (EDT)

> Was that an accidental mistake or because people using AH wanted to remove that recommendation ?

Daniel already responded, but let me add that I'd be happy if the WG
decides to write a a draft-ipsecme-ah-ipcomp-diediedie :)

Paul

---

From: "Dang, Quynh (Fed)" <[email-masked]>
Date: Fri, 11 Aug 2017 15:23:00 +0000

I think that would be a very useful document.

Quynh.

________________________________
From: Paul Wouters <[email-masked]>
Sent: Friday, August 11, 2017 11:05:59 AM
To: Dang, Quynh (Fed)
Cc: [email-masked]
Subject: Re: [IPsec] Preference of ESP over AH in RFC7321bis question.

Paul