Subject: [IPsec] draft-boucadair-ipsecme-ipv6-ipv4-codes

From: <[email-masked]>
Date: Tue, 31 Oct 2017 14:50:08 +0000

Dear all,

As per a suggestion from Tero, I'm sending this message to the list to ask for more feedback on this short draft: https://tools.ietf.org/html/draft-boucadair-ipsecme-ipv6-ipv4-codes-00

FWIW, the draft includes an "update" header because I thought this can be generalized to other use cases than the 3GPP case I'm interested in.

Comments and guidance to get early codepoint assignments is more than welcome.

Thank you.

Cheers,
Med

---

From: Paul Wouters <[email-masked]>
Date: Tue, 31 Oct 2017 16:09:41 -0400 (EDT)

On Tue, 31 Oct 2017, [email-masked] wrote:

> As per a suggestion from Tero, I’m sending this message to the list to ask for more feedback on this short draft: https://tools.ietf.org/html/draft-boucadair-ipsecme-ipv6-ipv4-codes-00  
> 
> FWIW, the draft includes an “update” header because I thought this can be generalized to other use cases than the 3GPP case I’m interested in.
> 

It seems okay to return some more information in the errors on obtaining
an internal IP address.

I'm not sure I understand the meaning of SINGLE_AF_SUPPORTED. Does that
imply the family must be the same as the IKE address family used? Or
does it just mean you can only request v4 or v6 but not both _and_
it is independent of the address family used for this IKE exchange?

That is, are you expecting 4in6 and 6in4 items if the IKE peer address
family is one, and the INTERNAL_IP family is the other family?

Maybe this is getting too combinatory, and the notify should be just
a FAMILY_RESTRICTION type with a value that can be various things,
so you can say v4only, v6only, internal=external, 4in6allowed,
6in4allowed ?

Paul