Subject: [IPsec] qr-ikev2 interop test

From: Paul Wouters <[email-masked]>
Date: Mon, 13 Nov 2017 05:05:04 -0500 (EST)

Some people were interested in interop for the ppk draft.

We have implemented draft-fluhrer-qr-ikev2, and are going to
implement draft-ietf-ipsecme-qr-ikev2 in the near future.

To test, feel free to use the below server and let us know if you
had positive or negative results:

server: vpn-ppk.nohats.ca
server ID: GroupPPK1
PSK: SecretPSK
PPK ID: PPKID1
static PPK: NotQuantumSafe

It is configured as an access VPN, so you will get an IP addres via CP to
0.0.0.0/0.

We are still working on cleaning up the code for dynamic PPK (OTP) support.

Paul & Vukasin

---

From: Tommy Pauly <[email-masked]>
Date: Tue, 14 Nov 2017 00:01:25 +0800

Thanks for setting this up! I'll try an interop soon (this week I hope).

However, some questions first: what values are you using for these?
- PPK_SUPPORT notify code
- PPK_IDENTITY notify code

Also, I presume you're using PPK_ID_FIXED, not PPK_ID_OPAQUE?

Thanks,
Tommy

> On Nov 13, 2017, at 6:05 PM, Paul Wouters <[email-masked]> wrote:
> 
> 
> _______________________________________________
> IPsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipsec

---

From: Vukasin Karadzic <[email-masked]>
Date: Mon, 13 Nov 2017 17:16:47 +0100

On 13 Nov 2017 5:01 pm, "Tommy Pauly" <[email-masked]> wrote:

The values 40960 and 40961 were picked as private use numbers for
PPK_SUPPORT and PPK_IDENTITY Notify messages, respectively

Yes!

Regards,
Vukasin