Subject: I'd like to speak in the IPTEL session

From: KITAGAWA Takurou <[email-masked]>
Date: 20 Mar 2000 13:29:05 +0900

I'd like to talk about a directory service for IP telephony 
using HTTP, in the IPTEL session in 47th IETF meeting.
Can I have a time (about a few minutes) to speak?

-- 
Kitagawa Takurou
Graduate School of Kyoto University
[email-masked]

---------
This message came from the IETF IPTEL Working Group Mailing List.

---

From: KITAGAWA Takurou <[email-masked]>
Date: 24 Mar 2000 13:46:15 +0900

If I can, I would like to speak about this server in the IPTEL
session in 47th IETF meeting.

---------------------------------------------------------------------------
Abstract

A telephone directory server, which changes a traditional
telephone number into the information that an IP telephony application uses,
is defined.
This server uses HTTP and CGI to communicate with a client.

1. Introduction

When a user employs IP telephony, he or she must specify 
many types of information such as IP address, port number,
protocol for communication, audio codec, and etc.
This specification bothers users very much.
Thus, when a user can specify all information just by one telephone
number, it will save him or her much trouble and IP telephony will
become easier to use.

In this draft, a telephone directory server, which changes a telephone
number given by a user into the information that IP telephony
applications require, is defined.
This server uses HTTP and CGI as a protocol for communication with
a client.

2. Query from client to server

A client accesses to following URI with HTTP, using a GET method.

http://<server>/[path]?<phone number>

<server> is the host name (or IP address) of a telephone directory
server.
A server MAY require [path], to specify a telephone directory in it.
<phone number> is the telephone number given by a user, and is
composed of digit 0-9, *, and/or #.

<server> and [path] in this URI, which are required information to
specify a telephone directory, are set up in a client in advance.

3. Answer from server to client

A server receives a requested telephone number with the CGI scheme.
Then a sever refers to internal database, whether the information
copes with the requested telephone number.

3.1 The case that server found matched information

A server returns HTTP status code 200 (OK) to a client,
and a body part of the answer contains the information.

The information returned to a client depends on a telephony system,
but usually contains:

 o A hostname or IP address of callee
 o A port number of callee
 o A protocol used in calling
 o An audio codec used in calling

The description format of the information is notified of the client by
the Content-Type field.
For example, SDP can be used as a concrete description format,.

Example: 

( C> indicates the data from a client to a server, and S> indicates
the data from a client to a server )

C>GET /?1234 HTTP/1.0
C>
S>200 OK
S>Content-Type: application/sdp
S>
S>v=0
S>o=user@somedomain
S>s=IP telephone call
S>c=IN IP4 somehost.somedomain
S>t=0 0
S>m=audio 10001 RTP/AVP 0

3.2 The case that the server could not find information

A server returns HTTP status code 404 (Not Found) to a client.

Example:

C>GET /?1234 HTTP/1.0
C>
S>404 Not Found
S>

3.3 Timeout

A client waits for an answer from a server during the specified time
after it sent an query.
When a client receives no answer from a server during the time, 
it judges that a server error occurred.

3.5 Other status codes

A server MAY return other status codes to a client if necessary.
When a client receives an HTTP Status Code not described above,
it SHOULD deal it as an usual HTTP user agents does.

4. Security

A telephone directory server MAY authenticate a client in accordance
with the HTTP framework, if necessary.

---------------------------------------------------------------------------

---------

---

From: KITAGAWA Takurou <[email-masked]>
Date: 24 Mar 2000 17:55:39 +0900

Jonathan Rosenberg <[email-masked]> writes:

> This is simply too late to be considered for a slot.

In a general IETF WG meeting,
a sudden speaker is usually also welcome.

And...

	IETF 47 1930-2200, Monday March 27
	==================================
	
	1. Agenda Bashing		[Rosenberg]	5 mins
	2. Status of CPL & TRIP
	   Frameworks			[Rosenberg]	5 mins
	3. Framework and Requirements
	   for the Internet Intelligent
	   Networks  (IIN)              [Slutsman]      15 mins
	4. TRIP				[Rosenberg]	45 mins
	5. TRIP for Gateway Route
	   Exporting			[Rosenberg]	15 mins
	   
	6. CPL				[Rosenberg]	45 mins

slots still remain apparently.
5 or 10 ten minutes for this topic are enough.

> Please submit as an
> I-D after the meeting if you wish to pursue this. In any case, I believe
> this to be outside of the charter of iptel. 

I belive this theme interests most people attending 
IPTEL WG. Let's discuss this topic openly.

> -Jonathan R.

---------