Subject: [IPTEL] CPL's timeouts

From: S_S_Dinesh/India/[email-masked]
Date: Mon, 8 May 2000 14:10:01 +0530

Regarding the Call Processing Language (CPL) draft, are there default
timeout values for the elements that accept timeout as an argument if
the user does not specify a value?

--
Kenny Hom
Senior Software Engineer
Vovida Networks, 2150 Trade Zone Blvd. 105, San Jose, CA 95131
[W] (408) 941-1790 / [F] (408) 941-1791

---------
This message came from the IETF IPTEL Working Group Mailing List.

_______________________________________________
IPTEL mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/iptel

---

From: S_S_Dinesh/India/[email-masked]
Date: Mon, 8 May 2000 14:10:11 +0530

Jonathan Lennox wrote:
>
> On Fri, February 11 2000, "Jonathan Rosenberg" wrote to "Henning
Schulzrinne, [email-masked], [email-masked],
[email-masked]" saying:
>
> > OK; I'll buy this argument. Which tags need timeouts? Isn't it only
> > proxy? I think perhaps a reasonable default is 30 seconds?
>
> Proxy's the only case where lack of response (noanswer) and failure are
> different.

A wholly unscientific check of call forward no answer seems to put the
detault at 15-20 seconds or three-four rings (18-24 seconds). Not that
it much matters, but 20 s seems to be about right.

> I don't think we need to worry about setting default timeouts
> for location lookup or the like.
>
> --
> Jonathan Lennox
> [email-masked]

---------

---

From: S_S_Dinesh/India/[email-masked]
Date: Mon, 8 May 2000 14:10:04 +0530

Proxy's the only case where lack of response (noanswer) and failure are
different.  I don't think we need to worry about setting default timeouts
for location lookup or the like.

--
Jonathan Lennox
[email-masked]

---------

---

From: S_S_Dinesh/India/[email-masked]
Date: Mon, 8 May 2000 14:10:10 +0530

-Jonathan R.

Henning Schulzrinne wrote:
>
> Since CPL scripts can explicitly provide timeouts, server-based defaults
> don't offer significant policy control to the server. However, they do
> open up weird interoperability issues ("my script worked fine yesterday,
> you upgraded the server and suddenly all my calls go to voice mail").
> Given that we specify default for parameters in SIP, I would argue that
> defaults in the spec aid interoperability and portability of scripts.
> Too many tunable server parameters aren't in anybody's interest. Having
> default parameters also allows "script testers" to reason about overall
> script behavior, e.g., with several proxy attempts, how long will it
> take overall until the call gets sent to voicemail.
>
> Jonathan Rosenberg wrote:
> >
> > None defined right now as I recall. I'm not sure there needs to be a
> > standard default. It might be OK for the proxy to set the default
> > administratively.
> >
> > -Jonathan R.
> >
> > Kenny Hom wrote:
> > >

--
Jonathan D. Rosenberg                       200 Executive Drive
Chief Scientist                             Suite 120
dynamicsoft                                 West Orange, NJ 07052
[email-masked]                     FAX:   (732) 741-4778
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com

---------