Subject: [IPTEL] Length in OPEN

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 13 Jun 2000 08:57:38 +0300

Hi,

Why is it needed the "optional parameter length" in the OPEN message if
the length of the whole message is already present in the fixed-sized
header?

Thanks,

Gonzalo
-- 
Gonzalo Camarillo         Phone :  +358  9 299 33 71
Oy L M Ericsson Ab        Mobile:  +358 40 702 35 35
Telecom R&D               Fax   :  +358  9 299 30 52
FIN-02420 Jorvas          Email :  [email-masked]
Finland

_______________________________________________
IPTEL mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/iptel

---

From: "Hussein F. Salama" <[email-masked]>
Date: Tue, 13 Jun 2000 10:46:11 -0700

> the length of the whole message is already present in the fixed-sized

TRIP inherited this format from BGP. I don't know why the "optional
parameters length" was included in BGP's OPEN message header. However,
unless I am missing something, removing this two-byte field will not
save us much, because the OPEN message only occurs once a session
anyways.

Hussein

-- 
Hussein F. Salama
Cisco Systems
Mail Stop SJC6/3, 170 W. Tasman Drive, San Jose, CA 95134
Voice: +1 (408) 527-7147, Fax: +1 (408) 527-1714

---

From: Dhaval Shah <[email-masked]>
Date: Thu, 22 Jun 2000 12:18:01 -0700 (PDT)

> save us much, because the OPEN message only occurs once a session

Is there any reason to keep it if TRIP doesn't need it? Also, the optional 
parameter length in BGP is 1 byte. Any reason why TRIP has 2 bytes?

Thanx,
Dhaval