Subject: Re: [IPTEL] draft-ietf-cpl-01 the DTD

From: Jonathan Lennox <[email-masked]>
Date: Fri, 7 Jul 2000 17:33:38 -0400 (EDT)

On Wed, June 21 2000, "James Undery" wrote to "[email-masked], [email-masked]" saying:

> Hi,
> 
> 	Just a quick observation, I know The CPL DTD got a mauling on the
> iptel mailing group a while back, but I think Nilo missed a mistake in the
> DTD,
> 
> 	<!ELEMENT timezone ( standard+, daylight* ) >
> 
> is what the text describes, rather than
> 
> 	<!ELEMENT timezone ( standard, daylight? ) >
> 
> in the draft's DTD.

No, the idea was that you would have multiple timezones, each with one
standard time and possibly one daylight time.  I don't think this actually
works, though; more about this in a followup message.

> 
> I am also interested in how seriously XML schemas are being considered as
> I think there are some areas where the DTD could be tightened up, but,
> don't want to waste time if the DTD is binned in favour of a schema.

Since XML schemas are a) not finished yet, b) not nearly as widely
implemented as DTDs, and c) specified in two huge, impenetrable (to me)
specifications, I don't think it's likely unless someone else wants to
volunteer to write up a schema for CPL.  So comments on the DTD are very
welcome.

-- 
Jonathan Lennox
[email-masked]

_______________________________________________
IPTEL mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/iptel

---

From: James Undery <[email-masked]>
Date: Mon, 10 Jul 2000 08:53:13 +0100

> works, though; more about this in a followup message.

In that case I'd remove the sentence "A timezone rule MAY contain several definitions of standard and
daylight if, for instance, different rules are in effect for different years." ;^)

James Undery