Subject: [IPTEL] [TRIP] The "Application Protocol" field

From: "Orit Levin" <[email-masked]>
Date: Sun, 20 Aug 2000 11:23:07 -0400

Hello!
Reading through the TRIP specification, I got a feeling that RAS and Annex G protocols are not, really, good "candidates" for the TRIP "Application Protocol". (I am sure, we are going to have an interesting discussion on that, during the ITU meeting in Portland, this week :-)
On the other hand, an architecture with "Call Signaling Proxies" performing translation between SIP and H.323 Signaling Protocols and being advertised as "NextHopServer", seems to fit very nicely into the TRIP architecture. Even, having a joined Routing DB, seems to be a natural thing.
Then, reading till the end, I came across an "open issue" listed as a "mapping of application protocols".
My questions would be:
- Is it about the same topic?
- How difficult it seems to the authors?
- How far down the road, this topic has been addressed/thought of?
Thanks, 
Orit Levin
RADVision Inc.
575 Corporate Drive Suite 420
Mahwah, NJ 07430
Tel: 1 201 529 4300  (230)
Fax: 1 201 529 3516
www.radvision.com
[email-masked]

---

From: "Hussein F. Salama" <[email-masked]>
Date: Mon, 21 Aug 2000 13:07:04 -0700

Orit,

> Orit Levin wrote:
> 
> Hello!
> Reading through the TRIP specification, I got a feeling that RAS and
> Annex G protocols are not, really, good "candidates" for the TRIP
> "Application Protocol". (I am sure, we are going to have an
> interesting discussion on that, during the ITU meeting in
> Portland, this week :-)
> On the other hand, an architecture with "Call Signaling Proxies"
> performing translation between SIP and H.323 Signaling Protocols and
> being advertised as "NextHopServer", seems to fit very nicely into the
> TRIP architecture. Even, having a joined Routing DB, seems to be a
> natural thing.

Yes, if a TRIP LS translates from one application protocol to another,
this necessitates the presence of an proxy that's capable of translating
between the two application protocols.

> - How difficult it seems to the authors?

From TRIP perspective, this is straightforward. Before sending an UPDATE
to an external peer, a TRIP LS simply replaces one application protocol
with a different application protocol in the ReachableRoutes attribute.

Hussein

-- 
Hussein F. Salama
Cisco Systems
Mail Stop SJC6/3, 170 W. Tasman Drive, San Jose, CA 95134
Voice: +1 (408) 527-7147, Fax: +1 (408) 527-1714

_______________________________________________
IPTEL mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/iptel

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 22 Aug 2000 12:23:06 -0400

> interesting discussion on that, during the ITU meeting in

We have gotten very mixed input from our H.323 experts on this.

Nearly a year ago, a number of folks said RAS was not a good candidate.

Recently, Paul Jones insisted quite strongly that both RAS and Annex G
get added in.

Now, you believe they should not be there.

I really want to get this resolved. TRIP is nearly finished. Any harm in
keeping it in? If it doesn't get used, so  be it.

-Jonathan R.

-- 
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com