Subject: RE: [IPTEL] [TRIP] Address Families in draft-ietf-iptel-trip-03

From: James Yu <[email-masked]>
Date: Fri, 11 Aug 2000 20:59:09 -0500

It seems that there may be a need to define the routing numbers in such a
way (or by implementation?) that allows easy aggregation of "routing
numbers" that contain only digits 0 through 9 for countries that don't use
digits A through E in the "routing numbers."

James

> -----Original Message-----
> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Friday, August 11, 2000 12:10 PM
> To: [email-masked]
> Cc: James Yu; [email-masked]'
> Subject: Re: [IPTEL] [TRIP] Address Families in 
> draft-ietf-iptel-trip-03
> 
> 
> 
> 
> "Hussein F. Salama" wrote:
> > 
> > James,
> > 
> > James Yu wrote:
> > >
> > > Hussein,
> > >
> > > As indicated earlier, the "POTS number" address family is 
> a subset of
> > > "routing number" address family (not in terms of the 
> numbers but in terms of
> > > allowable digits).  Aggregation needs to be done for the 
> "routing numbers"
> > > anyway if digits A through E may appear in the routing 
> numbers.   So you are
> > > not totally avoiding the problem.  If you need to 
> aggregate for the routing
> > > numbers and one "routing number" table can do the work, 
> why announcing the
> > > additional "POTS numbers" and managing an additional 
> "POTS number table at
> > > the LSs just because it is easier to aggregate that 
> address family (this is
> > > an "extra" work).  Under country code 1, digits A through 
> E are not used.
> > > It is then easy to aggregate the "routing numbers" under 
> country code 1.
> > 
> > I prefer having two separate address families to having a 
> single address
> > family with two, or may be more, sets of aggregation rules. Deciding
> > which set of aggregation rules to use based on the first 
> digit of the
> > prefix is too restrictive. For example, I can imagine TRIP 
> applications,
> > with limited scope, local or national, which advertise 
> numbers without
> > prepending the country code to them. Hence we won't have the '1' to
> > decide which aggregation rules to use?
> 
> THe other issue is that you are forced to do semantic based 
> aggregation.
> We want to
> allow (but not mandate of course)aggregation of numbers based 
> on syntax
> ONLY (i.e., I have 11, 12, 13 14, ... 10, and
> since there are ten digits, I can aggregate to 1). This NECESSITATES
> knowing the number
> of digits that exist.
> 
> -Jonathan R.
> 
> -- 
> Jonathan D. Rosenberg                       72 Eagle Rock Ave.
> Chief Scientist                             First Floor
> dynamicsoft                                 East Hanover, NJ 07936
> [email-masked]                     FAX:   (973) 952-5050
> http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
> http://www.dynamicsoft.com
> 
> 
> _______________________________________________
> IPTEL mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/iptel
> 

_______________________________________________
IPTEL mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/iptel

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 14 Aug 2000 02:36:45 -0400

Right, and thats called the "POTS Number" address family.

-Jonathan R.