Subject: RE: [IPTEL] h323 and Video

From: "Amar, Yigal" <[email-masked]>
Date: Thu, 5 Oct 2000 23:29:40 +0300

Paul,

The original stream surely have key frame,
but I'm writing an IVR application and need to 'catch' the stream in a
random point
and record it to a file , so I guess I'm missing it.

Yigal

> -----Original Message-----
> From: Paul Long [mailto:[email-masked]]
> Sent: Thursday, October 05, 2000 5:55 PM
> To: [email-masked]
> Subject: RE: [IPTEL] h323 and Video
> 
> 
> Yigal,
> 
> Yeah, your original video stream should probably have started 
> with a key
> frame (INTRA). Don't know why you don't have one. I have seen 
> some H.323
> endpoints, e.g., NetMeeting, loose the first one. To fix it, they just
> transmit several at the beginning of a call! :-p
> 
> Paul Long
> Smith MIcro Software, Inc.
> 
> -----Original Message-----
> From: Amar, Yigal [mailto:[email-masked]]
> Sent: Thursday, October 05, 2000 8:54 AM
> To: 'Paul Long'; [email-masked]
> Subject: RE: [IPTEL] h323 and Video
> 
> 
> Hi Paul,
> 
> Thanks for your answers
> I'm reading now the links that you send.
> As for the second question ,I understand now that I can't 
> modify the MTYPE
> of the first frame just like that. I can't also discard all 
> frames up to
> first INTRA
> because I've look in the H.261 standard and it allowed up to 
> 132 "P frames"
> after one INTRA frame,
> which is 13 seconds in a 10fps rate - not good.
> 
> I think I saw something in H.245 that says to the far 
> endpoint to generate
> an INTRA frame
> I need to read more about it.
> 
> Thanks
> 
> _______________________________________________
> IPTEL mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/iptel
> 

_______________________________________________
IPTEL mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/iptel

---

From: Paul Long <[email-masked]>
Date: Thu, 5 Oct 2000 15:51:36 -0500

Yigal,

In that case, your choices are to 1. suffer through the first several
seconds of corrupted video, 2. start recording or playingback/retransmitting
at the next key frame, or 3. generate your own key frame based on the last
key frame and any deltas that have been applied to it. The latter assumes
you are performing the decoding yourself and not merely grabbing a stream
blindly, which unfortunately sounds like what you are doing.

Paul Long
Smith Micro Software, Inc.

-----Original Message-----
From: Amar, Yigal [mailto:[email-masked]]
Sent: Thursday, October 05, 2000 3:30 PM
To: 'Paul Long'; [email-masked]
Subject: RE: [IPTEL] h323 and Video

Paul,

Yigal