Subject: RE: [IPTEL] h323 and Video

From: "Amar, Yigal" <[email-masked]>
Date: Sun, 8 Oct 2000 11:13:13 +0200

Paul,

Right now, for prototype purpose I'm not doing any decoding.
I just record the video stream as it comes in a form of RTP packets (with
timestamps)
and when playing it back to the remote endpoint(on user demand),
I renormalize the timestamps according to sender wall clock.

If I'm using only h.261 in my system, why do you think I need decoding for
??

Yigal

> -----Original Message-----
> From: Paul Long [mailto:[email-masked]]
> Sent: Thursday, October 05, 2000 10:52 PM
> To: [email-masked]
> Subject: RE: [IPTEL] h323 and Video
> 
> 
> Yigal,
> 
> In that case, your choices are to 1. suffer through the first several
> seconds of corrupted video, 2. start recording or 
> playingback/retransmitting
> at the next key frame, or 3. generate your own key frame 
> based on the last
> key frame and any deltas that have been applied to it. The 
> latter assumes
> you are performing the decoding yourself and not merely 
> grabbing a stream
> blindly, which unfortunately sounds like what you are doing.
> 
> Paul Long
> Smith Micro Software, Inc.
> 
> -----Original Message-----
> From: Amar, Yigal [mailto:[email-masked]]
> Sent: Thursday, October 05, 2000 3:30 PM
> To: 'Paul Long'; [email-masked]
> Subject: RE: [IPTEL] h323 and Video
> 
> 
> Paul,
> 
> The original stream surely have key frame,
> but I'm writing an IVR application and need to 'catch' the stream in a
> random point
> and record it to a file , so I guess I'm missing it.
> 
> Yigal
> 
> _______________________________________________
> IPTEL mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/iptel
> 

_______________________________________________
IPTEL mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/iptel

---

From: "Ami Amir" <[email-masked]>
Date: Tue, 10 Oct 2000 12:34:27 +0200

Yigal

The decoder (receive side codec) will eed to wait for an Key Frame in order
to start providing a meaningful image. If you disregard this issue when
recording, it is highly likely that a significant art of your recording will
be lost.

Ami

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Amar, Yigal
Sent: 08 October, 2000 11:13
To: 'Paul Long'; [email-masked]
Subject: RE: [IPTEL] h323 and Video

Paul,

Yigal

---

From: Paul Long <[email-masked]>
Date: Fri, 13 Oct 2000 11:24:24 -0500

Yigal,

Unlike audio, video typically has temporal dependencies between frames. You
therefore cannot simply extract a sample from a video stream at an arbitrary
point without risking artifacts during playback. That's just the way it is.
You need to decode the stream in order to throw away all INTER frames up to
the first INTRA.

Paul

-----Original Message-----
From: Amar, Yigal [mailto:[email-masked]]
Sent: Sunday, October 08, 2000 4:13 AM
To: 'Paul Long'; [email-masked]
Subject: RE: [IPTEL] h323 and Video

Paul,

Yigal