Subject: RE: [IPTEL] h323 and Video

From: "Amar, Yigal" <[email-masked]>
Date: Sun, 15 Oct 2000 16:12:38 +0200

Hi Amir,

Sorry for the late response , I wasn't around.  

Do you mean that even after I send the "FastUpdatePicture" H245 command ,
I have to wait for the INTRA frame , and only then start the recording?

Yigal

> -----Original Message-----
> From: Ami Amir [mailto:[email-masked]]
> Sent: Tuesday, October 10, 2000 12:34 PM
> To: 'Amar, Yigal'; 'Paul Long'; [email-masked]
> Cc: Rudy Shainer (E-mail)
> Subject: RE: [IPTEL] h323 and Video
> 
> 
> Yigal
> 
> The decoder (receive side codec) will eed to wait for an Key 
> Frame in order
> to start providing a meaningful image. If you disregard this 
> issue when
> recording, it is highly likely that a significant art of your 
> recording will
> be lost.
> 
> Ami
> 
> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Amar, Yigal
> Sent: 08 October, 2000 11:13
> To: 'Paul Long'; [email-masked]
> Subject: RE: [IPTEL] h323 and Video
> 
> 
> Paul,
> 
> Right now, for prototype purpose I'm not doing any decoding.
> I just record the video stream as it comes in a form of RTP 
> packets (with
> timestamps)
> and when playing it back to the remote endpoint(on user demand),
> I renormalize the timestamps according to sender wall clock.
> 
> If I'm using only h.261 in my system, why do you think I need 
> decoding for
> ??
> 
> Yigal
> 
> 
> 
> > -----Original Message-----
> > From: Paul Long [mailto:[email-masked]]
> > Sent: Thursday, October 05, 2000 10:52 PM
> > To: [email-masked]
> > Subject: RE: [IPTEL] h323 and Video
> >
> >
> > Yigal,
> >
> > In that case, your choices are to 1. suffer through the 
> first several
> > seconds of corrupted video, 2. start recording or
> > playingback/retransmitting
> > at the next key frame, or 3. generate your own key frame
> > based on the last
> > key frame and any deltas that have been applied to it. The
> > latter assumes
> > you are performing the decoding yourself and not merely
> > grabbing a stream
> > blindly, which unfortunately sounds like what you are doing.
> >
> > Paul Long
> > Smith Micro Software, Inc.
> >
> > -----Original Message-----
> > From: Amar, Yigal [mailto:[email-masked]]
> > Sent: Thursday, October 05, 2000 3:30 PM
> > To: 'Paul Long'; [email-masked]
> > Subject: RE: [IPTEL] h323 and Video
> >
> >
> > Paul,
> >
> > The original stream surely have key frame,
> > but I'm writing an IVR application and need to 'catch' the 
> stream in a
> > random point
> > and record it to a file , so I guess I'm missing it.
> >
> > Yigal
> >
> > _______________________________________________
> > IPTEL mailing list
> > [email-masked]
> > http://lists.bell-labs.com/mailman/listinfo/iptel
> >
> 
> _______________________________________________
> IPTEL mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/iptel
> 
> 
> _______________________________________________
> IPTEL mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/iptel
> 

_______________________________________________
IPTEL mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/iptel

---

From: Ami Amir <[email-masked]>
Date: Mon, 16 Oct 2000 09:17:32 +0200

Yup,

You cannot control the behaviour of codecs from a variety of vendors, and
hence when will they respond to your request for fastupdate. You can start
recording at will, but it won't do you any good to send an H.26x clip w/o an
initial intra frame.

-----Original Message-----
From: Amar, Yigal [mailto:[email-masked]]
Sent: 15 October, 2000 16:13
To: [email-masked]'; 'Paul Long'; [email-masked]
Cc: Rudy Shainer (E-mail)
Subject: RE: [IPTEL] h323 and Video

Hi Amir,

Yigal