Subject: RE: [IPTEL] CPL Question About Priority

From: [email-masked]
Date: Wed, 29 Nov 2000 15:40:01 -0600

> -----Original Message-----
> From: EXT Jonathan Lennox [mailto:[email-masked]]
> Sent: Tuesday, November 28, 2000 4:09 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Re: [IPTEL] CPL Question About Priority
> 
> 
. . .
> But I understood the the feature Cliff 
> was describing as
> "If I call anyone at Example Industries, first place my call 
> to the Example
> Industries switchboard, then try that specific person."  It's 
> not clear to
> me why anyone would ever want such a feature for their 
> outgoing call script.

That's a good summary (in the context of base CPL) of what I was asking
about, and I agree that there is probably no use for such a feature in base
CPL. When I asked the question, I wasn't thinking of a particular feature; I
was just thinking about the language definition. 

Suppose that some future extensions to CPL made it sensible to do what I was
asking. Then there would be difficulties because the use of priorities is
not strictly defined (so that at the very least, scripts using these
hypothetical new features would not be portable--they would behave
differently on different CPL servers).

While I don't have a good example of why I might want to try some other
address first in an outgoing call (unless there's been a successful "address
is" test), I equally don't understand why a CPL server would need to
override the priorities specified in the script. A script can always proxy
to one location at a time in whatever order it wants; why would a list of
locations with explicit priorities need to be treated differently? 

Maybe there's something about server policy with respect to priorities that
I don't understand, but it seems to me that making the language a little
more deterministic would make it more extensible (and portable) in the
future.

> -----Original Message-----
> From: EXT Jonathan Lennox [mailto:[email-masked]]
> Sent: Tuesday, November 28, 2000 3:57 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [IPTEL] CPL Question About Priority
> 
>
. . . 
> It's true that there's no priority specified for the initial 
> address.  I
> suppose it should be 1.0.

Then it would be impossible to add a new address with a higher priority to
the location set. (Unless the language specified that locations of equal
priority should be processed in LIFO order.)

> -----Original Message-----
> From: EXT Jonathan Lennox [mailto:[email-masked]]
> Sent: Wednesday, November 29, 2000 12:22 PM
> To: [email-masked]
> Subject: Re: [IPTEL] CPL Question About Priority
> 
> 
> On Wednesday, November 29 2000, "hammer michael" wrote to 
> "Jonathan Lennox, [email-masked], [email-masked], 
> [email-masked]" saying:
> 
> > You could potentially have a network selection based on 
> dynamic network 
> > characteristics.
> > Route through network A (the cheapest) unless it is 
> congested or denies me 
> > service,
> > otherwise route through network B while QoS > X, else ...
> > 
> > I know that bandwidth is supposed to be free and plentiful, 
> but could you 
> > foresee networks of the future dynamically changing their 
> rates based on 
> > demand and users selecting the better alternatives for routing?
> 
> Yes, absolutely, but this is way out of scope for the CPL.  
> Remember, CPL
> controls *signalling*, and the network selection you're 
> talking about is for
> *media*.
> 
> If I place a call to sip:[email-masked], and the 200 
> response to the INVITE
> has 128.59.19.147 in its SDP, I'm going to send my packets to 
> 128.59.19.147,
> regardless of what route my INVITE took.
> 
> If I'm using manyfolks, I'll also set up a resource 
> reservation to that IP
> address.  That's the point at which the service provider 
> should intervene to
> figure out what route they want my packets to take.
> 

What if the form of the address affects the type of signalling which affects
the type of media? For instance, given a telephone number that could be
routed either through the PSTN or through the IP network, would it be
unreasonable to have the script change the address from a tel URL to a sip
URL to select the type of routing?

_______________________________________________
IPTEL mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/iptel

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 29 Nov 2000 23:22:13 -0500

Correct, the application knows best what its QoS requirements are. And thats
why IETF has developed protocols like RSVP that allow the users to ask the
network for various levels of QoS. Whether it scales or not is a separate
discussion thats out of scope here.

As per senders of IP packets getting to determine the route through the IP
network; there is the possibility of such a thing using loose source IP
routing. But, in practice, this is never done and frought with problems.
There are serious topology discovery and other issues that need to be
resolved; a minor problem is that packets marked with loose source routes
are slow-path on routers, resulting in increased delay. I don't think anyone
uses loose source routing at all.

That aside, this is all completely out of scope for CPL. As Jonathan L. has
correctly observed, SIP signaling routing is completely orthogonal to media
routing, and for really, really good reasons (i.e., not re-inventing yet
another forwarding, switching, routing layer within the network just for
RTP; the IP network already knows how to deliver the RTP packets in the most
direct path from originator to recipient).

-Jonathan R.

> From: Lakshmi Krishnamurthy [mailto:[email-masked]]
> Sent: Wednesday, November 29, 2000 4:06 PM
> To: hammer michael
> I agree with this observation. The application always knows best in 
> terms of the nature & type of resources it needs accomodated by the 
> network. There needs to be a way of communicating this requirement to 
> the IP layer.
> 
> This need not be an explicit list of QoS params, but 
> something that is a 
> user-friendly mapping could be in order.
> 
> hammer michael wrote:
> 
> > I understand to an extent the distinction you are making, 
> that the IP 
> > layer, given the end-point address can figure out how to route the 
> > packets carrying the media along with resource 
> reservations.  However, 
> > the existence of Via, Route, and Record-Route parameters 
> and the usage 
> > for routes longer than two proxies would seem to undermine 
> the purity 
> > of your position.  Ultimately the purpose of signaling is 
> to establish 
> > the media path, so they are not so totally divorced.
> > 
> > I thought that one of the evolutionary goals of the IP 
> telephony was 
> > to put as much control in the hands of the end-user.  If 
> such control 
> > is in the IP layer, how does the user control that?  Will that be a 
> > Web-level interface or must he be an IP guru?  I was envisioning a 
> > little more control in the Application layer via some more 
> > user-friendly features.  In the current PSTN, there is some 
> level of 
> > stimulus signaling for customers to activate and deactivate 
> features 
> > and program-in network codes and user phone numbers for 
> forwarding.  I 
> > would expect that the level of user control would be much 
> higher in IP 
> > telephony.
> > 
> > Do you see the network cloud operating transparently and 
> what service 
> > you get is what you get?
> > Or is there another media-specific protocol that allows the user to 
> > explicitly control what network routes that his packets traverse?
> > 
> > Mike
> > 
> > 
> > At 12:22 PM 11/29/2000 -0500, Jonathan Lennox wrote:
> > 
> "Jonathan 
> >> Lennox, [email-masked], [email-masked], 
> >>  > You could potentially have a network selection based on dynamic 
> >> network
> >>  > characteristics.
> congested or 
> >> denies me
> >>  > I know that bandwidth is supposed to be free and plentiful, but 
> >> could you
> >>  > foresee networks of the future dynamically changing their rates 
> >> based on
>  Remember, 
> >> CPL
> talking about 
> >> is for
> response to the 
> >> INVITE
> >> If I'm using manyfolks, I'll also set up a resource reservation to 
> >> that IP
> >> address.  That's the point at which the service provider should 
> >> intervene to
> >> -- 
> >> Jonathan Lennox
> >> [email-masked]
---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 29 Nov 2000 23:23:51 -0500

I agree that priority values should be deterministic.

Lets specify that the default q value for the initial location set (relevant
only for outgoing requests) is 1.0, and that if the lookup tag results in
URLs with no q values, the value is assigned as 1.0 as well.

-Jonathan R.

---

> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, November 29, 2000 4:40 PM
> To: [email-masked]
> Subject: RE: [IPTEL] CPL Question About Priority
> 
> 
> 
>