Subject: RE: [IPTEL] CPL-03 Comments and Questions

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 13 Nov 2000 17:13:17 -0500

> -----Original Message-----
> From: Jonathan Lennox [mailto:[email-masked]]
> Sent: Monday, November 13, 2000 3:09 PM
> To: Jonathan Rosenberg
> Cc: [email-masked]'; [email-masked]
> Subject: RE: [IPTEL] CPL-03 Comments and Questions
> 
> 
> On Thursday, November 9 2000, "Jonathan Rosenberg" wrote to 
> "[email-masked]', Jonathan Rosenberg, 
> [email-masked]" saying:
> 
> [JR Writes:]
> > > > In any case, I'd suggest we update the text here to 
> indicate that the CPL
> > > > server append some query strings to the HTTP request 
> containing these
> > > > parameters. Thus, in the example above, the actual HTTP 
> > > > request would be:
> > > > 
> > > > GET 
> http://www.foo.com/mlylocation.txt?Request-URI=sip:user@host&F
> rom=sip:[email-masked]&Call-ID=[email-masked]&To=
> sip:user@host HTTP/1.1
> > > > 
> > > > Sound reasonable?
> 
> [CH Writes:]
> > > Sounds good. However, in your example you've used SIP fields 
> > > rather than CPL fields. Would Call ID really be useful? 
> 
> [JR Writes:]
> > You are correct - they should be the generic versions, not 
> the SIP versions.
> > 
> > Is Call-ID useful? Most definitely. This would allow me to 
> write an apps
> > that require complex, call-stateful operations.
> 
> This seems to me like a very big change to make at this point.  The
> intention of the current draft is "send a GET request 
> containing the URI in
> the location parameter, verbatim."  Changing that is a fairly 
> big deal -- it
> requires a serious chunk of thought as to exactly what 
> parameters go into
> the request.
> 
> One counter-argument is that a bit of experimentation shows that HTTP
> servers (or at least Apache) seem to ignore spurious 
> parameters in a GET
> request, so in the unlikely event that anyone is using the 
> HTTP location
> lookup already, this probably wouldn't break anything.
> 
> Do you have a proposal for these headers here?  And do you 
> think that if we
> change this, we should do another WG last-call?

Hmm.

My proposal is the following. We leave it as it is, and get baseline CPL out
the door. As a follow up (extension, whatever), I'm very interested in
investigating, in a general sense, applying VoiceXML style models of remote
fetching using HTTP to CPL scripts. There are lots of issues and work that
needs to be addressed. Rather than do this in an ad-hoc way now, lets devote
the proper attention to it, given people are sufficiently interested.

-Jonathan R.
---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
IPTEL mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/iptel

---

From: Jonathan Lennox <[email-masked]>
Date: Mon, 13 Nov 2000 18:43:50 -0500 (EST)

> the proper attention to it, given people are sufficiently interested.

I'm in favor of this.

Any thoughts on the issue of the use of the term "action"?  I think that's
my only remaining open issue before sending in the new revision for IESG
last call.

-- 
Jonathan Lennox
[email-masked]