Subject: Re: [Iptel] comments on draft-ietf-iptel-tgrep-01.txt

From: Manjunath Bangalore <[email-masked]>
Date: Wed, 25 Jun 2003 23:18:45 -0700

Hi Bob,

Appreciate your comments about the TGREP draft.
I had a clarification about this one comment of yours.

> Section 3.6.1: The carrier length should be variable. The carrier is usually
> derived from dialed digits, thus deployments will likely use the carrier
> codes used in dialing as TGREP carriers to avoid the additional overhead of
> mapping dialed carrier codes to TGREP carrier codes. The US uses 5-digit
> carrier codes in dialing (e.g. 10288 for AT&T as in 1010288). Is it to be
> assumed that for country code of less than three digits that the 3-octet
> country-code is padded with NULL bytes?

Yes, country codes less than three digits should be padded with NULL bytes, and
this will be specified in the next revision. Given that, would you think there
is reason to make the Carrier code to be variable-length?
Also, for padding ASCII strings, is it common practice to use the "NULL" or the
"blank" character?

Thanks,
-Manjax

_______________________________________________
Iptel mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/iptel

---

From: Michael Hammer <[email-masked]>
Date: Fri, 27 Jun 2003 14:39:46 -0400

Bob,

Reference the 1010288:

101 is a dialing prefix indicating that the following is a carrier code,
0288 is the 4-digit carrier code.

In a sense the 0 before 288 could be considered padding to get to the fixed 
length 4 digit code.

Mike