Subject: [Iptel] Comments on draft-ietf-iptel-trip-mib-06.txt

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 6 Jul 2003 12:18:41 +0300

Here are my comments on the latest TRIP MIB I-D. I congratulate the authors for the considerable improvement of the document, and thank them for taking into account most of my comments in the review of the previous version.

There are still a few problems:

1) smilint complains of two indices possibly exceeding the OID size limitation:

TRIP-MIB.txt:328: [5] {index-exceeds-too-large} warning: index of row `tripRouteTypeEntry' can exceed OID size limit by 138 subidentifier(s)
TRIP-MIB.txt:511: [5] {index-exceeds-too-large} warning: index of row `tripPeerEntry' can exceed OID size limit by 136 subidentifier(s)

This is probably because of use of multiple indices with a  syntax of OBJECT STRING or OBJECT IDENTIFIER. According to  Section 4.6.5 in http://www.ietf.org/internet-drafts/draft-ietf-ops-mib-review-guidelines-01.txt,
' It is RECOMMENDED that all MIB documents make explicit any limitations on index component lengths that management software must observe. This may be done either by including SIZE constraints on the index components or by specifying applicable constraints in the conceptual row DESCRIPTION clause or in the surrounding documentation. '
  
2)  One of my comments in the review of draft-05 was about the need to improve the DESCRIPTION clause of tripRouteUnknown. If I were an implementer, I still do not know what this object is supposed to contain, and how the information is encoded.

3) Two of comments in the previous review were ignored. I would not block this document because of these, but I still think that they were valid, and the authors would like to consider following them for improved readability and consistency.

These comments were:

'4. The readability of the document would be much improved if an abbreviation section would be included. Some of the abbreviations are not detailed, some other are explained only after a few occurrences in the text (LS, ITAD) -- LS is now explained at the first occurrence, but ITAD is still not explained. --
10. 'location server' in the DESCRIPTION clause of tripPeerOutUpdates is inconsistent with the other clauses in the same table where it is abbreviated.'

4) You would like to swap the order of the two phrases that compose Section 4, and remove the double reference in the same section.

5) Year in copyright notes and the Copyright Section should be updated to 2003.

Regards,

Dan

---

From: "David Zinman" <[email-masked]>
Date: Thu, 10 Jul 2003 19:09:20 -0400

Comments on draft-ietf-iptel-trip-mib-06.txtFixes in draft-ietf-iptel-trip-mib-07.txt
  ----- Original Message ----- 
  From: Romascanu, Dan (Dan) 
  To: [email-masked] 
  Cc: Jon Peterson (E-mail) ; Bert Wijnen (E-mail) ; David Zinman ; [email-masked] ; [email-masked] ; [email-masked] ; [email-masked] 
  Sent: Sunday, July 06, 2003 5:18 AM
  Subject: [Iptel] Comments on draft-ietf-iptel-trip-mib-06.txt

Fixed, with appropriate comments.  

I have changed this, with the help of Jonathan Rosenberg to make it much clearer.

  These comments were:

I explain the ITAD in section 5.1 of the draft, before the MIB definitions in section 6. I will add the description to the MIB too.

Missed that one.

Done.

done

  Regards,

  Dan

DZ