Subject: [Iptel] read-only compliance for TRIP MIB

From: "David Zinman" <[email-masked]>
Date: Wed, 14 Jan 2004 09:00:38 -0500

There has been a request to include a "read-only" compliance
section in the TRIP MIB. If most implementations plan on 
doing read-write support then it might not useful. 
However, if there is enough support for read-only compliance,
another draft will be issued to support it.

Comments, preferences??

The decision will be made by Tuesday Jan 20.

DZ

_______________________________________________
Iptel mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/iptel

---

From: Kevin Lingle <[email-masked]>
Date: Wed, 14 Jan 2004 10:11:33 -0500

david,

just as a data point to consider...

in the last call review of ietf sip-mib draft we have
taken a comment that the likelihood of configuration
being done via snmp may be questionable.  agents may
not wish to support those objects as read-write and the
current compliance would not allow them to claim conformance.
therefore, many of the read-write objects that are configuration
parameters will be reorganized alternate object-groups that will
go into an additional module-compliance that agents using
other means to provision the system can claim conformance with.

that sounds a lot like what you've referred to as "read-only"
compliance below, so i would agree that there is value in
the supporting this in the trip mib.

kevin

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 14 Jan 2004 11:03:16 -0500

I concur on this point.

Indeed, our policy for our products is that we do not do configuration 
through snmp; its only use for performance and fault management. As 
such, read-only compliance statements for MIBs would be good.

-Jonathan R.

Kevin Lingle wrote:

>> section in the TRIP MIB. If most implementations plan on doing 
>> read-write support then it might not useful. However, if there is 
>> enough support for read-only compliance,

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: Bob Natale <[email-masked]>
Date: Wed, 14 Jan 2004 12:15:35 -0500

At 1/14/2004:11:03 AM, Jonathan Rosenberg wrote:

Hi Jonathan, everyone:

If you would care to elaborate on your policy, would you
comment on your view of the acceptability of SNMPv3 for
configuration support.

If that view is positive, does anyone think it might be
possible and desirable to do conformance groups based on
SNMPv3 operations?

Cheers,

BobN
- - - - -
>I concur on this point.
>
>Indeed, our policy for our products is that we do not do configuration through snmp; its only use for performance and fault management. As such, read-only compliance statements for MIBs would be good.
>
>-Jonathan R.
>
>Kevin Lingle wrote:
>
>>david,
>>>section in the TRIP MIB. If most implementations plan on doing read-write support then it might not useful. However, if there is enough support for read-only compliance,