Subject: RE: [Iptel] read-only compliance for TRIP MIB

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 14 Jan 2004 20:01:38 +0200

David,

The TRIP MIB has RowStatus objects.  If you intent to provide a read-only compliance version, does this mean that the tables with row creation capabilities will have a fixed number of rows, without the manager being able to create or delete rows in this tables? Please have a look and confirm that this is your intention, and take care to clarify in the document what rows are supposed to be permanent in this situation for each table.

Thanks and Regards,

Dan

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On 
> Behalf Of David Zinman
> Sent: 14 January, 2004 4:01 PM
> To: [email-masked]
> Subject: [Iptel] read-only compliance for TRIP MIB
> 
> 
> There has been a request to include a "read-only" compliance
> section in the TRIP MIB. If most implementations plan on 
> doing read-write support then it might not useful. 
> However, if there is enough support for read-only compliance,
> another draft will be issued to support it.
> 
> Comments, preferences??
> 
> The decision will be made by Tuesday Jan 20.
> 
> DZ
> 
> 
> 
> _______________________________________________
> Iptel mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/iptel
> 

_______________________________________________
Iptel mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/iptel

---

From: "David Zinman" <[email-masked]>
Date: Wed, 14 Jan 2004 22:15:29 -0500

Dan,

I'm not sure I understand what you mean by "permanent". In a read-only
implementation of the MIB, even though the (SNMP) manager cannot add rows to
a table, this does not preclude the TRIP application or other source from
adding rows to the table.

For example, in a read-only MIB representing a routing table, even though
the manager may not add a route (a row), a route might possibly be added or
removed dynamically by the routing application. In such a case there may be
no permanent rows at all.

DZ

----- Original Message ----- 
From: "Romascanu, Dan (Dan)" <[email-masked]>
To: "David Zinman" <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, January 14, 2004 1:01 PM
Subject: RE: [Iptel] read-only compliance for TRIP MIB

David,

The TRIP MIB has RowStatus objects.  If you intent to provide a read-only
compliance version, does this mean that the tables with row creation
capabilities will have a fixed number of rows, without the manager being
able to create or delete rows in this tables? Please have a look and confirm
that this is your intention, and take care to clarify in the document what
rows are supposed to be permanent in this situation for each table.

Thanks and Regards,

Dan