Subject: Re: [its] projects (was: P1609.3 Networking Services and IPv6 AddressAuto-Configuration)

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 15 Jul 2013 16:28:08 +0200

Dirk,

Any idea whether the results of this project use:

- dynamic IPv6 prefix exchanges between vehicles, or between vehicle
   and infrastructure?
- IPv6-straight-over-80211p?
- any form of geonetworking?

Thanks,

Alex

Le 26/06/2013 11:19, [email-masked] a écrit :
> Hi all,
> Speaking of actual use cases it may be of interest that the German project SIMTD - "Safe, Intelligent Mobility - Test field Deutschland (Germany)" has completed to test the functionality, efficacy and feasibility for everyday use of car-to-x communication under real-life driving conditions.  Some detailed information can be found here: http://simtd.de/index.dhtml/0251caae465f8345005d/-/enEN/-/CS/-/ and	
> http://simtd.de/index.dhtml/0251caae465f8345005d/object.media/enEN/8033/CS/-/news/Presse/simTD-Pressemitteilung_2013_EN.pdf
>
> Best regards
> Dirk
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Rex Buddenberg
> Sent: Dienstag, 25. Juni 2013 05:19
> To: Michael Richardson
> Cc: Alison Chaiken; [email-masked]
> Subject: Re: [its] P1609.3 Networking Services and IPv6 AddressAuto-Configuration
>
> Michael,
>
> We might want to consider this the snowplow case; gets past some of your human factors issues.  Try this as a variant to the ambulance/siren illustration.
>
> One of my friends and sounding board for such stuff works for Wyoming DoT.  He observes that the casualty rate among snowplow operators in Wy is higher than among cops.  The typical accident scenario is when the plow is working on I-80 and is overtaken by other traffic, the villain usually a semi.  If the semi driver doesn't figure out that it is a snowplow ahead of him until too late, he's exceeded the intertia/road slickness limits, and rear-ends the plow.  (Trucks as a class are more prone to push the weather limits than the family sedan.  If the family sedan is out in this weather, and is smart, he's tucked in behind the semi).
>      In this case, visibility is routinely awful (it's snowing, and often blowing).  And even if the plow had a siren, the semi driver probably wouldn't hear it until too late.  The sedan behind the semi is in an even worse situation.
>      So this is a good use case for alerting message.
>
>
>
> On Mon, 2013-06-24 at 09:07 -0400, Michael Richardson wrote:
>> Alison Chaiken <[email-masked]> wrote:
>>      alison> If passenger vehicles expect WSM on 802.11p, don't emergency
>>      alison>vehicles then need 802.11p to communicate with them, irrespective
>>      alison>of LTE plans for emergency vehicles?  Assuredly in the Grand
>>      alison>Connected Future we don't expect that emergency vehicles will
>>      alison>communicate with individual drivers via audible alarms and
>>      alison>flashing lights only?  And assuredly having emergency vehicles
>>      alison>call out siren messages over LTE to infrastructure which sends
>>      alison>802.11p would be ridiculous?
>>
>> I don't know that it would be ridiculous to assume this.
>> I agree that the latency might suck.  I presume, however two things:
>>
>> 1) the route the *ambulance* or *fire* truck might take is well known
>>     in advance to the traffic control system ("in advance" is a relative
>>     term, in this I'm saying that 5s >> 0.1s maximum latency).
>>     So it need not be the vehicle *itself* that is calling out it's route,
>>     the vehicle may well be following the route that the traffic control
>>     system has established.
>>
>> 2) my observation is that flashing lights and sirens have two undesireable
>>     affects.  On overly consentious drivers (my mom-in-law, former er nurse),
>>     they yank the wheel, to get out the way, often so fast they nearly
>>     cause a collision themselves, even when the vehicle won't even be
>>     coming near them.
>>     On drivers who day-dream (my mom!  "oh, was there a stop sign back there?")
>>     they don't notice a thing until the vehicle is stuck behind them.
>>
>> It would be very useful to both of them to be told that the vehicle is
>> coming, and that it will in fact affect them.
>>
>>
>> --
>> ]               Never tell me the odds!                 | ipv6 mesh networks [
>> ]   Michael Richardson, Sandelman Software Works        | network architect  [
>> ]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [
>>
>
>
> _______________________________________________
> its mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/its
> _______________________________________________
> its mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/its
>

---

From: Michael Richardson <[email-masked]>
Date: Mon, 15 Jul 2013 12:30:30 -0400

Rex Buddenberg wrote:
> Michael,
>
> We might want to consider this the snowplow case; gets past some of your
> human factors issues.  Try this as a variant to the ambulance/siren
> illustration.
>
> One of my friends and sounding board for such stuff works for Wyoming DoT.
>      He observes that the casualty rate among snowplow operators in Wy is
>      higher than among cops.  The typical accident scenario is when the
>      plow is working on I-80 and is overtaken by other traffic, the villain
>      usually a semi.  If the semi driver doesn't figure out that it is a
>      snowplow ahead of him until too late, he's exceeded the intertia/road
>      slickness limits, and rear-ends the plow.  (Trucks as a class are more
>      prone to push the weather limits than the family sedan.  If the family
>      sedan is out in this weather, and is smart, he's tucked in behind the
>      semi).

>      In this case, visibility is routinely awful (it's snowing, and often
>      blowing).  And even if the plow had a siren, the semi driver probably
>      wouldn't hear it until too late.  The sedan behind the semi is in an
>      even worse situation.

>      So this is a good use case for alerting message.

That's an interesting situation, and I observe (anecdotaly) the same thing in
Ontario.

Way out on the highways, and the side roads, and the like, LTE isn't too
great, and I'm not convinced it will really get better.
I am really un-happy about having to backhaul that stuff: I'd rather have a
protocol that worked vehicle to vehicle.  This is one reason I'd like a
layer-3 (mesh) approach: we can use whatever LTE there is, and whatever 11p
there is, but the GeoNet stuff seems very much layer-2 stuck.

---

From: Andreas Festag <[email-masked]>
Date: Tue, 16 Jul 2013 07:58:20 +0000

simTD has used the ETSI TC ITS protocol stack for communication over 11.p/ITS-G5 and a proprietary solution for communication over cellular.

Kind regards,

Andreas

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Alexandru Petrescu
Sent: Monday, July 15, 2013 4:28 PM
To: [email-masked]
Subject: Re: [its] projects (was: P1609.3 Networking Services and IPv6 AddressAuto-Configuration)

Dirk,

Thanks,

Alex

Le 26/06/2013 11:19, [email-masked] a écrit :
> http://simtd.de/index.dhtml/0251caae465f8345005d/object.media/enEN/803
> 3/CS/-/news/Presse/simTD-Pressemitteilung_2013_EN.pdf
>
> Best regards
> Dirk
>> It would be very useful to both of them to be told that the vehicle 
>> is coming, and that it will in fact affect them.
>>
>>
>> --

---

From: "Dr. Hans-Joachim Fischer" <[email-masked]>
Date: Tue, 16 Jul 2013 13:00:16 +0200

Dear Andreas,

could you please be so kind to tell us which versions of which ETSI 
standard were implemented by which manufacturer for usage in simTD?

Sincerely
Hans-Joachim

-- 
------------------------------------------------------------------------------
ESF online-news:    http://fischer-tech.eu/Feeds/esf.rss
C-ITS online news:  http://its-standards.info/Feeds/cits.rss
------------------------------------------------------------------------------
The information contained in this message is confidential and may be legally privileged. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, dissemination, or reproduction is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.
------------------------------------------------------------------------------
Dr. Hans-Joachim Fischer
ESF GmbH
Fichtenweg 9
89143 Blaubeuren
+49 (7344) 175340
+49 (7344) 919123 (Fax)
http://fischer-tech.eu : Main web of ESF GmbH
http://its-standards.eu : News on cooperative ITS standardization
http://its-testing.org : International consultancy for cooperative ITS
------------------------------------------------------------------------------

---

From: <[email-masked]>
Date: Tue, 16 Jul 2013 17:34:11 +0200

Hello Alex,
Concerning your questions my impression is (if I understood it correctly form available documents) that SimTD did not specify IPv6 Prefix Exchange since the protocol stack shows IPv6 over IPv4 over 802.11p and other wireless and cellular technologies - so I would guess that also no IPv6 straight over 802.11p.
There are Geoservers with polling Lat/Lon from the vehicles (and distributing Geo data for warnings etc.)  
I anyone is more involved and can help with details, I would be glad!

Best regards
Dirk
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Alexandru Petrescu
Sent: Montag, 15. Juli 2013 16:28
To: [email-masked]
Subject: Re: [its] projects (was: P1609.3 Networking Services and IPv6 AddressAuto-Configuration)

Dirk,

Thanks,

Alex

---

From: "Dr. Hans-Joachim Fischer" <[email-masked]>
Date: Tue, 16 Jul 2013 17:46:55 +0200

IPv6 over 802.11p:
Yes, this is in our scope. We, at ISO TC204 WG16, are developing a suite 
of standards on how to use IPv6 in the context of an ITS station. There 
is no restriction at all on how to use IPv6. At ETSI they only want to 
have IP over GeoNetworking, which bears significant technical risks. 
Whether to use IPv6 over 802.11p narrow band channels with quickly 
moving stations depends on the road scenario (potentially this is 
reasonable for roadside to car communications), the traffic scenario 
(how many stations are trying to use the same channel).

Dissemination of Geo Data, i.e. geo-dissemination of information (the 
term we are using at ISO) can be done with different protocols. 
GeoNetworking is, in my opinion, the uppermost useless tool to do it in 
5,9 GHz channels. There is an excellent idea to use IPv6. And this will 
go over any kind of access technology (802.11p, CNs, Internet).

Sincerely
Hans-Joachim

---

From: Andreas Festag <[email-masked]>
Date: Wed, 17 Jul 2013 15:15:16 +0000

Dear Dirk,

AFAIK, simTD did not apply IP over 802.11p (neither IPv4 nor IPv6).

Kind regards,

Andreas

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, July 16, 2013 5:34 PM
To: [email-masked]; [email-masked]
Subject: Re: [its] projects (was: P1609.3 Networking Services and IPv6 AddressAuto-Configuration)

Hello Alex,
Concerning your questions my impression is (if I understood it correctly form available documents) that SimTD did not specify IPv6 Prefix Exchange since the protocol stack shows IPv6 over IPv4 over 802.11p and other wireless and cellular technologies - so I would guess that also no IPv6 straight over 802.11p.
There are Geoservers with polling Lat/Lon from the vehicles (and distributing Geo data for warnings etc.) I anyone is more involved and can help with details, I would be glad!

Best regards
Dirk
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Alexandru Petrescu
Sent: Montag, 15. Juli 2013 16:28
To: [email-masked]
Subject: Re: [its] projects (was: P1609.3 Networking Services and IPv6 AddressAuto-Configuration)

Dirk,

Thanks,

Alex