Subject: [geonet/its] Question about scoping

From: Melinda Shore <[email-masked]>
Date: Thu, 30 Jan 2014 09:28:46 -0900

I'd like to start a discussion about potential scope and how
it's impacted (or not) by particular use cases.  In particular
it's pretty clear that disseminating IP packets to geographic
locations is in scope.  It is less clear that identifying the
location of a sender is, and we should talk about that
(particularly in the context of current efforts to harden the
internet against eavesdropping and other privacy invasions).

The current use case that addresses this most directly is
the one regarding an ISP using source geolocation for traffic
engineering.  I think we need to be much clearer about why
this would need to be solved using an IP address/geolocation
mapping rather than some other mechanism and why this would
fall within the same set of work items as geographic packet
dissemination.  Because operators already know who their
customers are, what addresses are assigned to them, which
cable is plugged into which port on a router, and so on, we'd
need to identify what's currently not known and (again)
why an address-to-location mapping is the right way to solve
it.  We'd also need to be prepared to respond to some rather
difficult questions about subscriber privacy.

We do not need a long list of use cases.  We do need a few
compelling ones along with an argument for why we think the
approach we've been discussing is the right way to address
those use cases.  So, I think we need to either strengthen
the address-to-locator mapping use case, or drop it.  How
do you all feel about this?

Melinda

---

From: Eliot Lear <[email-masked]>
Date: Thu, 30 Jan 2014 19:49:44 +0100

Hi Melinda,

> internet against eavesdropping and other privacy invasions).

This is a great question, and it's an important question with regard to
privacy.

As I see it, it depends on whether one expects to engage in two way
communications.  If one does not, then why would one need to have the
location of the sender.  If one does, then the location of the sender
may become self-evident (e.g., by acting on something that was scoped).

> difficult questions about subscriber privacy.

One of the questions we would need to answer, I think, is what physical
interfaces can be assumed, if any.  Are we requiring that 802.11p be
deployed?  If not, are we anticipating separate cell networks from the
geonet?

Eliot

---

From: Melinda Shore <[email-masked]>
Date: Thu, 30 Jan 2014 11:20:22 -0900

> may become self-evident (e.g., by acting on something that was scoped).

Yes, but that's not quite the same as maintaining a
mapping.  Clearly it's the case that unless mitigations
are put in place an attacker could send out a broadcast
to a particular location and see who's there by looking
at responses (if, in fact, there are any).  But that's
not quite the same as "I want to find where the holder of
IP address 123.345.567.789 is right now."  Package
tracking is probably a much stronger use case for this
sort of thing than traffic engineering but even so it's
probably worth asking why current technologies are
inadequate.  We're looking for problems that have not
been solved, or have been solved but badly, rather
than trying to develop a laundry list of things that
could possibly be done with this technology, I
believe.

Melinda

---

From: Abdussalam Baryun <[email-masked]>
Date: Sat, 1 Feb 2014 02:22:47 +0100

On Thursday, January 30, 2014, Melinda Shore wrote:

> it.

Because IMHO it is the easiest way to solve it, there may be other ways but
all organisations start simple.

> those use cases.

I agree,

> So, I think we need to either strengthen
> the address-to-locator mapping use case, or drop it.

Why we think it is better to strengthen used use cases? Usually if a case
is used in real life and IETF is missing the community practice I think
IETF needs to strengthen its work to follow reality but not ignore why they
used it.

> How

I don't think to have only two way directions (strength or drop) ,
how about adding two other directions; simplest cases available and
practical cases used.

AB

---

From: Abdussalam Baryun <[email-masked]>
Date: Sat, 1 Feb 2014 02:36:51 +0100

On Thursday, January 30, 2014, Eliot Lear wrote:

> > In particular
> location of the sender.

Each location may have special service. So the applications need locations
information.

> If one does, then the location of the sender

What does this mean? Is it advantage or disadvantage?

> deployed?  If not, are we anticipating separate cell networks from the

IMHO Physical interface is to be used only not depending on it.

---

From: Abdussalam Baryun <[email-masked]>
Date: Sat, 1 Feb 2014 02:53:39 +0100

On Thursday, January 30, 2014, Melinda Shore wrote:
>   But that's
> inadequate.

There is mobile IP for that discovery as RFC3775. An extension to that may
be needed for our geonet-its protocols.

We're looking for problems that have not
> been solved, or have been solved but badly,

Why badly? And who solved it badly?

AB