Subject: Re: [ipwave] [its] I-D Action: draft-li-ipv4-over-80211ocb-00.txt

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 1 Feb 2017 13:24:22 +0100

Hi Gonzalo,

There have been multiple private comments about IPv4 on .11-OCB since Seoul.

- IPv6 importance in US may be due at least partly to gov't mandates
   of 2008, [2011 witnessed last IPv4], 2012 and 2014.  No other later.
   IPv6 deployment stats exist.

IMHO there are similar mandates at least in Europe, issued by gov't, by 
comm regulators, and other enforcement bodies.

- there exist many IETF means of co-existence between IPv4 and IPv6
   such as dual-stack, IPv6 connection using IPv4 tunneling, and
   translation techniques.

I agree.

- many IEEE 802 MAC/PHY specs already work with IPv4 and equally well
   with IPv6.  Maybe in 802.11 the "Traffic Classification (TCLAS)"
   there could be a need for distinction of IPv4 from IPv6.

Hold on - I can't find a field called TCLAS.  But there is a field 
called "Type" in the LLC header, coloquially known as "Ethertype" 
(0x0800 for IPv4 and 0x86dd for IPv6).  To add to the surprise, there is 
also a field called "Traffic Class" in the IPv6 header which has nothing 
to do with IPv4.

- the IEEE 1609 and WAVE state “The WAVE standards support Internet
   Protocol (IP) version 6 (v6) [B21]. IPv6 was selected over IPv4
   because IPv6 is expected to be a viable protocol into the foreseeable
   future, whereas the long term future of IPv4 is less certain.
   (Although not described in the WAVE standards, IPv4 has been tunneled
   over IPv6 in WAVE trials.)”.

IMHO 1609 should do native IPv4 as well.

Yours,

Alex

Le 01/12/2016 à 06:35, Gonzalo Salgueiro (gsalguei) a écrit :
> Hi IPWAVErs -
>
> We have just published a draft documenting how IPv4 is encoded over
> 802.11OCB.  You can find it here:
>
> https://tools.ietf.org/html/draft-li-ipv4-over-80211ocb-00
>
> We are fully aware that the WG is focused on IPv6 and that in Seoul
> there was consensus to remove IPv4 from draft-petrescu-ipv6-over-80211p.
>  I believe that at the last meeting the decision was to use an
> individual submission for IPv4 and that WG/chairs would determine how
> best to coordinate with this.
>
> I speak for the other authors and collaborators of this draft when I say
> that we’re all strongly in favor of an IPv6 focus for the WG.  It seems
> we may have a subtle disagreement on the need to simply document how
> IPv4 is to be encoded, especially in light of how consistent the
> alignment is with IPv6.  Obviously, our preference would be for the work
> (IPv4 over 802.11OCB) to be done officially by the WG since it seems an
> almost trivial exercise and with minimal overhead.  That said, we’re not
> here to trump WG consensus, so at this point we are making the WG aware
> of the existence of this draft and looking for any reviews and comments
> to improve the document.  Additionally, we’d greatly appreciate any
> coordination assistance and guidance on how best (and most efficiently)
> to get this individual submission progressed.
>
> Thanks,
>
> Gonzalo
>
>
>> On Nov 30, 2016, at 4:43 PM, [email-masked]
>> <mailto:[email-masked]> wrote:
>>
>>
>> A New Internet-Draft is available from the on-line Internet-Drafts
>> directories.
>>
>>
>>        Title           : Transmission of IPv4 over IEEE 802.11 in OCB mode
>>        Authors         : Tony Li
>>                          Gonzalo Salgueiro
>>                          Dino Farinacci
>> Filename        : draft-li-ipv4-over-80211ocb-00.txt
>> Pages           : 12
>> Date            : 2016-11-30
>>
>> Abstract:
>>   This document describes the transmission of IPv4 packets over IEEE
>>   802.11-2012 networks when run Outside the Context of a BSS
>>   (802.11-OCB, earlier known as 802.11p).
>>
>>
>> The IETF datatracker status page for this draft is:
>> https://datatracker.ietf.org/doc/draft-li-ipv4-over-80211ocb/
>>
>> There's also a htmlized version available at:
>> https://tools.ietf.org/html/draft-li-ipv4-over-80211ocb-00
>>
>>
>> Please note that it may take a couple of minutes from the time of
>> submission
>> until the htmlized version and diff are available at tools.ietf.org.
>>
>> Internet-Drafts are also available by anonymous FTP at:
>> ftp://ftp.ietf.org/internet-drafts/
>>
>> _______________________________________________
>> I-D-Announce mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/i-d-announce
>> Internet-Draft directories: http://www.ietf.org/shadow.html
>> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>
>
> _______________________________________________
> its mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/its
>

---

From: "Gonzalo Salgueiro (gsalguei)" <[email-masked]>
Date: Wed, 1 Feb 2017 12:38:41 +0000

Thanks, Alexandre.  Good info.  Can you clarify whether you view these as primarily informational or whether they will/should have impacts on the text of IPv4 .11-OCB draft?

Cheers,

Gonzalo

On Feb 1, 2017, at 1:24 PM, Alexandre Petrescu <[email-masked]<mailto:[email-masked]>> wrote:

Hi Gonzalo,

IMHO there are similar mandates at least in Europe, issued by gov't, by comm regulators, and other enforcement bodies.

I agree.

Hold on - I can't find a field called TCLAS.  But there is a field called "Type" in the LLC header, coloquially known as "Ethertype" (0x0800 for IPv4 and 0x86dd for IPv6).  To add to the surprise, there is also a field called "Traffic Class" in the IPv6 header which has nothing to do with IPv4.

Yours,

Alex

Thanks,

Gonzalo

Abstract:

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 1 Feb 2017 13:56:46 +0100

Primarily informational.

As a side note, if there is such a thing as TCLAS that I dont know, then 
we should reflect it in both v[46] .11-OCB drafts.

What is TCLAS at IEEE?  Can we assume it to be the regular Ethertype field?

Alex

Le 01/02/2017 à 13:38, Gonzalo Salgueiro (gsalguei) a écrit :
> Thanks, Alexandre.  Good info.  Can you clarify whether you view these
> as primarily informational or whether they will/should have impacts on
> the text of IPv4 .11-OCB draft?
>
> Cheers,
>
> Gonzalo
>
>> On Feb 1, 2017, at 1:24 PM, Alexandre Petrescu
>> <[email-masked] <mailto:[email-masked]>>
>> wrote:
>>
>> Hi Gonzalo,
>>
>> IMHO there are similar mandates at least in Europe, issued by gov't,
>> by comm regulators, and other enforcement bodies.
>>
>> (0x0800 for IPv4 and 0x86dd for IPv6).  To add to the surprise, there
>> is also a field called "Traffic Class" in the IPv6 header which has
>> nothing to do with IPv4.
>>

---

From: "Gonzalo Salgueiro (gsalguei)" <[email-masked]>
Date: Wed, 1 Feb 2017 14:25:33 +0000

> On Feb 1, 2017, at 1:56 PM, Alexandre Petrescu <[email-masked]> wrote:
> 
> Primarily informational.

Good that was my take on it as well.

> As a side note, if there is such a thing as TCLAS that I dont know, then we should reflect it in both v[46] .11-OCB drafts.
> 

TCLAS was an information element in 802.11e QoS. 

Cheers,

Gonzalo

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 2 Feb 2017 16:16:46 +0100

ok we'll go with ethertype

Le 01/02/2017 à 20:28, Dick Roy a écrit :
> 1)     EPD is used almost everywhere now (Europe is the only problem
> left), so the LLC sublayer header is composed of ONLY a two-octet
> Ethertype.
>
> 2)     Nothing prevents that ethertype from specifying IPv4
>
> 3)     To be compliant with US, ISO and ETSI standards, all devices that
> support IP must support IPv6.
>
> 4)     Any regulatory body (governmental or otherwise) is free to create
> deployment specifications that require other protocols such as IPv4,
> they just might not interoperate in other regions (which is the whole
> reason for the international standards in the first place).
>
>
>
> Cheers,
>
>
>
> RR
>
> ------------------------------------------------------------------------
>
> *From:*Gonzalo Salgueiro (gsalguei) [mailto:[email-masked]]
> *Sent:* Wednesday, February 1, 2017 4:39 AM
> *To:* Alexandre Petrescu
> *Cc:* Tony Li; [email-masked]
> *Subject:* Re: [ipwave] [its] I-D Action: draft-li-ipv4-over-80211ocb-00.txt
>
>
>

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 2 Feb 2017 18:29:01 +0100

Le 01/02/2017 à 15:25, Gonzalo Salgueiro (gsalguei) a écrit :
>> As a side note, if there is such a thing as TCLAS that I dont know,
>> then we should reflect it in both v[46] .11-OCB drafts.
>>

'Was' means it is no longer?

'Information Element' means that it is not a field in a header, but a
set of many more such fields possibly stored, and not necessarily
transmitted?

Alex

>>> Thanks, Alexandre.  Good info.  Can you clarify whether you view
>>> these as primarily informational or whether they will/should have
>>> impacts on the text of IPv4 .11-OCB draft?
>>>
>>> Cheers,
>>>
>>> Gonzalo
>>>
>>>> <[email-masked]
>>>> <mailto:[email-masked]>> wrote:
>>>>
>>>> Hi Gonzalo,
>>>>
>>>> - IPv6 importance in US may be due at least partly to gov't
>>>> mandates of 2008, [2011 witnessed last IPv4], 2012 and 2014.
>>>> No other later. IPv6 deployment stats exist.
>>>>
>>>> IMHO there are similar mandates at least in Europe, issued by
>>>> gov't, by comm regulators, and other enforcement bodies.
>>>>
>>>> - there exist many IETF means of co-existence between IPv4 and
>>>> IPv6 such as dual-stack, IPv6 connection using IPv4 tunneling,
>>>> and translation techniques.
>>>>
>>>> I agree.
>>>>
>>>> - many IEEE 802 MAC/PHY specs already work with IPv4 and
>>>> equally well with IPv6.  Maybe in 802.11 the "Traffic
>>>> Classification (TCLAS)" there could be a need for distinction
>>>> of IPv4 from IPv6.
>>>>
>>>> Hold on - I can't find a field called TCLAS.  But there is a
>>>> field called "Type" in the LLC header, coloquially known as
>>>> "Ethertype" (0x0800 for IPv4 and 0x86dd for IPv6).  To add to
>>>> the surprise, there is also a field called "Traffic Class" in
>>>> the IPv6 header which has nothing to do with IPv4.
>>>>
>>>> - the IEEE 1609 and WAVE state “The WAVE standards support
>>>> Internet Protocol (IP) version 6 (v6) [B21]. IPv6 was selected
>>>> over IPv4 because IPv6 is expected to be a viable protocol into
>>>> the foreseeable future, whereas the long term future of IPv4 is
>>>> less certain. (Although not described in the WAVE standards,
>>>> IPv4 has been tunneled over IPv6 in WAVE trials.)”.
>>>>
>>>>> We have just published a draft documenting how IPv4 is
>>>>> encoded over 802.11OCB.  You can find it here:
>>>>>
>>>>> We are fully aware that the WG is focused on IPv6 and that in
>>>>> Seoul there was consensus to remove IPv4 from
>>>>> draft-petrescu-ipv6-over-80211p. I believe that at the last
>>>>> meeting the decision was to use an individual submission for
>>>>> IPv4 and that WG/chairs would determine how best to
>>>>> coordinate with this.
>>>>>
>>>>> I speak for the other authors and collaborators of this draft
>>>>> when I say that we’re all strongly in favor of an IPv6 focus
>>>>> for the WG.  It seems we may have a subtle disagreement on
>>>>> the need to simply document how IPv4 is to be encoded,
>>>>> especially in light of how consistent the alignment is with
>>>>> IPv6.  Obviously, our preference would be for the work (IPv4
>>>>> over 802.11OCB) to be done officially by the WG since it
>>>>> seems an almost trivial exercise and with minimal overhead.
>>>>> That said, we’re not here to trump WG consensus, so at this
>>>>> point we are making the WG aware of the existence of this
>>>>> draft and looking for any reviews and comments to improve the
>>>>> document.  Additionally, we’d greatly appreciate any
>>>>> coordination assistance and guidance on how best (and most
>>>>> efficiently) to get this individual submission progressed.
>>>>>
>>>>> Thanks,
>>>>>
>>>>> Gonzalo
>>>>>
>>>>>
>>>>>> A New Internet-Draft is available from the on-line
>>>>>> Internet-Drafts directories.
>>>>>>
>>>>>>
>>>>>> Title           : Transmission of IPv4 over IEEE 802.11 in
>>>>>> OCB mode Authors         : Tony Li Gonzalo Salgueiro Dino
>>>>>> Farinacci Filename        :
>>>>>> draft-li-ipv4-over-80211ocb-00.txt Pages           : 12
>>>>>> Date            : 2016-11-30
>>>>>>
>>>>>> Abstract: This document describes the transmission of IPv4
>>>>>> packets over IEEE 802.11-2012 networks when run Outside the
>>>>>> Context of a BSS (802.11-OCB, earlier known as 802.11p).
>>>>>>
>>>>>>
There's also a htmlized version available at:
>>>>>> Please note that it may take a couple of minutes from the
>>>>>> time of submission until the htmlized version and diff are
>>>>>> available at tools.ietf.org.
>>>>>>
>>>>>> I-D-Announce mailing list [email-masked]
>>>>>> Internet-Draft directories:
>>>>>> http://www.ietf.org/shadow.html or
>>>>>> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>>>>>
>>>>>
>>>>>
>>>>> _______________________________________________ its mailing
>>>>> list [email-masked] https://www.ietf.org/mailman/listinfo/its
>>>
>

---

From: "Gonzalo Salgueiro (gsalguei)" <[email-masked]>
Date: Thu, 2 Feb 2017 23:02:03 +0000

Hi Alexandre -

On Feb 2, 2017, at 6:29 PM, Alexandre Petrescu <[email-masked]<mailto:[email-masked]>> wrote:

On Feb 1, 2017, at 1:56 PM, Alexandre Petrescu
<[email-masked]<mailto:[email-masked]>> wrote:

Primarily informational.

What is TCLAS at IEEE?  Can we assume it to be the regular
Ethertype field?

Poor choice of words.  It is still in the latest IEEE-802.11 Standard,

"traffic classification (TCLAS): The specification of certain parameter values to identify a protocol data unit(#2222) (PDU) or a medium access control (MAC) service data unit (MSDU). The classification process is(#2223) performed above the MAC service access point (MAC SAP(#3409)), within the MLME, or within the MAC, based on the type of classification.(#78)"

All details (primitives, elements, procedures) are specified in the standard.

-G

Alex

Cheers,

Gonzalo

Alex

Cheers,

Gonzalo

On Feb 1, 2017, at 1:24 PM, Alexandre Petrescu
<[email-masked]<mailto:[email-masked]>
<mailto:[email-masked]>> wrote:

Hi Gonzalo,

There have been multiple private comments about IPv4 on .11-OCB
since Seoul.

I agree.

Yours,

Alex

Thanks,

Gonzalo

_______________________________________________ its mailing
list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/its

---

From: M Montemurro <[email-masked]>
Date: Thu, 02 Feb 2017 18:25:47 -0500

The TCLAS element is used in WLAN admission control requests to indicate the mapping of DSCP or ToS to IEEE 802.11 priority.

Cheers,

Mike

Sent from my BlackBerry - the most secure mobile device - via the Bell Network

From: [email-masked]

Sent: February 2, 2017 6:02 PM

To: [email-masked]

Cc: [email-masked]; [email-masked]

Subject: Re: [ipwave] TCLAS

Hi Alexandre -

On Feb 2, 2017, at 6:29 PM, Alexandre Petrescu <[email-masked]> wrote:

<[email-masked]> wrote:

Primarily informational.

Ethertype field?

"traffic classification (TCLAS): The specification of certain parameter values to identify a protocol data unit(#2222)
(PDU) or a medium access control (MAC) service data unit (MSDU). The classification process is(#2223) performed above the MAC service access point (MAC SAP(#3409)), within the MLME, or within the
MAC, based on the type of classification.(#78)"

-G

transmitted?

Alex

Cheers,

Gonzalo

Alex

Cheers,

Gonzalo

Hi Gonzalo,

since Seoul.

I agree.

of IPv4 from IPv6.

...

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 3 Feb 2017 13:37:42 +0100

Hi Gonzalo,

Le 03/02/2017 à 00:02, Gonzalo Salgueiro (gsalguei) a écrit :
> Hi Alexandre -
>
>> On Feb 2, 2017, at 6:29 PM, Alexandre Petrescu
>>>> As a side note, if there is such a thing as TCLAS that I dont
>>>> know, then we should reflect it in both v[46] .11-OCB drafts.
>>>>
> "*traffic classification (TCLAS*): The specification of certain
> parameter values to identify a protocol data unit(#2222) (PDU) or a
> medium access control (MAC) service data unit (MSDU). The
> classification process is(#2223) performed above the MAC service
> access point (MAC SAP(#3409)), within the MLME, or within the MAC,
> based on the type of classification.(#78)"
>

There is an obvious need to map a TCLAS of that standard in the Traffic
Class field of the IPv6 header.  This would help with an enormous amount
of need o traffic differentiation in the 802.11-OCB world: instead of
differentiating channelled frequencies (currently 6 channels each for a 
different app) differentiate by TCLAS/TraficClass fields.  Instead of 
putting an emergency message on a particular channel, tag it with a 
specific traffic class, as packet processing, instead of as circuit 
switching.

At this time there is no such draft, and as such I will not talk about
TCLAS in the IPv6/OCB draft.

Yours,

Alex

>
>
> -G
>
>
>>
>> 'Information Element' means that it is not a field in a header, but
>> a set of many more such fields possibly stored, and not
>> necessarily transmitted?
>>
>> Alex
>>
>>>
>>> Cheers,
>>>
>>> Gonzalo
>>>
>>>>
>>>> Alex
>>>>
>>>>
>>>>> Thanks, Alexandre.  Good info.  Can you clarify whether you
>>>>> view these as primarily informational or whether they
>>>>> will/should have impacts on the text of IPv4 .11-OCB draft?
>>>>>
>>>>> Cheers,
>>>>>
>>>>> Gonzalo
>>>>>
>>>>>> <mailto:[email-masked]>
>>>>>> - IPv6 importance in US may be due at least partly to
>>>>>> gov't mandates of 2008, [2011 witnessed last IPv4], 2012
>>>>>> and 2014. No other later. IPv6 deployment stats exist.
>>>>>>
>>>>>> IMHO there are similar mandates at least in Europe, issued
>>>>>> by gov't, by comm regulators, and other enforcement
>>>>>> bodies.
>>>>>>
>>>>>> - there exist many IETF means of co-existence between IPv4
>>>>>> and IPv6 such as dual-stack, IPv6 connection using IPv4
>>>>>> tunneling, and translation techniques.
>>>>>>
>>>>>> I agree.
>>>>>>
>>>>>> Classification (TCLAS)" there could be a need for
>>>>>> distinction of IPv4 from IPv6.
>>>>>>
>>>>>> Hold on - I can't find a field called TCLAS.  But there is
>>>>>> a field called "Type" in the LLC header, coloquially known
>>>>>> as "Ethertype" (0x0800 for IPv4 and 0x86dd for IPv6).  To
>>>>>> add to the surprise, there is also a field called "Traffic
>>>>>> Class" in the IPv6 header which has nothing to do with
>>>>>> IPv4.
>>>>>>
>>>>>> Internet Protocol (IP) version 6 (v6) [B21]. IPv6 was
>>>>>> selected over IPv4 because IPv6 is expected to be a viable
>>>>>> protocol into the foreseeable future, whereas the long term
>>>>>> future of IPv4 is less certain. (Although not described in
>>>>>> the WAVE standards, IPv4 has been tunneled over IPv6 in
>>>>>> WAVE trials.)”.
>>>>>>
>>>>>>> draft-petrescu-ipv6-over-80211p. I believe that at the
>>>>>>> last meeting the decision was to use an individual
>>>>>>> submission for IPv4 and that WG/chairs would determine
>>>>>>> how best to coordinate with this.
>>>>>>>
>>>>>>> I speak for the other authors and collaborators of this
>>>>>>> draft when I say that we’re all strongly in favor of an
>>>>>>> IPv6 focus for the WG.  It seems we may have a subtle
>>>>>>> disagreement on the need to simply document how IPv4 is
>>>>>>> to be encoded, especially in light of how consistent the
>>>>>>> alignment is with IPv6.  Obviously, our preference would
>>>>>>> be for the work (IPv4 over 802.11OCB) to be done
>>>>>>> officially by the WG since it seems an almost trivial
>>>>>>> exercise and with minimal overhead. That said, we’re not
>>>>>>> here to trump WG consensus, so at this point we are
>>>>>>> making the WG aware of the existence of this draft and
>>>>>>> looking for any reviews and comments to improve the
>>>>>>> coordination assistance and guidance on how best (and
>>>>>>> most efficiently) to get this individual submission
>>>>>>> progressed.
>>>>>>>
>>>>>>> Thanks,
>>>>>>>
>>>>>>> Gonzalo
>>>>>>>
>>>>>>>
>>>>>>>> Title           : Transmission of IPv4 over IEEE 802.11
>>>>>>>> in OCB mode Authors         : Tony Li Gonzalo Salgueiro
>>>>>>>> Dino Farinacci Filename        :
>>>>>>>> draft-li-ipv4-over-80211ocb-00.txt Pages           :
>>>>>>>> 12 Date            : 2016-11-30
>>>>>>>>
>>>>>>>> Abstract: This document describes the transmission of
>>>>>>>> IPv4 packets over IEEE 802.11-2012 networks when run
>>>>>>>> Outside the Context of a BSS (802.11-OCB, earlier known
>>>>>>>> as 802.11p).
>>>>>>>>
>>>>>>>>
>>>>>>>> time of submission until the htmlized version and diff
>>>>>>>> are available at tools.ietf.org.
>>>>>>>>
>>>>>>>> Internet-Drafts are also available by anonymous FTP
>>>>>>>> at: ftp://ftp.ietf.org/internet-drafts/
>>>>>>>>
>>>>>>> _______________________________________________ its
>>>>>>> mailing list [email-masked] <mailto:[email-masked]>
> _______________________________________________ its mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/its
>

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 3 Feb 2017 13:40:05 +0100

Could a DSCP of an IPv6 Traffic Class field (not IPv4 ToS field) also be 
mapped into an 802.11 priority?

Alex

Le 03/02/2017 à 00:25, M Montemurro a écrit :
> The TCLAS element is used in WLAN admission control requests to indicate
> the mapping of DSCP or ToS to IEEE 802.11 priority.
>
> Cheers,
>
> Mike
>
> *From:* [email-masked]
> *Sent:* February 2, 2017 6:02 PM
> *To:* [email-masked]
> *Cc:* [email-masked]; [email-masked]
> *Subject:* Re: [ipwave] TCLAS
>
>
> Hi Alexandre -
>
> medium access control (MAC) service data unit (MSDU). The classification
> process is(#2223) performed above the MAC service access point (MAC
> SAP(#3409)), within the MLME, or within the MAC, based on the type of
> classification.(#78)"
>
>>>>>> <[email-masked] <mailto:[email-masked]>
> *...*

---

From: M Montemurro <[email-masked]>
Date: Fri, 03 Feb 2017 10:05:17 -0500

Yes, there are a set of classifier fields for IPv6.

  Original Message  
From: [email-masked]
Sent: February 3, 2017 7:40 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [ipwave] TCLAS

Alex

---

From: M Montemurro <[email-masked]>
Date: Fri, 3 Feb 2017 10:09:35 -0500

That being said, I'm not sure what IEEE 802.11 frame would include a TCLAS
element. As I said earlier, TCLAS elements are included in an Admission
Control request (ADDTS frame). ADDTS frames are not currently specified for
use with OCB.