Subject: [ipwave] I-D Action: draft-ietf-ipwave-ipv6-over-80211ocb-02.txt

From: [email-masked]
Date: Sun, 12 Mar 2017 12:59:41 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the IP Wireless Access in Vehicular Environments of the IETF.

        Title           : Transmission of IPv6 Packets over IEEE 802.11 Networks in mode Outside the Context of a Basic Service Set (IPv6-over-80211ocb)
        Authors         : Alexandre Petrescu
                          Nabil Benamar
                          Jérôme Härri
                          Christian Huitema
                          Jong-Hyouk Lee
                          Thierry Ernst
                          Tony Li
	Filename        : draft-ietf-ipwave-ipv6-over-80211ocb-02.txt
	Pages           : 33
	Date            : 2017-03-12

Abstract:
   In order to transmit IPv6 packets on IEEE 802.11 networks run outside
   the context of a basic service set (OCB, earlier "802.11p") there is
   a need to define a few parameters such as the recommended Maximum
   Transmission Unit size, the header format preceding the IPv6 header,
   the Type value within it, and others.  This document describes these
   parameters for IPv6 and IEEE 802.11 OCB networks; it portrays the
   layering of IPv6 on 802.11 OCB similarly to other known 802.11 and
   Ethernet layers - by using an Ethernet Adaptation Layer.

   In addition, the document attempts to list what is different in
   802.11 OCB (802.11p) compared to more 'traditional' 802.11a/b/g/n
   layers, layers over which IPv6 protocols operates without issues.
   Most notably, the operation outside the context of a BSS (OCB) has
   impact on IPv6 handover behaviour and on IPv6 security.

   An example of an IPv6 packet captured while transmitted over an IEEE
   802.11 OCB link (802.11p) is given.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ipwave-ipv6-over-80211ocb/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-ipwave-ipv6-over-80211ocb-02

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-ipwave-ipv6-over-80211ocb-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Alexandre Petrescu <[email-masked]>
Date: Sun, 12 Mar 2017 21:04:31 +0100

Hi participants in IPWAVE WG,

This new version of the draft addresses comments received recently from 
Michelle Wetterwald and Dick Roy.

Please use this draft for further discussion.

This is the draft that will be discussed in Chicago.

The changelog is:
o Replaced almost all occurences of 802.11p with 802.11-OCB, leaving
   only when explanation of evolution was necessary.
o Shortened by removing parameter details from a paragraph in the
   Introduction.
o Moved a reference from Normative to Informative.
o Added text in intro clarifying there is no handover spec at IEEE,
   and that 1609.2 does provide security services.
o Named the contents the fields of the EthernetII header (including
   the Ethertype bitstring).
o Improved relationship between two paragraphs describing the
   increase of the Sequence Number in 802.11 header upon IP
   fragmentation.
o Added brief clarification of "tracking".

Alex

Le 12/03/2017 à 20:59, [email-masked] a écrit :
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 17 Mar 2017 17:35:39 +0100

Hello IPWAVErs,

The following questioning was made about this text:
> The IPv6 network layer operates on 802.11 OCB in the same manner as
> it operates on 802.11 WiFi.

The question is "if 802.11 OCB operates like 802.11 WiFi, then what is
the point of 802.11 OCB?"

My answer to this is that the reader should read it better.  The text
does not say that 802.11 OCB operates like 802.11 WiFi does.  The text
says that the IPv6 network layer operates on OCB as on WiFi.

That does not mean OCB operates the same as WiFi.

As such there is no need to improve the text.

What do you think, François ?

If, on the other hand, the question was about how IPv6 operates on WiFi,
then I could agree with some consequences of some of the potential
answers...

Alex

Le 12/03/2017 à 20:59, [email-masked] a écrit :
>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories. This draft is a work item of the IP Wireless Access in
> Vehicular Environments of the IETF.
>
> Title           : Transmission of IPv6 Packets over IEEE 802.11
> Networks in mode Outside the Context of a Basic Service Set
> (IPv6-over-80211ocb) Authors         : Alexandre Petrescu Nabil
> Benamar Jérôme Härri Christian Huitema Jong-Hyouk Lee Thierry Ernst
> Tony Li Filename        :
> draft-ietf-ipwave-ipv6-over-80211ocb-02.txt Pages           : 33 Date
> : 2017-03-12
>
> Abstract: In order to transmit IPv6 packets on IEEE 802.11 networks
> run outside the context of a basic service set (OCB, earlier
> "802.11p") there is a need to define a few parameters such as the
> recommended Maximum Transmission Unit size, the header format
> preceding the IPv6 header, the Type value within it, and others.
> This document describes these parameters for IPv6 and IEEE 802.11 OCB
> networks; it portrays the layering of IPv6 on 802.11 OCB similarly to
> other known 802.11 and Ethernet layers - by using an Ethernet
> Adaptation Layer.
>
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
>
> _______________________________________________ I-D-Announce mailing
> list [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce Internet-Draft
> directories: http://www.ietf.org/shadow.html or
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

---

From: François Simon <[email-masked]>
Date: Mon, 20 Mar 2017 10:54:13 -0400

My apologies; error on my part (misinterpretation).   Fygs

-----Original Message-----
From: its [mailto:[email-masked]] On Behalf Of Alexandre Petrescu
Sent: Friday, March 17, 2017 12:36 PM
Cc: [email-masked]
Subject: Re: [ipwave] draft-ietf-ipwave-ipv6-over-80211ocb-02.txt - IPv6 on OCB as on WiFi

Hello IPWAVErs,

The following questioning was made about this text:
> The IPv6 network layer operates on 802.11 OCB in the same manner as it 
> operates on 802.11 WiFi.

The question is "if 802.11 OCB operates like 802.11 WiFi, then what is the point of 802.11 OCB?"

My answer to this is that the reader should read it better.  The text does not say that 802.11 OCB operates like 802.11 WiFi does.  The text says that the IPv6 network layer operates on OCB as on WiFi.

If, on the other hand, the question was about how IPv6 operates on WiFi, then I could agree with some consequences of some of the potential answers...

Alex

_______________________________________________
its mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/its