Subject: [ipwave] Is the LTE-V PC5 interface IP-enabled?

From: Alexandre Petrescu <[email-masked]>
Date: Tue, 20 Jun 2017 16:47:23 +0200

Hello participants to IPWAVE WG,

I wonder whether in V2V communications the LTE-V PC5 interface is 
IP-enabled?  It would only seem natural to be so, given all the earlier 
mantra of all-IP during the 3G to 4G transition.

Alex

---

From: "Kedalagudde, Meghashree Dattatri" <[email-masked]>
Date: Tue, 20 Jun 2017 15:20:17 +0000

Hi Alex, 

Based on Release 14 TS 23.285 (LTE enhancements for V2X services), for V2X communication over PC5: 
-  Both IP based and non-IP based V2X messages are supported.
-  For IP based V2X messages, only IPv6 is used. IPv4 is not supported in this release.

Referring to section 5.1 in 23.285, 

"5.1.1	User plane for PC5 reference point supporting V2X services

The PC5-U stack as defined in clause 5.1.2.1 of TS 23.303 [5] is used for the V2X communication over PC5 reference point. IP and Non-IP PDCP SDU types are supported for the V2X communication over PC5.
For IP PDCP SDU type, only IPv6 is supported. The IP address allocation and configuration are as defined in clause 4.5.1.
The Non-IP PDCP SDU contains a Non-IP Type header, which indicates the V2X message family used by the application layer, e.g. IEEE 1609 family's WSMP [13], ISO defined FNTP [14], etc.

NOTE:	The Non-IP Type header and allowed value will be defined by stage 3."

-Megha

-----Original Message-----
From: its [mailto:[email-masked]] On Behalf Of Alexandre Petrescu
Sent: Tuesday, June 20, 2017 7:47 AM
To: [email-masked]
Subject: [ipwave] Is the LTE-V PC5 interface IP-enabled?

I wonder whether in V2V communications the LTE-V PC5 interface is IP-enabled?  It would only seem natural to be so, given all the earlier mantra of all-IP during the 3G to 4G transition.

Alex

_______________________________________________
its mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/its