Subject: [ipwave] Comments on draft-ietf-ipwave-ipv6-over-80211ocb-04

From: José Santa Lozano <[email-masked]>
Date: Thu, 7 Sep 2017 17:20:29 +0200

Dear all,

Please, find attached a list of comments and suggestions embedded in a PDF document of the draft, with the aim of make easier their following.

Expecting that they result of interest and help.

Regards,

-- 
José Santa Lozano
Department of Information and Communication Engineering
Faculty of Computer Science
University of Murcia
30100 Murcia, Spain
Phone: +34-868-884616 / +34-868-884455
Fax: +34-868-884151
Web: http://ants.inf.um.es/~josesanta <http://ants.inf.um.es/~josesanta>

---

From: Alexandre PETRESCU <[email-masked]>
Date: Sun, 10 Sep 2017 16:00:48 +0200

Hi José,

The comments helped improve the document.

You raise a question that I answer here.

Draft says:

> At the time of writing, the prohibition is explicit at higher
> layer protocols providing services to the application; these
> higher layer protocols are specified in IEEE 1609 documents.

José said:
> Do you refer here to he WAVE stack, or this statement is also true for 
> the European case?

Yes, the text refers to WAVE stack because it says IEEE 1609.

For the European case: I heard people saying IPv6 is forbidden on the 
control channel.  But
I could not find a standardised agreed reference to that. Countries 
restrict the control channel to "safety" use,
yet countries dont talk about forbidding IPv6 explicitely.  This can 
easily let think that in Europe
IPv6-used-as-safety is not forbidden on the control channel.

In Europe, some people say that IPv6 _is_ allowed on the CCH, _if_ it 
runs on GeoNetworking.  But
the country frequency regulators dont talk about GeoNetworking at all.

In America IEEE 1609 they say explicitly IPv6 forbidden on control 
channel.  But the FCC doesnt say so.

Add to that: the control channel value in terms of mega Hertz in America 
is different than in Europe.
The channel considered as CCH in America falls in an SCH in Europe 
(service channel).  In that sense
one could say that where IPv6 is forbidden in America, is explicitely 
permitted in Europe.

This makes little sense.  Ideally, there would be one control channel 
number in terms of mega Hertz
both in America and in Europe _and_ IPv6 would not be forbidden there.  
But still restrict the
use of that channel to more like "safety".  That "safety" could easily 
be implemented in IPv6: it's
a Traffic Class, or a Flow Label, and in 802.11 it's also a "Traffic 
Something".

Because of this doubt, I prefer to keep the text as is, and just add 
"WAVE stack".

Draft says:
> Other aspects particular to 802.11-OCB which are also particular to
> 802.11 (e.g. the ’hidden node’ operation) may have an influence on
> the use of transmission of IPv6 packets on 802.11-OCB networks. The
> subnet structure which may be assumed in 802.11-OCB networks is
> strongly influenced by the mobility of vehicles.

José says:
> ... but, for this reason there exist solutions like  NEMO, isn't it? I 
> am not sure if you refer here to the posibility of an in-vehicle 
> network movement.

I reformulated to mean the car-external subnet.  The NEMO protocols 
deals with the in-vehicle stable network.
Mobile IPv6 and its handover management mechanism deal with such varying 
subnet structure, but only when there
is an RSU.  In this document we dont deal with handover, nor Mobile 
IPv6, nor NEMO - it's other documents.

Draft says:
> There are considerations for 2 or more IEEE 802.11-OCB interface
> cards per vehicle.

José says:
> or a transceiver supporting more than one channnel to be used 
> simultaneously.

There are no 802.11-OCB transceivers that can use more than one channel 
simultaneously.  So I dont include that text.

Yours,

--
Alexandre Petrescu
[email-masked], tél 0169089223

Le 07/09/2017 à 17:20, José Santa Lozano a écrit :
> Dear all,
>
> Please, find attached a list of comments and suggestions embedded in a 
> PDF document of the draft, with the aim of make easier their following.
>
> Web: http://ants.inf.um.es/~josesanta <http://ants.inf.um.es/%7Ejosesanta>
>
>
>
>
>
>

---

From: José Santa Lozano <[email-masked]>
Date: Wed, 13 Sep 2017 09:30:19 +0200

Dear Alexandre,

Thanks for the clarifications and for applying the changes. Now the document is in a better shape.

Regards,

Jose.

> El 10 sept 2017, a las 16:00, Alexandre PETRESCU <[email-masked]> escribió:
> 
> Hi José,
> 
>> Do you refer here to he WAVE stack, or this statement is also true for the European case?
> 
> For the European case: I heard people saying IPv6 is forbidden on the control channel.  But
> I could not find a standardised agreed reference to that.  Countries restrict the control channel to "safety" use,
> yet countries dont talk about forbidding IPv6 explicitely.  This can easily let think that in Europe
> In Europe, some people say that IPv6 _is_ allowed on the CCH, _if_ it runs on GeoNetworking.  But
> In America IEEE 1609 they say explicitly IPv6 forbidden on control channel.  But the FCC doesnt say so.
> 
> Add to that: the control channel value in terms of mega Hertz in America is different than in Europe.
> The channel considered as CCH in America falls in an SCH in Europe (service channel).  In that sense
> one could say that where IPv6 is forbidden in America, is explicitely permitted in Europe.
> 
> This makes little sense.  Ideally, there would be one control channel number in terms of mega Hertz
> both in America and in Europe _and_ IPv6 would not be forbidden there.  But still restrict the
> use of that channel to more like "safety".  That "safety" could easily be implemented in IPv6: it's
> a Traffic Class, or a Flow Label, and in 802.11 it's also a "Traffic Something".
> 
> Because of this doubt, I prefer to keep the text as is, and just add "WAVE stack".
> 
> Draft says:
>> ... but, for this reason there exist solutions like  NEMO, isn't it? I am not sure if you refer here to the posibility of an in-vehicle network movement.
> 
> 
> I reformulated to mean the car-external subnet.  The NEMO protocols deals with the in-vehicle stable network.
> Mobile IPv6 and its handover management mechanism deal with such varying subnet structure, but only when there
> is an RSU.  In this document we dont deal with handover, nor Mobile IPv6, nor NEMO - it's other documents.
> 
> Draft says:
>> or a transceiver supporting more than one channnel to be used simultaneously.
> 
> There are no 802.11-OCB transceivers that can use more than one channel simultaneously.  So I dont include that text.
> 
> Yours,
> --
> Alexandre Petrescu
> [email-masked] <mailto:[email-masked]>, tél 0169089223
> 
> _______________________________________________
> its mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/its