Subject: Re: [ipwave] WGLC for draft-ietf-ipwave-ipv6-over-80211ocb-08 - privacy text, and tutorial text movement

From: Nabil Benamar <[email-masked]>
Date: Fri, 6 Oct 2017 19:36:50 +0100

​Hi Dick,​

Best regards
Nabil Benamar
-------------------
نبيل بنعمرو

On Fri, Oct 6, 2017 at 7:01 PM, Dick Roy <[email-masked]> wrote:

> While I agree with William about the principle, please do not mandate the
> use of ANY feature in ANY standard that is not IPv6 specific!

​
I agree.

> The work of
> this group MUST NOT impose ANY requirements having to do with security,
> privacy, frequency bands, etc.. This is a network layer (L3) effort and
> nothing more.

​and this is why we mentioned "More IETF protocols are
   available in the toolbox of the IP security protocol designer."
​

> Please stop trying to create a system specification, and
> focus on the task at had ... modifications and additions to IPv6 networking
> (as currently specified in the relevant IETF RFCs) to make IPv6 function
> properly in rapidly varying topological environments with
> less-than-perfectly-reliable L2 links. This certainly includes, but is not
> limited to, ND, IPsec, and routing table issues.
>
> Any mention of IEEE 802.x, IEEE 1609.x, SAEJxxxx, should be restricted to
> the introduction, and there they should only be mentioned in the context of
> being related to ONE (of many) interesting use case ... ITS.
>
> RR
>
> -----Original Message-----
> From: its [mailto:[email-masked]] On Behalf Of Alexandre Petrescu
> Sent: Friday, October 6, 2017 8:38 AM
> To: William Whyte; Nabil Benamar
> Cc: [email-masked]
> Subject: Re: [ipwave] WGLC for draft-ietf-ipwave-ipv6-over-80211ocb-08 -
> privacy text, and tutorial text movement
>
> When MUST-ing an IEEE document I would like to make sure I take shortest
> paths.  For example, if IPv6-over-OCB MUSTs 1609.x document which then
> MUSTs an RFC in return about privacy identifiers, I would prefer the
> IP-OCB draft to rather MUST directly that RFC, instead of the 1609.x
> document.
>
> Second, the MUST statement is relatively strong.  I would like to make
> sure that software is available easily, IPR is IETF conditions, etc,
> before saying MUST.
>
> There may be other conditions.
>
> But I agree with you it should not be a blind principle.
>
>
> Le 06/10/2017 à 17:31, William Whyte a écrit :
> > I don't see a reason to avoid MUSTing documents from other SDOs. Using
> > documents from other SDOs as normative references happens all the time.
> > For example, in the Connected Vehicle setting, both ETSI and SAE
> > documents have normative references to IEEE standards. It may not be
> > appropriate in this particular case for technical reasons, but I don't
> > think it should be a principle.
> >
> > Cheers,
> >
> > William
> >
> > On Fri, Oct 6, 2017 at 11:10 AM, Nabil Benamar <[email-masked]
> > <mailto:[email-masked]>> wrote:
> >
> >     I definitely agree with you Alex. No mention of  "MUST" for non RFC
> >     documents.
> >
> >
> >
> >     Best regards
> >     Nabil Benamar
> >     -------------------
> >     نبيل بنعمرو
> >
> >
> >
> >
> >
> >
> >     On Fri, Oct 6, 2017 at 3:58 PM, Alexandre Petrescu
> >     <[email-masked] <mailto:[email-masked]>>
> >     wrote:
> >
> >         Margaret,
> >
> >         Le 02/10/2017 à 18:50, Margaret Cullen a écrit :
> >         [...]
> >
> >             Also in Section 4:  The bullet about privacy concerns me, as
> it
> >             points out a “strong need” for privacy mechanisms, but it
> >             doesn’t
> >             specify any.  Should it state that one of the two IEEE
> functions
> >             cited MUST be implemented when using IPv6 over 802.11-OCB?
> >             Would
> >             those sufficiently address the concern?
> >
> >
> >         I would disagree to make a MUST for IEEE documents.  We could
> >         MUST RFCs.
> >
> >         At the same time, I suggest we move that entire Section 4 into
> >         an appendix.  It is more tutorial in nature.  Do you disagree?
> >
> >         Alex
> >
> >         _______________________________________________
> >         its mailing list
> >         [email-masked] <mailto:[email-masked]>
> >         https://www.ietf.org/mailman/listinfo/its
> >         <https://www.ietf.org/mailman/listinfo/its>
> >
> >
> >
> >     _______________________________________________
> >     its mailing list
> >     [email-masked] <mailto:[email-masked]>
> >     https://www.ietf.org/mailman/listinfo/its
> >     <https://www.ietf.org/mailman/listinfo/its>
> >
> >
> >
> >
> > --
> >
> >
> > PLEASE UPDATE YOUR ADDRESS BOOKS WITH MY NEW ADDRESS:
> > [email-masked] <mailto:[email-masked]>
>
> _______________________________________________
> its mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/its
>
>

---

From: Nabil Benamar <[email-masked]>
Date: Fri, 6 Oct 2017 20:52:43 +0100

Good point!

I do think that the security issues are an open debate....this may lead to
another draft that some authors have already started to think about!

Best regards
Nabil Benamar
-------------------
نبيل بنعمرو

On Fri, Oct 6, 2017 at 8:26 PM, Dick Roy <[email-masked]> wrote:

> “and this is why we mentioned "More IETF protocols are
>
>    available in the toolbox of the IP security protocol designer."”
>
>
>
> This is good, however the real question for the group is: Are
> modifications to these IETF protocols necessary for operation in rapidly
> varying topological environments, and if so, what?  Also, are other new
> IETF L3 security-related protocols necessary for proper IPv6 operation in
> such environments?
>
>
>
> Cheers,
>
>
> RR
>
>
> ------------------------------
>
> *From:* its [mailto:[email-masked]] *On Behalf Of *Nabil Benamar
> *Sent:* Friday, October 6, 2017 11:37 AM
> *To:* Richard Roy
> *Cc:* Alexandre Petrescu; William Whyte; [email-masked]
>
> *Subject:* Re: [ipwave] WGLC for draft-ietf-ipwave-ipv6-over-80211ocb-08
> - privacy text, and tutorial text movement
>
>
>
>
>
> ​Hi Dick,​
>
>
>
>
>
>
> Best regards
>
> Nabil Benamar
>
> -------------------
>
> نبيل بنعمرو
>
>
>
>
>
>
>
>
>
>
>

---

From: Rex Buddenberg <[email-masked]>
Date: Fri, 06 Oct 2017 14:18:35 -0700

Nabil,

I agree with RR on this one.  Here's why:

Content security is a layer 6 problem which puts it well outside the
scope of IPWAVE.  Further, IEEE 1609 has addressed it that way,
although not explicitly.

The rest of the issue is infrastructure security, NOT content security:
  - Layer 4/5 security secures connections
  - Layer 3 security fences off virtual private internetworking
infrastructures
  - Layer 1 and 2 security protects only single network segments --
gotta be removed at first router.

Each of these points is either outside scope or counter to objectives.
Worth an open debate but, IMHO, not inclusion in IPWAVE paper.

On Fri, 2017-10-06 at 20:52 +0100, Nabil Benamar wrote:
> Good point!
> 
> I do think that the security issues are an open debate....this may
> lead to another draft that some authors have already started to think
> about!
> 
> 
> 
> Best regards
> Nabil Benamar
> -------------------
> نبيل بنعمرو
> 
> 
> 
> 
> 
> 
> > modifications to these IETF protocols necessary for operation in
> > rapidly varying topological environments, and if so, what?  Also,
> > are other new IETF L3 security-related protocols necessary for
> > proper IPv6 operation in such environments?
> >  
> > Cheers,
> > 
> > RR
> >  
> > From: its [mailto:[email-masked]] On Behalf Of Nabil Benamar
> > Sent: Friday, October 6, 2017 11:37 AM
> > To: Richard Roy
> > Cc: Alexandre Petrescu; William Whyte; [email-masked]
> > 
> > Subject: Re: [ipwave] WGLC for draft-ietf-ipwave-ipv6-over-
> > 80211ocb-08 - privacy text, and tutorial text movement
> >  
> >  
> > Hi Dick,
> > 
> >  
> >  
> > Best regards
> > Nabil Benamar
> > -------------------
> > نبيل بنعمرو
> >  
> >  
> >  
> >  
> > 
> >  
> > and this is why we mentioned "More IETF protocols are