Subject: Re: [ipwave] fe80::/64 vs fe80::/10

From: Nabil Benamar <[email-masked]>
Date: Thu, 12 Oct 2017 15:50:02 +0100

Best regards
Nabil Benamar
-------------------
نبيل بنعمرو

On Thu, Oct 12, 2017 at 3:41 PM, Alexandre Petrescu <
[email-masked]> wrote:

>
>
> Le 12/10/2017 à 16:29, Nabil Benamar a écrit :
>
>> Hi Alex,
>>
>> the FE80::/10 is a range of addresses rather than an IPv6 @.
>>
>
> By "IPv6 @" I think you mean "IPv6 address".

​Yes.​

>
>
> So ALL addresses with the first Hextet between FE80 and FEBF are
>> valid Link-local address.
>>
>
> I agree with you.  So, RFC2464 does not allow for other link-local
> addresses than those starting with FE80.  It does not allow, for
> example, for link-local addresses that start with FEBF, even though
> RFC4291 does allow them.
>

>
> Do we want IPv6-over-OCB to allow link-local addresses in the entire
> range from FE80 to FEBF (as RFC4291 suggests)?
>

​I would go for this choice since this is the IPv6 standard.​

>
> Or do we want to restrain IPv6-over-OCB to link-local addresses of FE80
> form?
>
> Depending on this we may formulate a clarification text.
> (in the former case we can write "fe80::/10" whereas in the latter we
> can write "fe80::/10 followed by 54 zeros")
>
>
> Alex
>
> _______________________________________________
> its mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/its
>

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 12 Oct 2017 16:55:40 +0200

Le 12/10/2017 à 16:50, Nabil Benamar a écrit :
> 
> 
> 
> 
> Best regards
> Nabil Benamar
> -------------------
> نبيل بنعمرو
> 
> 
> 
> 
> 
> 
> On Thu, Oct 12, 2017 at 3:41 PM, Alexandre Petrescu 
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
> 
> 

But if we go this way (IPv6-over-OCB to allow for FEBF LLs) it is going 
to be different than IPv6-over-Ethernet, I think.

But I prefer it too.

Alex

>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/its>
> 
>