Subject: Re: [ipwave] WGLC for draft-ietf-ipwave-ipv6-over-80211ocb-08 - privacy text, and tutorial text movement

From: Nabil Benamar <[email-masked]>
Date: Sat, 7 Oct 2017 08:46:42 +0100

Best regards
Nabil Benamar
-------------------
نبيل بنعمرو

On Fri, Oct 6, 2017 at 10:35 PM, Dick Roy <[email-masked]> wrote:

>
>
>
>
> -----Original Message-----
> From: its [mailto:[email-masked]] On Behalf Of Rex Buddenberg
> Sent: Friday, October 6, 2017 2:19 PM
> To: Nabil Benamar; Richard Roy
> Cc: Alexandre Petrescu; [email-masked]
> Subject: Re: [ipwave] WGLC for draft-ietf-ipwave-ipv6-over-80211ocb-08 -
> privacy text, and tutorial text movement
>
>
>
> Nabil,
>
>
>
> I agree with RR on this one.  Here's why:
>
>
>
> Content security is a layer 6 problem which puts it well outside the
>
> scope of IPWAVE.
>
> *[RR] I would say it’s an application issue ultimately, which puts it
> above layer 7 (6 is presentation and 7 is application (meaning API)) where
> applications reside. *
>

​I would say in layer 7 since there is nothing above that layer ;)​

> *Either way, its outside the scope of IPWAVE for sure.*
>
​I agree.​

> Further, IEEE 1609 has addressed it that way,
>
> although not explicitly.
>
> *[RR] Correct!*
>
>
>
> The rest of the issue is infrastructure security, NOT content security:
>
> -       Layer 4/5 security secures connections
>
> *[RR] Yup!*
>
>
​Ok, but how is layer 5 a part of the infrastructure ?​

>   - Layer 3 security fences off virtual private internetworking
>
> Infrastructures
>
> *[RR] Yup! *
>
>   - Layer 1 and 2 security protects only single network segments --
>
> gotta be removed at first router.
>
> *[RR] Yup!*
>
>
>
> Each of these points is either outside scope or counter to objectives.
>
> Worth an open debate but, IMHO, not inclusion in IPWAVE paper.
>
>
> ​No objection !​
>
> *[RR] Agreed!*
>
>
>
> On Fri, 2017-10-06 at 20:52 +0100, Nabil Benamar wrote:
>
> > Good point!
>
> >
>
> > I do think that the security issues are an open debate....this may
>
> > lead to another draft that some authors have already started to think
>
> > about!
>
> >
>
> >
>
> >
>
> > Best regards
>
> > Nabil Benamar
>
> > -------------------
>
> > نبيل بنعمرو
>
> >
>
> >
>
> >
>
> >
>
> >
>
> >
>
> > On Fri, Oct 6, 2017 at 8:26 PM, Dick Roy <[email-masked]>
>
> > wrote:
>
> > > “and this is why we mentioned "More IETF protocols are
>
> > >    available in the toolbox of the IP security protocol designer."”
>
> > >
>
> > > This is good, however the real question for the group is: Are
>
> > > modifications to these IETF protocols necessary for operation in
>
> > > rapidly varying topological environments, and if so, what?  Also,
>
> > > are other new IETF L3 security-related protocols necessary for
>
> > > proper IPv6 operation in such environments?
>
> > >
>
> > > Cheers,
>
> > >
>
> > > RR
>
> > >
>
> > > From: its [mailto:[email-masked]] On Behalf Of Nabil Benamar
>
> > > Sent: Friday, October 6, 2017 11:37 AM
>
> > > To: Richard Roy
>
> > > Cc: Alexandre Petrescu; William Whyte; [email-masked]
>
> > >
>
> > > Subject: Re: [ipwave] WGLC for draft-ietf-ipwave-ipv6-over-
>
> > > 80211ocb-08 - privacy text, and tutorial text movement
>
> > >
>
> > >
>
> > > Hi Dick,
>
> > >
>
> > >
>
> > >
>
> > > Best regards
>
> > > Nabil Benamar
>
> > > -------------------
>
> > > نبيل بنعمرو
>
> > >
>
> > >
>
> > >
>
> > >
>
> > >
>
> > >
>
> > > On Fri, Oct 6, 2017 at 7:01 PM, Dick Roy <[email-masked]>
>
> > > wrote:
>
> > > While I agree with William about the principle, please do not
>
> > > mandate the
>
> > > use of ANY feature in ANY standard that is not IPv6 specific!
>
> > >
>
> > > I agree.
>
> > >
>
> > > The work of
>
> > > this group MUST NOT impose ANY requirements having to do with
>
> > > security,
>
> > > privacy, frequency bands, etc.. This is a network layer (L3) effort
>
> > > and
>
> > > nothing more.
>
> > >
>
> > > and this is why we mentioned "More IETF protocols are
>
> > >    available in the toolbox of the IP security protocol designer."
>
> > >
>
> > > Please stop trying to create a system specification, and
>
> > > focus on the task at had ... modifications and additions to IPv6
>
> > > networking
>
> > > (as currently specified in the relevant IETF RFCs) to make IPv6
>
> > > function
>
> > > properly in rapidly varying topological environments with
>
> > > less-than-perfectly-reliable L2 links. This certainly includes, but
>
> > > is not
>
> > > limited to, ND, IPsec, and routing table issues.
>
> > >
>
> > > Any mention of IEEE 802.x, IEEE 1609.x, SAEJxxxx, should be
>
> > > restricted to
>
> > > the introduction, and there they should only be mentioned in the
>
> > > context of
>
> > > being related to ONE (of many) interesting use case ... ITS.
>
> > >
>
> > > RR
>
> > >
>
> > > -----Original Message-----
>
> > > From: its [mailto:[email-masked]] On Behalf Of Alexandre
>
> > > Petrescu
>
> > > Sent: Friday, October 6, 2017 8:38 AM
>
> > > To: William Whyte; Nabil Benamar
>
> > > Cc: [email-masked]
>
> > > Subject: Re: [ipwave] WGLC for draft-ietf-ipwave-ipv6-over-
>
> > > 80211ocb-08 -
>
> > > privacy text, and tutorial text movement
>
> > >
>
> > > When MUST-ing an IEEE document I would like to make sure I take
>
> > > shortest
>
> > > paths.  For example, if IPv6-over-OCB MUSTs 1609.x document which
>
> > > then
>
> > > MUSTs an RFC in return about privacy identifiers, I would prefer
>
> > > the
>
> > > IP-OCB draft to rather MUST directly that RFC, instead of the
>
> > > 1609.x
>
> > > document.
>
> > >
>
> > > Second, the MUST statement is relatively strong.  I would like to
>
> > > make
>
> > > sure that software is available easily, IPR is IETF conditions,
>
> > > etc,
>
> > > before saying MUST.
>
> > >
>
> > > There may be other conditions.
>
> > >
>
> > > But I agree with you it should not be a blind principle.
>
> > >
>
> > >
>
> > > Le 06/10/2017 à 17:31, William Whyte a écrit :
>
> > > > I don't see a reason to avoid MUSTing documents from other SDOs.
>
> > > Using
>
> > > > documents from other SDOs as normative references happens all the
>
> > > time.
>
> > > > For example, in the Connected Vehicle setting, both ETSI and SAE
>
> > > > documents have normative references to IEEE standards. It may not
>
> > > be
>
> > > > appropriate in this particular case for technical reasons, but I
>
> > > don't
>
> > > > think it should be a principle.
>
> > > >
>
> > > > Cheers,
>
> > > >
>
> > > > William
>
> > > >
>
> > > > On Fri, Oct 6, 2017 at 11:10 AM, Nabil Benamar <[email-masked]
>
> > > om
>
> > > > <mailto:[email-masked]>> wrote:
>
> > > >
>
> > > >     I definitely agree with you Alex. No mention of  "MUST" for
>
> > > non RFC
>
> > > >     documents.
>
> > > >
>
> > > >
>
> > > >
>
> > > >     Best regards
>
> > > >     Nabil Benamar
>
> > > >     -------------------
>
> > > >     نبيل بنعمرو
>
> > > >
>
> > > >
>
> > > >
>
> > > >
>
> > > >
>
> > > >
>
> > > >     On Fri, Oct 6, 2017 at 3:58 PM, Alexandre Petrescu
>
> > > >     <[email-masked] <mailto:alexandre.petrescu@gmai
>
> > > l.com>>
>
> > > >     wrote:
>
> > > >
>
> > > >         Margaret,
>
> > > >
>
> > > >         Le 02/10/2017 à 18:50, Margaret Cullen a écrit :
>
> > > >         [...]
>
> > > >
>
> > > >             Also in Section 4:  The bullet about privacy concerns
>
> > > me, as
>
> > > it
>
> > > >             points out a “strong need” for privacy mechanisms,
>
> > > but it
>
> > > >             doesn’t
>
> > > >             specify any.  Should it state that one of the two
>
> > > IEEE
>
> > > functions
>
> > > >             cited MUST be implemented when using IPv6 over
>
> > > 802.11-OCB?
>
> > > >             Would
>
> > > >             those sufficiently address the concern?
>
> > > >
>
> > > >
>
> > > >         I would disagree to make a MUST for IEEE documents.  We
>
> > > could
>
> > > >         MUST RFCs.
>
> > > >
>
> > > >         At the same time, I suggest we move that entire Section 4
>
> > > into
>
> > > >         an appendix.  It is more tutorial in nature.  Do you
>
> > > disagree?
>
> > > >
>
> > > >         Alex
>
> > > >
>
> > > >         _______________________________________________
>
> > > >         its mailing list
>
> > > >         [email-masked] <mailto:[email-masked]>
>
> > > >         https://www.ietf.org/mailman/listinfo/its
>
> > > >         <https://www.ietf.org/mailman/listinfo/its>
>
> > > >
>
> > > >
>
> > > >
>
> > > >     _______________________________________________
>
> > > >     its mailing list
>
> > > >     [email-masked] <mailto:[email-masked]>
>
> > > >     https://www.ietf.org/mailman/listinfo/its
>
> > > >     <https://www.ietf.org/mailman/listinfo/its>
>
> > > >
>
> > > >
>
> > > >
>
> > > >
>
> > > > --
>
> > > >
>
> > > >
>
> > > > PLEASE UPDATE YOUR ADDRESS BOOKS WITH MY NEW ADDRESS:
>
> > > > [email-masked] <mailto:[email-masked]>
>
> > >
>
> > > _______________________________________________
>
> > > its mailing list
>
> > > [email-masked]
>
> > > https://www.ietf.org/mailman/listinfo/its
>
> > >
>
> > >
>
> > >
>
> > _______________________________________________
>
> > its mailing list
>
> > [email-masked]
>
> > https://www.ietf.org/mailman/listinfo/its
>
>
>
> _______________________________________________
>
> its mailing list
>
> [email-masked]
>
> https://www.ietf.org/mailman/listinfo/its
>

---

From: François Simon <[email-masked]>
Date: Sat, 7 Oct 2017 08:21:56 -0400

Actually, according to the OSI model, Security is one of the 5 Management Functional Areas (FCAPS) and “resides” in the Management Layer.   Fygs

From: its [mailto:[email-masked]] On Behalf Of Nabil Benamar
Sent: Saturday, October 07, 2017 3:47 AM
To: Richard Roy <[email-masked]>
Cc: Rex Buddenberg <[email-masked]>; Alexandre Petrescu <[email-masked]>; [email-masked]
Subject: Re: [ipwave] WGLC for draft-ietf-ipwave-ipv6-over-80211ocb-08 - privacy text, and tutorial text movement

 

Best regards

Nabil Benamar

-------------------

نبيل بنعمرو

 

On Fri, Oct 6, 2017 at 10:35 PM, Dick Roy <[email-masked] <mailto:[email-masked]> > wrote:

-----Original Message-----
From: its [mailto:[email-masked] <mailto:[email-masked]> ] On Behalf Of Rex Buddenberg
Sent: Friday, October 6, 2017 2:19 PM
To: Nabil Benamar; Richard Roy
Cc: Alexandre Petrescu; [email-masked] <mailto:[email-masked]> 
Subject: Re: [ipwave] WGLC for draft-ietf-ipwave-ipv6-over-80211ocb-08 - privacy text, and tutorial text movement

Nabil,

scope of IPWAVE.  

[RR] I would say it’s an application issue ultimately, which puts it above layer 7 (6 is presentation and 7 is application (meaning API)) where applications reside. 

Either way, its outside the scope of IPWAVE for sure.

​I agree.​

although not explicitly.

[RR] Correct!

[RR] Yup!

Infrastructures

[RR] Yup! 

[RR] Yup!

​No objection !​

[RR] Agreed!

> On Fri, Oct 6, 2017 at 8:26 PM, Dick Roy <[email-masked] <mailto:[email-masked]> >

> > From: its [mailto:[email-masked] <mailto:[email-masked]> ] On Behalf Of Nabil Benamar

> > Cc: Alexandre Petrescu; William Whyte; [email-masked] <mailto:[email-masked]> 

> > On Fri, Oct 6, 2017 at 7:01 PM, Dick Roy <[email-masked] <mailto:[email-masked]> >

> > From: its [mailto:[email-masked] <mailto:[email-masked]> ] On Behalf Of Alexandre

> > Cc: [email-masked] <mailto:[email-masked]> 

> > > <mailto:[email-masked] <mailto:[email-masked]> >> wrote:

> > >     <[email-masked] <mailto:[email-masked]>  <mailto:alexandre.petrescu@gmai <mailto:alexandre.petrescu@gmai> 

> > l.com <http://l.com> >>

> > >         [email-masked] <mailto:[email-masked]>  <mailto:[email-masked] <mailto:[email-masked]> >

> > >     [email-masked] <mailto:[email-masked]>  <mailto:[email-masked] <mailto:[email-masked]> >

> > > [email-masked] <mailto:[email-masked]>  <mailto:[email-masked] <mailto:[email-masked]> >

its mailing list

---

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Mon, 09 Oct 2017 16:32:29 +0200

Hi,

This WG is chartered to care only about the security and privacy
implications of running IPv6 over IEEE 802.11-OCB. Security at layers
above or below is not in the scope of the IPWAVE WG.

Thanks,

Carlos

On Sat, 2017-10-07 at 08:21 -0400, François Simon wrote:
> Actually, according to the OSI model, Security is one of the 5
> Management Functional Areas (FCAPS) and “resides” in the Management
> Layer.   Fygs
>  
> Subject: Re: [ipwave] WGLC for draft-ietf-ipwave-ipv6-over-80211ocb-
> 08 - privacy text, and tutorial text movement
>  
>  
> 
>  
>  
> Best regards
> Nabil Benamar
> -------------------
> نبيل بنعمرو
>  
>  
>  
>  
> 
>  
> > [RR] I would say it’s an application issue ultimately, which puts
> > it above layer 7 (6 is presentation and 7 is application (meaning
> > API)) where applications reside.
> 
>  
> I would say in layer 7 since there is nothing above that layer ;)
> Ok, but how is layer 5 a part of the infrastructure ?
> > No objection !
> > > > > [email-masked] <mailto:[email-masked]
> > >
> > > >