Subject: [Jmap] Is the group address syntax from RFC5322 really not supported in JMAP?

From: Mads Hjorth <[email-masked]>
Date: Fri, 21 Apr 2017 07:09:13 +0000

HI, 

I have an eye on JMAP for the use in a rather large scale messaging system (+5 million mailboxes).

In one of our use cases, we want to send messages to an named group, allowing the recipient to see the name of the group, but not the identity of the members. We consider using the RFC5322 syntax for this e.g. 

To: Teenage Mutant Ninja Turtles:;
Bcc: “Leonardo” <[email-masked]>, “Donatello” <[email-masked]>

But the current JMAP states 

> Group information and comments from the RFC 5322 header MUST be discarded when converting into an Emailer object.

And I don’t see a motivation for the diversion from the RFC. 

Is it hard to implement? Never used? or is there another good explanation?

           †
        [[ o ]]
         *****
DIGITALISERINGSSTYRELSEN

Mads Hjorth
Chefkonsulent

tel:+4541782351
mailto:[email-masked]
http://www.digst.dk

"I would have got rid of the slash slash 
 after the colon. You don't really need it. 
 It just seemed like a good idea at the time." 

- Tim Berners-Lee

---

From: Alexey Melnikov <[email-masked]>
Date: Fri, 21 Apr 2017 09:46:56 +0100

> On 21 Apr 2017, at 08:09, Mads Hjorth <[email-masked]> wrote:
> 
> HI, 
> 

I noticed lack of this in my review as well and I would like to see this supported.

> _______________________________________________
> Jmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jmap

---

From: Bron Gondwana <[email-masked]>
Date: Mon, 24 Apr 2017 11:16:54 +1000

https://github.com/jmapio/jmap/issues/59

-- 
  Bron Gondwana
  [email-masked]

---

From: "John Levine" <[email-masked]>
Date: 24 Apr 2017 14:52:23 -0000

>https://github.com/jmapio/jmap/issues/59

Seems to me that this is one of the many problems that a separate submission
envelope solves.

R's,
John

>> > In one of our use cases, we want to send messages to an named group, allowing the recipient to see the name of the group, but not the identity of
>the members. We consider using the RFC5322 syntax for this e.g. 
>> >

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 24 Apr 2017 15:59:14 +0100

> Seems to me that this is one of the many problems that a separate submission
Possibly, but currently group names can't be expressed in syntax. So the 
above ticket is about that.

---

From: "John R Levine" <[email-masked]>
Date: 24 Apr 2017 11:25:55 -0400

>> Seems to me that this is one of the many problems that a separate 
>> submission envelope solves.

They aren't expressed in SMTP either, they're just a convention for 5322 
headers.  It's always been up to the MUA to pick out the actual addresses 
at submission time.  In practice there have always been ways to store 
distribution lists on one's mail server, but I don't think any of those 
have ever made it into an RFC.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail. https://jl.ly