Subject: [Jmap] Draft meeting notes

From: "Chris Newman" <[email-masked]>
Date: Mon, 17 Jul 2017 16:13:34 +0200

Topic: "why JMAP"

Issue: JMAP Mail: keywords
  seems concluded
  action item: register four $XXX keywords for system flags (Chris 
volunteered to help with IANA considerations)
discussion, but no objections from attendees

Issue: JMAP Mail: Submission
  changed to use a more JMAP-ish MessageSubmission object
  ongoing discussion seems close to consensus
  action item: Chris Newman will propose syntax to align better with
  concern expressed about name "messageid"
no other objections from attendees about general direction

Issue: JMAP Mail: Message object & partial body fetch
  no proposal yet
  suggestion to expose IMAP MIME part numbers in attachment list
  discussion that HTTP range is probably not be sufficient
needs more discussion

Issue: JMAP Core: extension mechanisms
needs some work but no significant controversy expressed in room

Issue: JMAP Core: authentication
  action item: need to split to separate document
  action item: Torsten & Neil will discuss possibility of profiling 
OAuth
  point: possible interaction with token binding WG

Issue: JMAP Core: push mechanism
  discussion of Martin's objections to EventSource
  discussion of encryption of push data

Issue: JMAP Core: "transport"
  HTTP as a tunnel vs. HTTP resources for every object
  long discussion

Github Tickets
* changed vs. created in getFooUpdates (issues/78)
* disallow destroying mailboxes	with messages (issues/69)
   some preference expressed to allow delete of mailbox with	messages
* mailboxids property

		- Chris

---

From: Bron Gondwana <[email-masked]>
Date: Tue, 18 Jul 2017 02:48:36 +1000

> volunteered to help with IANA considerations)

https://github.com/jmapio/jmap/issues/73

>   concern expressed about name "messageid"

https://github.com/jmapio/jmap/issues/102

>   discussion that HTTP range is probably not be sufficient

https://github.com/jmapio/jmap/issues/103

and more generally:

https://github.com/jmapio/jmap/issues/104

>   action item: need to split to separate document

https://github.com/jmapio/jmap/issues/105

>   action item: Torsten & Neil will discuss possibility of profiling

https://github.com/jmapio/jmap/issues/106

>   point: possible interaction with token binding WG

https://github.com/jmapio/jmap/issues/107

>   discussion of encryption of push data

https://github.com/jmapio/jmap/issues/109 came up from a jabber question
https://github.com/jmapio/jmap/issues/110 for the encryption question

>   HTTP as a tunnel vs. HTTP resources for every object

https://github.com/jmapio/jmap/issues/111 about working with HTTP folks on what we need that HTTP doesn't provide (yet), even if we don't change to meet it
https://github.com/jmapio/jmap/issues/112 for the URL mapping of objects.
>   some preference expressed to allow delete of mailbox with     

https://github.com/jmapio/jmap/issues/113 for mailboxIds

> 
> - Chris
> 
> _________________________________________________
> Jmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jmap

--
  Bron Gondwana, CEO, FastMail Pty Ltd
  [email-masked]

---

From: Bron Gondwana <[email-masked]>
Date: Wed, 19 Jul 2017 17:39:39 +1000

These are now uploaded to datatracker - sorry I forgot to do that on Monday.
Bron.