Subject: Re: [Jmap] Alias and Downgrading in Action

From: "अजय@डाटा.भारत"<[email-masked]>
Date: Sun, 10 Sep 2017 22:06:17 +0530 (IST)

Neil,, though I raised this point at very last stage.. but I thought "better late than never" .I would like to point only two points to consider.. 1. There may be a need to authenticate users using Alias ID on jmap.2. There may be a need to use Different FROM ID (Alias) while sending mail.  This may be more important in case EAI is being used. How Alias gets implement at server it surely an issue, . but if jmap supports that, I believe it will have better adoption in future. thanks. 

From: Neil Jenkins   MailId : [73196612]To: IETF JMAP Mailing List Subject: Re: [Jmap] Alias and Downgrading in ActionDate: 10 Sep 2017 05:28:53 AM 
Hi Ajay,
 
On Sat, 9 Sep 2017, at 02:43 PM, अजय@डाटा.भारत wrote:
I think it may be good idea to also consider Email Alias, Single Mail Box for multiple IDs and Downgrading.  I am attaching few videos and links to explain features in brief and would be happy to discuss further.
 
I believe creating/modifying aliases is too service-specific to be worth having in the JMAP Mail spec. You need to know what restrictions there are on the mailbox part, what domain names can be used, what addresses are available, whether the alias can target other users too etc. etc.
 
Neil.
_______________________________________________Jmap mailing [email-masked]://www.ietf.org/mailman/listinfo/jmapDo not Remove:[HID]20170910052850644[-HID]
[XGENFOOTER]

[-XGENFOOTER]

---

From: Neil Jenkins <[email-masked]>
Date: Mon, 11 Sep 2017 11:20:37 +1000

On Mon, 11 Sep 2017, at 02:36 AM, अजय@डाटा.भारत wrote:
> 1. There may be a need to authenticate users using Alias ID on jmap.

Authentication is a whole big area still to be resolved, but even with
the current proposal there is nothing to stop the server from accepting
an alias for login (and returning the "real" username with the auth data
at the end of successful authentication).
> 2. There may be a need to use Different FROM ID (Alias) while sending
>    mail.  This may be more important in case EAI is being used.
This is covered already by the Identities[1] section of the JMAP
Mail spec.
Regards,
Neil.

Links:

  1. http://jmap.io/spec-mail.html#identities