Subject: Re: [Jmap] MessageSubmission last call

From: Neil Jenkins <[email-masked]>
Date: Mon, 04 Sep 2017 11:14:22 +1000

On Fri, 1 Sep 2017, at 03:56 AM, Chris Newman wrote:
> Actually, the "status" and "diagnostic" fields in the DSN are a
> new SMTP> reply so I presumed that would replace the old one. If you just want
> to> save only the SMTP submission reply, or only SMTP replies seen by the> local ADMD the field definition needs to say that.

Ah right, yes I presumed the *smtpReply* field would only be the last
reply seen before it left your local network. But actually, it probably
makes sense to also update this if you receive the DSN. Anyone got a
good argument either way? If not, I'll make the spec say it should be
updated from the DSN.
>>> So is that DSN left in the INBOX because the final-recipient doesn't>>> match a RCPT TO address, or does it get correlated into the
>>> MessageSubmission DSNs field based on the original-recipient field?>> I would say this should be correlated based on the original-recipient>> field, so this would be considered a successful delivery.
> 
> Yes, but which address is used as the key in the map? Does the status> appear under both addresses, or just the original recipient?

The map is from the email addresses that was supplied as the RCPT TO to
the current delivery status, so this means only the original recipient
address appears.
Neil.

---

From: Neil Jenkins <[email-masked]>
Date: Mon, 18 Sep 2017 14:49:38 +1000

I've updated the spec to say DSNs update the smtpReply and merged this
(hurray! thanks everyone!). Any further issues or comments, please raise
a new GitHub issue[1].
Cheers,
Neil.

Links:

  1. https://tools.ietf.org/html/draft-ietf-webpush-encryption-09