Subject: Re: [Jmap] Jmap Digest, Vol 12, Issue 1

From: vaibhav singh <[email-masked]>
Date: Mon, 13 Nov 2017 11:20:12 +0530

>
> From: Alexey Melnikov <[email-masked]>
> To: vaibhav singh <[email-masked]>, [email-masked]
> Cc:
> Bcc:
> Date: Sun, 12 Nov 2017 12:19:27 +0800
> Subject: Re: [Jmap] [JMAP] SMIME Attachments (was: Re: S/MIME for JMAP)
> On 29/10/2017 07:33, vaibhav singh wrote:
> >
> >
> >        1. Re: [JMAP] SMIME Attachments (was: Re:  S/MIME for JMAP)
> >           (Bron Gondwana)
> >
> >
> >     ---------- Forwarded message ----------
> >     From: Bron Gondwana <[email-masked]
> >     <mailto:[email-masked]>>
> >     To: [email-masked] <mailto:[email-masked]>
> >     Cc:
> >     Bcc:
> >     Date: Thu, 26 Oct 2017 09:04:40 +1100
> >     Subject: Re: [Jmap] [JMAP] SMIME Attachments (was: Re: S/MIME for
> JMAP)
> >     __
> >     If you want to use a JMAP server to pass opaque blobs, that works
> >     fine.  Obviously things like hasAttachment aren't going to work,
> >     because the opaque blob doesn't have an attachment.  The mail inside
> >     may have an attachment, but the JMAP server doesn't know that.
> >
> >     Since the same issue exists with IMAP, it sounds like maybe what
> >     you're suggesting is an IANA registration of a keyword like
> >     $HasEncryptedAttachment, which would allow multiple MUAs to share
> >     that metadata.  Of course the server couldn't add it, so it would
> >     only be present at the time the first MUA-with-keys connected and
> >     downloaded the message to evaluate its contents.
> >
> >
> > Yes, I can start the process for requesting " $HasEncryptedAttachment
> > "be registered by IANA, in case nobody sees an issue with it.
>
> Please do. I can help you offline, if you need help.

Thanks a lot. I have requested for the keyword to be registered to IANA,
and got feedback about it from Mr. Barry Leiba, following which I have put
up the keyword up for discussion on imapext mailing group (
[email-masked]).

Relevant subject line on imapext is "[imapext] General Request for
Assignment (imap-keywords) (was: [JMAP] SMIME Attachments)". Kindly have a
look and suggest any modifications to the keyword, if needed.

Thanks,
Vaibhav

>
>
>
> _______________________________________________
> Jmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jmap
>
>

-- 

Regards,
Vaibhav Singh

---

From: Josef 'Jeff' Sipek <[email-masked]>
Date: Mon, 13 Nov 2017 07:38:21 -0500

On Mon, Nov 13, 2017 at 11:20:12 +0530, vaibhav singh wrote:
...
> look and suggest any modifications to the keyword, if needed.

I don't see it anywhere...

Jeff.

-- 
All parts should go together without forcing.  You must remember that the
parts you are reassembling were disassembled by you.  Therefore, if you
can’t get them together again, there must be a reason.  By all means, do not
use a hammer.
		— IBM Manual, 1925

---

From: vaibhav singh <[email-masked]>
Date: Mon, 13 Nov 2017 20:44:16 +0530

On Mon, Nov 13, 2017 at 6:08 PM, Josef 'Jeff' Sipek <[email-masked]>
wrote:

>  <https://www.boxbe.com/overview> Josef 'Jeff' Sipek (
> [email-masked]) is not on your Guest List
> <https://www.boxbe.com/approved-list?tc_serial=34235308140&tc_rand=1106222033&utm_source=stf&utm_medium=email&utm_campaign=ANNO_MWTP&utm_content=001&key=xuSZvDYrb0FnU5VjU4uRNuT%2BrhnEfRT%2F3X15zK%2BxG58%3D&token=g2vEv5ixd0HTUPQhOozJ%2FUNyNACgqj6ZIF7dH%2BbIHaUkUk2L4%2FJGhYGkwST674t%2B>
> | Approve sender
> <https://www.boxbe.com/anno?tc_serial=34235308140&tc_rand=1106222033&utm_source=stf&utm_medium=email&utm_campaign=ANNO_MWTP&utm_content=001&key=xuSZvDYrb0FnU5VjU4uRNuT%2BrhnEfRT%2F3X15zK%2BxG58%3D&token=g2vEv5ixd0HTUPQhOozJ%2FUNyNACgqj6ZIF7dH%2BbIHaUkUk2L4%2FJGhYGkwST674t%2B>
> | Approve domain
> <https://www.boxbe.com/anno?tc_serial=34235308140&tc_rand=1106222033&utm_source=stf&utm_medium=email&utm_campaign=ANNO_MWTP&utm_content=001&dom&key=xuSZvDYrb0FnU5VjU4uRNuT%2BrhnEfRT%2F3X15zK%2BxG58%3D&token=g2vEv5ixd0HTUPQhOozJ%2FUNyNACgqj6ZIF7dH%2BbIHaUkUk2L4%2FJGhYGkwST674t%2B>
>

Whoops, accidently sent the request to [email-masked], should
have sent it to [email-masked]. Have resent the request to the correct
mailing list now. Thanks for pointing it out.
-Vaibhav

> canâ€™t get them together again, there must be a reason.  By all means, do
> not
> use a hammer.
>                 â€” IBM Manual, 1925
>
>