Subject: [Jmap] Protocol Testing Service

From: डाटा<[email-masked]>
Date: Thu, 16 Nov 2017 16:24:08 +0530 (IST)

Hello,I was just wondering, if there is a tool available which can test the protocol and support for IMAP server.  Please let me know personally, off the list. ThanksAjay
[XGENFOOTER][-XGENFOOTER]
Do not Remove:[HID]20171116103259444[-HID]

---

From: Bron Gondwana <[email-masked]>
Date: Thu, 16 Nov 2017 20:52:00 +0800

CCing the list because it's of general interest.

There's no comprehensive public test suite for JMAP yet, because it's
still changing too much.  There's some early draft work here:
https://github.com/fastmail/JMAP-TestSuite

And a bunch of JMAP is tested by the Cassandane tests for Cyrus-IMAPd,
but they're not factored out to be useful outside Cassandane:
https://github.com/cyrusimap/cassandane/

In particular the mail part is tested with:

https://github.com/cyrusimap/cassandane/blob/master/Cassandane/Cyrus/JMAPMail.pm
....

But you asked about IMAP.  The most comprehensive IMAP testing suite is
Timo's excellent ImapTest:
https://imapwiki.org/ImapTest

Regards,

Bron.

P.S. Cassandane also includes drivers for both JMAP-TestSuite and
     ImapTest, so they can be run against Cyrus IMAP as part of our
     continuous integration tests.  You've very welcome to look at how
     they've been hooked into a full environment there.
On Thu, 16 Nov 2017, at 18:54, डाटा wrote:
> Hello,
> 
> I was just wondering, if there is a tool available which can test the
> protocol and support for IMAP server.  Please let me know personally,
> off the list.> 
> Thanks
> 
> Ajay 
> 
> [XGENFOOTER]
> 
> [-XGENFOOTER]
> 
> Do not Remove:
> _________________________________________________
> Jmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jmap

--
  Bron Gondwana, CEO, FastMail Pty Ltd
  [email-masked]