Subject: [Json] Proposed document set from this WG

From: Paul Hoffman <[email-masked]>
Date: Tue, 19 Feb 2013 16:47:22 -0800

Straw-man, personal opinions.

1) JSON base, 4627bis
   Target: current JSON users
   Current: grammar, encoding, parser rules, generator rules, MIME type registration)
   New: Internet transfer rules, list of changes from 4627

2) JSON value comparison
   Target: systems that want to compare two JSON values (usually objects) for equivalence
   Character equivalence rules
   Unicode normalization (if any)
   Numeric normalization (if any)

3) JSON document description
   Target: systems that want to be sure an incoming document is what they expect it to be
   Might be schema-like, might just be content rules

Both #2 and #3 are useful, but to a much smaller audience than #1. #2 and #3 are also much more exciting than #1, but that excitement in the XML world has led to efforts that have been actively harmful.

4) JSON patching and testing
   Target: systems that use JSON as a data model and need to change data

#4 is even more marginal than #2 and #3, but would need to be done in a JSON-focused WG.

5+) JSON format for X
   Target: systems that use data of type X (personal information, calendar items, DNS records, ...)

The WG might *not* be chartered to do any of #5+, and each X needs its own mailing list. Draft updates might be mentioned on the WG mailing list.

--Paul Hoffman

---

From: Francis Galiegue <[email-masked]>
Date: Wed, 20 Feb 2013 02:00:33 +0100

Hello,

> Straw-man, personal opinions.

Even within this scope, I feel the need to comment as the author of
proposals for #2 and #3 ;)

[...]
> Both #2 and #3 are useful, but to a much smaller audience than #1. #2 and #3 are also much more exciting than #1, but that excitement in the XML world has led to efforts that have been actively har…

This is why I regard input to the current JSON Schema I-Ds as
especially critical. I _think_ right now the core and validation specs
can be steered "back into shape" before it is too late. The hyper
schema specification (author CC:ed) covers a much larger ground, and I
am not sure whether it enters the scope of this particular working
group.

And yes, the current core specification has an attempt at #2. And as
has been coined on this list already, it can be improved upon.

> #4 is even more marginal than #2 and #3, but would need to be done in a JSON-focused WG.

I fail to see how "and testing" differs from #3 here? Are you
referring to the "test" operation of the current JSON Patch I-D?

Cheers,
-- 
Francis Galiegue, [email-masked]
Try out your JSON Schemas: http://json-schema-validator.herokuapp.com