Subject: [Json] Another small charter change

From: Paul Hoffman <[email-masked]>
Date: Fri, 15 Mar 2013 08:46:26 -0400

As Jim Schaad pointed out in the BoF, we need a small change to the third paragraph. I have removed "It is clear that at this point, as the IETF specification is the standard one" from the beginning of the third paragraph because some people consider the ECMAScript document to be the standard.

Does anyone object to this?

--Paul Hoffman

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 15 Mar 2013 10:18:02 -0400

> As Jim Schaad pointed out in the BoF, we need a small change to the third paragraph. I have removed "It is clear that at this point, as the IETF specification is the standard one" from the beginnin…

Hmm.

1) 4627 is not a "standard", indeed.
2) "It is clear that" is code for "I don't know how to substantiate my view that".

3) However, I'm not happy with allowing the impression as if JSON were a part of JavaScript.
   The whole point was that it is not.  JSON was *derived* from JavaScript, and some changes 
   were made.  Further evolution of JavaScript does not change JSON (ensuring this property
   *was* why the changes were made).  (The fact that the set of JavaScript implementations 
   of JSON is an important one to consider when making potentially compatibility-affecting
   fixes notwithstanding.)
   
As long as we agree that removing the text is not implicitly a retraction of the view that it is 4627 that defines JSON, I'm fine with the change.

Grüße, Carsten

---

From: Tim Bray <[email-masked]>
Date: Fri, 15 Mar 2013 08:02:50 -0700

Heh, when I want to refresh myself on JSON syntax I go neither to the RFC
nor to the ECMA, but to json.org.  So, yes to the change. -T

On Fri, Mar 15, 2013 at 5:46 AM, Paul Hoffman <[email-masked]> wrote:

> As Jim Schaad pointed out in the BoF, we need a small change to the third
> paragraph. I have removed "It is clear that at this point, as the IETF
> specification is the standard one" from the beginning of the third
> paragraph because some people consider the ECMAScript document to be the
> standard.
>
> _______________________________________________
> json mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/json
>