Subject: [Json] JSON & ECMA

From: Larry Masinter <[email-masked]>
Date: Sat, 16 Mar 2013 15:20:36 -0700

I wish the charter included an explicit liaison statement about coordinating with TC39 to insure that the new IETF spec is suitable for, and used as normative reference from ECMAScript 6. 

I also wish the charter included an explicit liaison with both W3C and WHATWG that made forking unlikely, because of participation in the review.

I'd like to work on updating http://tools.ietf.org/html/bcp70 , RFC 3470, "Guidelines for the Use of Extensible Markup Language (XML) within IETF Protocols" to cover JSON and also the considerations of XML vs. JSON,  as a working group item.

---

From: Paul Hoffman <[email-masked]>
Date: Sat, 16 Mar 2013 15:29:45 -0700

> I wish the charter included an explicit liaison statement about coordinating with TC39 to insure that the new IETF spec is suitable for, and used as normative reference from ECMAScript 6. 

We can't do that for the simple reason that there is no liaison relationship between the IETF and ECMA. I have heard that the IAB is now discussing this based on the discussion in the BoF this week.

> I also wish the charter included an explicit liaison with both W3C and WHATWG that made forking unlikely, because of participation in the review.

Neither of those SDOs have specs that claim to define JSON, do they? If not, why would they fork?

And, also, the IETF has no liaison relationship with WHATWG.

Of course, we will reach out far and wide asking for review. 

> I'd like to work on updating http://tools.ietf.org/html/bcp70 , RFC 3470, "Guidelines for the Use of Extensible Markup Language (XML) within IETF Protocols" to cover JSON and also the consideration…

Are you saying you want that as an initial charter item, or to be considered in the second step after we finish 4627bis? My preference is the latter, so that we can focus on the one main topic. Also, such an update would naturally parallel work on a JSON schema / description document.

--Paul Hoffman

---

From: Tim Bray <[email-masked]>
Date: Sat, 16 Mar 2013 15:53:22 -0700

> > I wish the charter included an explicit liaison statement about
coordinating with TC39 to insure that the new IETF spec is suitable for,
and used as normative reference from ECMAScript 6.
>
> We can't do that for the simple reason that there is no liaison
relationship between the IETF and ECMA. I have heard that the IAB is now
discussing this based on the discussion in the BoF this week.

Does the community get a chance to comment? I would argue strongly against
any relationship with ECMA given an opportunity.

>
> > I also wish the charter included an explicit liaison with both W3C and
WHATWG that made forking unlikely, because of participation in the review.
> > I'd like to work on updating http://tools.ietf.org/html/bcp70 , RFC
3470, "Guidelines for the Use of Extensible Markup Language (XML) within
IETF Protocols" to cover JSON and also the considerations of XML vs. JSON,
 as a working group item.
>
> Are you saying you want that as an initial charter item, or to be
considered in the second step after we finish 4627bis? My preference is the
latter, so that we can focus on the one main topic. Also, such an update
would naturally parallel work on a JSON schema / description document.
>
> --Paul Hoffman
> _______________________________________________
> json mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/json

---

From: Paul Hoffman <[email-masked]>
Date: Sat, 16 Mar 2013 16:58:00 -0700

On Mar 16, 2013, at 3:53 PM, Tim Bray <[email-masked]> wrote:

> Does the community get a chance to comment? I would argue strongly against any relationship with ECMA given an opportunity.

The community gets lots of opportunities to comment. We are now deciding what the WG charter should look like. Later, we will have opportunities to update the charter to add new work and other considerations.

--Paul Hoffman

---

From: Larry Masinter <[email-masked]>
Date: Sun, 24 Mar 2013 13:56:58 -0700

How about "The working group should work to ensure that the JSON specification produced will be suitable for being the normative definition of JSON referenced from specifications from other standards groups, including W3C and ECMA TC39."

That doesn't require any direct coordination, but makes it clear that the intent is that other specs normatively reference this one.

As for BCP 70 / RFC 3470 update, I don't mind making it a second work item but if it is in the charter, it lets an update to 3470 be a working-group draft.

---

From: Eliot Lear <[email-masked]>
Date: Mon, 25 Mar 2013 16:41:22 +0100

Tim,

On 3/16/13 11:53 PM, Tim Bray wrote:
>
>
> Does the community get a chance to comment? I would argue strongly
> against any relationship with ECMA given an opportunity.
>

I'd like to understand your concerns.  We are already normatively
referencing ECMA-262 in RFC-4627.  It's important to establish who the
design authority is.  At least one person at ECMA thinks they are, for
what it's worth.  That argues for some communication to avoid two
competing standards.

Eliot

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 25 Mar 2013 08:49:37 -0700

On Mar 25, 2013, at 8:41 AM, Eliot Lear <[email-masked]> wrote:

> I'd like to understand your concerns.  We are already normatively referencing ECMA-262 in RFC-4627.  It's important to establish who the design authority is.  At least one person at ECMA thinks they are, for what it's worth.  That argues for some communication to avoid two competing standards.

The actual text from RFC 4627 says:

   It is derived from the object
   literals of JavaScript, as defined in the ECMAScript Programming
   Language Standard, Third Edition [ECMA].

That is, the JSON grammar is derived from the JavaScript literals, but RFC 4627 does not cede design authority to ECMAScript.

A few weeks ago, Douglas said:

The JSON Standard was inspired by ECMA's ECMAScript Standard, Third Edition, but is not dependent on it. ECMAScript Fifth Edition does not define JSON, but implements the JSON standard in ECMAScript. Changes in the ECMAScript Standard have no impact on JSON. JSON is language independent.

That seems right to me.

--Paul Hoffman

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 25 Mar 2013 08:51:57 -0700

On Mar 24, 2013, at 1:56 PM, Larry Masinter <[email-masked]> wrote:

> How about “The working group should work to ensure that the JSON specification produced will be suitable for being the normative definition of JSON referenced from specifications from other standards groups, including W3C and ECMA TC39.”

How is that an actionable statement for the charter?

What could this WG do that would *not* make the specification we produce "be suitable for being the normative definition of JSON referenced from specifications from other standards groups, including W3C and ECMA TC39"?

> That doesn’t require any direct coordination, but makes it clear that the intent is that other specs normatively reference this one.

I think us putting in the charter things that put pressure on other SDOs is not terribly productive for anyone. Maybe let's keep the charter about the IETF work.

--Paul Hoffman

---

From: Larry Masinter <[email-masked]>
Date: Mon, 25 Mar 2013 13:54:21 -0700

I was talking about the IETF work.

I'd like it to be clear in the IETF working group charter that other standards groups working on related technology will have their requirements considered "in scope" to the IETF work.

> -----Original Message-----
> From: Paul Hoffman [mailto:[email-masked]]
> Sent: Monday, March 25, 2013 8:52 AM
> To: Larry Masinter
> Cc: [email-masked]
> Subject: Re: [Json] JSON & ECMA
> 
> > How about "The working group should work to ensure that the JSON
> specification produced will be suitable for being the normative definition of
> JSON referenced from specifications from other standards groups, including
> W3C and ECMA TC39."
> 

It would mean that requirements from other standards groups would
explicitly be "in scope" for the IETF work. For example, perhaps ECMAScript 6
could avoid repeating the grammar if only the IETF spec contained a 
named non-terminal to cover the case of not allowing duplicate names.

> What could this WG do that would *not* make the specification we produce
> "be suitable for being the normative definition of JSON referenced from
> specifications from other standards groups, including W3C and ECMA TC39"?

Not acknowledge or give any priority to the requirements of those
wanting to make normative reference.
 
> > That doesn't require any direct coordination, but makes it clear that the
> intent is that other specs normatively reference this one.
> 
> I think us putting in the charter things that put pressure on other SDOs is not
> terribly productive for anyone. Maybe let's keep the charter about the IETF
> work.

The intent isn't to put pressure on other SDOs. It is to put pressure on
IETF participants to make best effort to accommodate other SDOs.