Subject: [Json] JSON & ECMA

From: Douglas Crockford <[email-masked]>
Date: Fri, 15 Mar 2013 12:45:36 -0700

The JSON Standard was inspired by ECMA's ECMAScript Standard, Third 
Edition, but is not dependent on it. ECMAScript Fifth Edition does not 
define JSON, but implements the JSON standard in ECMAScript. Changes in 
the ECMAScript Standard have no impact on JSON. JSON is language 
independent.

There is a question about where the JSON Standard should live. One 
theory is that it should be at IETF, because there is an informational 
RFC that associated JSON with the MIME type application/json. The other 
theory is that the standard should live at ECMA because JSON was 
initially derived from ECMAScript, and because ECMA is related to ISO.

I do not know how this should be decided.

---

From: Tim Bray <[email-masked]>
Date: Fri, 15 Mar 2013 13:03:46 -0700

It should live somewhere with good googlejuice that has moderately sane
editorial processes and where the likelihood that someone will grab the
steering wheel and do something stupid is acceptably low.  IETF is
plausible on that metric.

In my personal experience (which may be unusual), ISO and (to a greater
degree) ECMA combine corruption and ineptitude on an epic scale, so that
association would be a negative. Others may differ. -T

On Fri, Mar 15, 2013 at 12:45 PM, Douglas Crockford
<[email-masked]>wrote:

> define JSON, but implements the JSON standard in ECMAScript. Changes in the
> ECMAScript Standard have no impact on JSON. JSON is language independent.
>
> There is a question about where the JSON Standard should live. One theory
> is that it should be at IETF, because there is an informational RFC that
> associated JSON with the MIME type application/json. The other theory is
> that the standard should live at ECMA because JSON was initially derived
> from ECMAScript, and because ECMA is related to ISO.
>
> ______________________________**_________________
> json mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/json<https://www.ietf.org/mailman/listinfo/json>
>

---

From: Paul Hoffman <[email-masked]>
Date: Sat, 16 Mar 2013 09:51:56 -0700

On Mar 15, 2013, at 12:45 PM, Douglas Crockford <[email-masked]> wrote:

> The JSON Standard was inspired by ECMA's ECMAScript Standard, Third Edition, but is not dependent on it. ECMAScript Fifth Edition does not define JSON, but implements the JSON standard in ECMAScript.

I read the text in v5.1 as defining JSON, even if the JSON community doesn't allow that. That is, I don't see anything there that says "this is not really the standard".

> Changes in the ECMAScript Standard have no impact on JSON. JSON is language independent.

Both are good to hear.

> There is a question about where the JSON Standard should live. One theory is that it should be at IETF, because there is an informational RFC that associated JSON with the MIME type application/json. The other theory is that the standard should live at ECMA because JSON was initially derived from ECMAScript, and because ECMA is related to ISO.
> 

In some sense, the people who decide that are the JSON-using community. There is no law here, just code.

--Paul Hoffman

---

From: R S <[email-masked]>
Date: Sat, 16 Mar 2013 16:08:36 -0700

It would be good to update the RFC.

- Rob

On Fri, Mar 15, 2013 at 12:45 PM, Douglas Crockford
<[email-masked]> wrote:
> The JSON Standard was inspired by ECMA's ECMAScript Standard, Third Edition,
> but is not dependent on it. ECMAScript Fifth Edition does not define JSON,
> but implements the JSON standard in ECMAScript. Changes in the ECMAScript
> Standard have no impact on JSON. JSON is language independent.
>
> There is a question about where the JSON Standard should live. One theory is
> that it should be at IETF, because there is an informational RFC that
> _______________________________________________
> json mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/json