Subject: Re: [Json] Last call: JSON charter

From: Ray Polk <[email-masked]>
Date: Fri, 29 Mar 2013 12:41:46 -0700 (PDT)

Was it suggested (perhaps by Paul?) in Orlando that we consider reorganizing the RFC into three parts?  Then also perhaps replacing one of those parts with a reference to a corresponding section of the ECMAScript spec?  (sorry, I can't find the minutes from the BoF.)

Issues with ECMA dependencies notwithstanding, I liked the idea not repeating ourselves.  Would such an addition be too much of a distraction/detraction from the primary objectives?

-Ray
 
----- Original Message -----
From: [email-masked]
To: [email-masked]
Sent: Friday, March 29, 2013 12:03:58 PM GMT -07:00 US/Canada Mountain
Subject: Re: [Json] Last call: JSON charter

On Mar 29, 2013, at 10:39 AM, Joe Hildebrand (jhildebr) <[email-masked]> wrote:

> Please review and send your final comments on the proposed charter for a
> potential JSON working group:
> 
> http://trac.tools.ietf.org/wg/appsawg/trac/wiki/JSON
> 
> 
> If you have been participating on the list, please chime in on this thread
> even if you have already said you agree with that text.

The proposed text as it stands today seems fine to me.

(To reiterate what I said to Larry's proposal: I would likely object to adding wording about other SDOs to this charter.)

--Paul Hoffman

_______________________________________________
json mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/json

---

From: Paul Hoffman <[email-masked]>
Date: Fri, 29 Mar 2013 13:34:25 -0700

On Mar 29, 2013, at 12:41 PM, Ray Polk <[email-masked]> wrote:

> Was it suggested (perhaps by Paul?) in Orlando that we consider reorganizing the RFC into three parts?

My presentation emphasized the different topics in the three sections already in RFC 4627. Section 2 is grammar, Section 3 is encoding, Section 4 is parsers, Section 5 is generators, and Section 6 is IANA considerations. I could see us reorganizing the document a bit to move the trivial amount of text from Section 5 into Section 3, maybe move the encoding discussion into the IANA considerations. The only reason we might want to reorganize the document is to make the topic split even clearer. For example, there is currently a sentence about parsers in the grammar section.

>  Then also perhaps replacing one of those parts with a reference to a corresponding section of the ECMAScript spec?  (sorry, I can't find the minutes from the BoF.)

There was discussion of that, but there was also pushback.

> Issues with ECMA dependencies notwithstanding, I liked the idea not repeating ourselves.  Would such an addition be too much of a distraction/detraction from the primary objectives?

That might be fodder for the WG discussion.

--Paul Hoffman