Subject: Re: [Json] ECMAScript v6 adds new escape sequence: \u{x…}

From: "Manger, James H" <[email-masked]>
Date: Tue, 12 Mar 2013 23:59:23 +1100

>> In an ECMAScript 6th edition draft (2012-11-22), a Unicode escape can be \uxxxx, or \u{x...}. > Hence, "\n" = "\u000A" = "\u{A}".

> Why would that nice new JS feature change JSON?
>
>Grüße, Carsten

Because though the \u{x...} rule is defined in a section about JS lexical conventions, it is also referenced by section A.8.1 "JSON Lexical Grammar".

...actually ECMAScript edition 6 drafts repeat the JSON Lexical Grammar in 2 places: section 15.12.1 and Annex A.8 and they DISAGREE!

My guess is that \u{x...} does NOT apply to JSON, but they have forgotten to update the annex to reflect this.

--
James Manger

----- Reply message -----
From: "Carsten Bormann" <[email-masked]>
Date: Tue, Mar 12, 2013 10:38 pm
Subject: [Json] ECMAScript v6 adds new escape sequence: \u{x…}
To: "Manger, James H" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>

On Mar 12, 2013, at 01:11, "Manger, James H" <[email-masked]> wrote:

> In an ECMAScript 6th edition draft (2012-11-22), a Unicode escape can be \uxxxx, or \u{x...}.
> Hence, "\n" = "\u000A" = "\u{A}".

Why would that nice new JS feature change JSON?

Grüße, Carsten

_______________________________________________
json mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/json

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 12 Mar 2013 09:06:08 -0400

> My guess is that \u{x...} does NOT apply to JSON, but they have forgotten to update the annex to reflect this.

Ah.  Do they have a channel for putting in bug reports?

Grüße, Carsten