Subject: [Json] 8.2. "A JSON text which is composed entirely of Unicode characters"

From: "Manger, James H" <[email-masked]>
Date: Fri, 20 Sep 2013 13:30:50 +1000

Section 8.2. "Unicode Characters" of draft-ietf-json-rfc4627bis-03 says JSON text is interoperable when it is "composed entirely of Unicode characters".

This is poorly worded. {"\DEAD":1} is a JSON text composed of 11 characters — all 11 of which are Unicode characters — but it is NOT interoperable.

Presumably we want to say that if all the logical strings that are represented in a JSON text are composed entirely of Unicode characters then it is interoperable.

Suggestion: modify the first sentence of 8.3 to:

   When all the strings represented in a JSON text are composed
   entirely of Unicode characters [UNICODE] (however escaped),
   then that JSON text is interoperable in the sense that all
   software implementations which parse it will agree on the contents.

P.S. This sentence also drops the last line as implementations will
agree on array items etc, not just object members.

[For comparison, the draft 3 sentence is:

   A JSON text which is composed entirely of Unicode characters
   [UNICODE] (however encoded) is interoperable in the sense that all
   software implementations which parse it will agree on the contents of
   names and values of object members. ]

--
James Manger

---

From: Tim Bray <[email-masked]>
Date: Thu, 19 Sep 2013 21:01:02 -0700

You mean \uDEAD in your example, but I take your point. Actually both your
points, because there are strings in arrays too, d’oh. Let’s take James’
edit for the next draft unless someone sees something he and I missed.  Hm,
except for they might not agree on the contents of too-big numbers, so
it'll have to be “agree on the content of names and string values in
objects and arrays”.   -T

On Thu, Sep 19, 2013 at 8:30 PM, Manger, James H <
[email-masked]> wrote:

> Section 8.2. "Unicode Characters" of draft-ietf-json-rfc4627bis-03 says
> JSON text is interoperable when it is "composed entirely of Unicode
> characters".
>
> This is poorly worded. {"\DEAD":1} is a JSON text composed of 11
> characters — all 11 of which are Unicode characters — but it is NOT
> interoperable.
>
> Presumably we want to say that if all the logical strings that are
> represented in a JSON text are composed entirely of Unicode characters then
> it is interoperable.
>
>
> _______________________________________________
> json mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/json
>