Subject: Re: [Json] REMINDER - WGLC Ends 2013-10-11

From: Allen Wirfs-Brock <[email-masked]>
Date: Fri, 11 Oct 2013 16:21:25 -0700

I didn't suggest removing the ABNF. I suggested relabeling it as informative. 

Tim Bray <[email-masked]> wrote:

>Since the normative definitions are isomorphic, there is no benefit to the reader in making them go somewhere else to discover what is already present in this document, and that would be the only effect of removing the syntax specification, especially since there is no intention anywhere that the syntax ever change.  -T
>
>
>
>On Fri, Oct 11, 2013 at 4:00 PM, Allen Wirfs-Brock <[email-masked]> wrote:
>
>We really should avoid having two (Ecma-404 and rfc4627bis) normative syntax specifications for JSON text.  Since it is claimed that the 4627bis ABNF recognizes the same language as that described by the Ecma-404 syntax diagrams it would seem more appropriate for 4627bis to narratively reference Ecma-404 and say that the 4627bis ABNF is an informative restatement of the Ecma-404 syntax specification.
>
>Notational preference really isn't a very good reason to have  two different normative definitions of the same thing.
>
>Allen Wirfs-Brock
>
>_______________________________________________
>json mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/json
>
>

---

From: Tim Bray <[email-masked]>
Date: Fri, 11 Oct 2013 16:24:17 -0700

Have a look at the “Specifications of JSON” section.  I think it makes it
clear that there are multiple specifications of JSON, they are all in
perfect harmony as to the syntactic elements of the language, and thus it
would be counterproductive to suggest that the reader needs to go anywhere
else to make sure they have it right.

This is one of the nice things about working with JSON, there is no
disagreement as to the syntax of the language.

On Fri, Oct 11, 2013 at 4:21 PM, Allen Wirfs-Brock <[email-masked]>wrote:

> Since the normative definitions are isomorphic, there is no benefit to the
> reader in making them go somewhere else to discover what is already present
> in this document, and that would be the only effect of removing the syntax
> specification, especially since there is no intention anywhere that the
> syntax ever change.  -T
>
>
> On Fri, Oct 11, 2013 at 4:00 PM, Allen Wirfs-Brock <[email-masked]>wrote:
>
>> We really should avoid having two (Ecma-404 and rfc4627bis) normative
>> syntax specifications for JSON text.  Since it is claimed that the 4627bis
>> ABNF recognizes the same language as that described by the Ecma-404 syntax
>> diagrams it would seem more appropriate for 4627bis to narratively
>> reference Ecma-404 and say that the 4627bis ABNF is an informative
>> restatement of the Ecma-404 syntax specification.
>>
>> Notational preference really isn't a very good reason to have  two
>> different normative definitions of the same thing.
>>
>> Allen Wirfs-Brock

---

From: Bjoern Hoehrmann <[email-masked]>
Date: Sat, 12 Oct 2013 02:04:02 +0200

>disagreement as to the syntax of the language.

The W3C specification for XML 1.0 says you cannot put a string like `1`
at the top level of a document, you have to wrap it inside an element.

So, if ECMA published their own specification for XML 1.0 that says the
string `1` is a well-formed XML 1.0 document, and the W3C specification
keeps saying the opposite, would you really describe that as perfect
harmony with no disagreement about what constitutes a well-formed XML
1.0 document? What would your XML 1.0 processor do when asked to parse
the string `1` in this scenario?

Under ECMA-404 the string `1` is "JSON text" but it is not "JSON text"
under the definition in RFC 4627 or draft-ietf-json-rfc4627bis-06. How
is that different from the scenario above? I can't imagine you saying
"This is one of the nice things about working with XML, some parsers
accept the string `1` correctly as well-formed XML document, while some
other processors correctly treat it as non-conforming garbage" but that
is the situation we have with JSON.
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/

---

From: Tim Bray <[email-masked]>
Date: Fri, 11 Oct 2013 19:04:10 -0700

Once again, check out
https://www.tbray.org/tmp/draft-ietf-json-rfc4627bis-06.html#rfc.section.1.2-
it is perfectly clear that the syntax is the same in all specs, with
the
difference that the ECMA flavor has not required JSON texts to be arrays or
objects at the top level.  This difference has existed for a long time,
JSON has managed to prosper in the face of it, and there is no good reason
to do anything about it aside from noting its existence. -T

---

From: R S <[email-masked]>
Date: Fri, 11 Oct 2013 19:07:43 -0700

I think Tim is correct.

- Rob
 On Oct 11, 2013 7:04 PM, "Tim Bray" <[email-masked]> wrote:

> Once again, check out
> https://www.tbray.org/tmp/draft-ietf-json-rfc4627bis-06.html#rfc.section.1.2- it is perfectly clear that the syntax is the same in all specs, with the
> On Fri, Oct 11, 2013 at 5:04 PM, Bjoern Hoehrmann <[email-masked]>wrote:
>
>> * Tim Bray wrote: