Subject: [Json] {"Height": 125, "Width": "100"} example

From: "Manger, James H" <[email-masked]>
Date: Thu, 10 Oct 2013 12:03:21 +1100

4627 and 4627bis include an example with the following object members:
  {
    "Height": 125,
    "Width":  "100"
  },

This looks like a typo ("100" instead of 100), but it is still valid JSON.

Is this a typo (that -bis should correct)?
Or is this a subtle suggestion to JSON parsers that they should automatically
try to convert strings to numbers if an app asks for, say, the "Width" field
as an int but the parser finds a string in the JSON?

--
James Manger

---

From: Tim Bray <[email-masked]>
Date: Wed, 9 Oct 2013 21:55:58 -0700

Don’t know if it’s a typo, but it’s kind of charmingly idiosyncratic and
has lasted all these years... let’s spare it.

On Wed, Oct 9, 2013 at 6:03 PM, Manger, James H <
[email-masked]> wrote:

> _______________________________________________
> json mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/json
>

---

From: "Martin J. Dürst" <[email-masked]>
Date: Thu, 10 Oct 2013 14:46:00 +0900

> has lasted all these years... let’s spare it.

It's charmingly idiosyncratic (or should we call this idiosyntactic?) 
for those who have enough self-confidence to see what's going on.

Without explanation, it's not an example that should be copied in any 
way, so I strongly advocate fixing it one way or the other (i.e. 
removing the quotes from "100", changing "Width" to a property name more 
in line with a string value, adding an explanation, or some such).

Regards,   Martin.

> On Wed, Oct 9, 2013 at 6:03 PM, Manger, James H<

---

From: Paul Hoffman <[email-masked]>
Date: Thu, 10 Oct 2013 08:59:11 -0700

On Oct 9, 2013, at 9:55 PM, Tim Bray <[email-masked]> wrote:

> Don’t know if it’s a typo, but it’s kind of charmingly idiosyncratic and has lasted all these years... let’s spare it. 

I would rather fix it, given that it does hint at something wrong, unnecessarily.

--Paul Hoffman

---

From: "Matt Miller (mamille2)" <[email-masked]>
Date: Thu, 10 Oct 2013 16:20:09 +0000

> Don’t know if it’s a typo, but it’s kind of charmingly idiosyncratic and has lasted all these years... let’s spare it. 

/me doffs hat

Syntactically, the example is valid to the ABNF.  Pedantically, some people will get hung up on this seeming wrong.  It's a nit, but I think it's worth addressing.

- m&m

Matt Miller < [email-masked] >
Cisco Systems, Inc.

---

From: Tim Bray <[email-masked]>
Date: Thu, 10 Oct 2013 09:35:39 -0700

OK, OK.  You guys are no fun.

On Thu, Oct 10, 2013 at 9:20 AM, Matt Miller (mamille2)
<[email-masked]>wrote:

> Syntactically, the example is valid to the ABNF.  Pedantically, some
> people will get hung up on this seeming wrong.  It's a nit, but I think
> it's worth addressing.
>
>
> - m&m
>