Subject: Re: [Json] LC comment on http://tools.ietf.org/html/draft-ietf-json-rfc4627bis-07#section-11

From: Julian Reschke <[email-masked]>
Date: Thu, 05 Dec 2013 17:31:54 +0100

On 2013-11-12 08:18, Julian Reschke wrote:
> <http://tools.ietf.org/html/draft-ietf-json-rfc4627bis-07#section-11>:
>
>>    Encoding considerations:  8bit if UTF-8; binary if UTF-16 or UTF-32.
>>       JSON may be represented using UTF-8, UTF-16, or UTF-32.  When JSON
>>       is written in UTF-8, JSON is 8bit compatible.  When JSON is
>>       written in UTF-16 or UTF-32, the binary content-transfer-encoding
>>       must be used.
>
> That is a bit misleading, because content-transfer-encoding isn't needed
> (nor defined) if the transport allows binary anyway (such as HTTP).
>
> Related to this: a frequent question on stackoverflow is about the
> charset parameter on application/json. Maybe it's worth re-stating that
> it is not only not defined but also really really has no effect.

Hi there,

again, it would be great if we could add something like:

"Note: there really is no 'charset' parameter defined. Adding one really 
has no effect on compliant recipients."

Best regards, Julian

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 5 Dec 2013 17:35:42 +0100

On 05 Dec 2013, at 17:31, Julian Reschke <[email-masked]> wrote:

> "Note: there really is no 'charset' parameter defined. Adding one really has no effect on compliant recipients."

+1, another piece of redundancy that is well called for.

(I trust the editor will come up with a sentence without two “really”s :*)

Grüße, Carsten

---

From: Paul Hoffman <[email-masked]>
Date: Thu, 5 Dec 2013 11:03:52 -0800

<hat on>

Tim: please add the following to the end of Section 11.

   Note: no "charset" parameter is defined for this registration.
   Adding one really has no effect on compliant recipients.

This will probably cause a delay in the RFC being issued, and the IESG might ask us to remove it, but if it keeps coming up on StackOverflow, we should at least make a stab at answering it.

--Paul Hoffman

---

From: Bjoern Hoehrmann <[email-masked]>
Date: Thu, 05 Dec 2013 21:10:36 +0100

>   Adding one really has no effect on compliant recipients.

I think such a statement is not supported by the requirements in the
specification. It would have to say that is incorrect to use the value
of a charset parameter to determine the encoding of the document.
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/