Subject: [Json] media types for i-json profiles

From: Larry Masinter <[email-masked]>
Date: Fri, 24 Jan 2014 03:57:05 +0000

Can anyone give a single concrete use case where having two media types

   application/XXX+i-json and
   application/XXX+json

or just having both

      application/json
and application/i-json

is even a little bit useful or the difference significant? The only situations I can imagine (oh, validation of input, processing them differently, or some guarantee of ‘safety’) don’t work out for me.

Ø  recommending that people who specify protocols based on i-json use an application/XXX+i-json media type.

Larry
--
http://larry.masinter.net

---

From: "Martin J. Dürst" <[email-masked]>
Date: Fri, 24 Jan 2014 15:40:16 +0900

Fully agreed. I tried to say the same thing in
http://www.ietf.org/mail-archive/web/json/current/msg02373.html.

Regards,    Martin.

On 2014/01/24 12:57, Larry Masinter wrote:
> _______________________________________________
> json mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/json

---

From: "Manger, James" <[email-masked]>
Date: Fri, 24 Jan 2014 23:29:25 +1100

> is even a little bit useful or the difference significant? The only
> situations I can imagine (oh, validation of input, processing them
> differently, or some guarantee of ‘safety’) don’t work out for me.
> 
> 
> ➢  recommending that people who specify protocols based on i-json use
> an application/XXX+i-json media type.
> 
> 
> Larry
> --

No. There is no reason to have application/XXX+i-json and application/XXX+json.
But draft-bray-i-json-01 no longer suggests that.
It does not define application/i-json.
It recommends that new protocols define an application/XXX+i-json media type, presumably *instead of* an application/XXX+json one (not in addition to it).

It would help to be just a bit clearer that a new message spec that needs a new media type SHOULD choose one of the form application/XXX+i-json, but messages that already have media types do not need new ones. In particular, application/XXX+i-json SHOULD NOT be defined if application/XXX+json is already defined for the same messages.

I would still prefer to drop application/XXX+i-json all together.

--
James Manger