Subject: [Json] [Technical Errata Reported] RFC7159 (3915)

From: RFC Errata System <[email-masked]>
Date: Fri, 7 Mar 2014 09:12:44 -0800 (PST)

The following errata report has been submitted for RFC7159,
"The JavaScript Object Notation (JSON) Data Interchange Format".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=7159&eid=3915

--------------------------------------
Type: Technical
Reported by: Vasiliy Faronov <[email-masked]>

Section: 12

Original Text
-------------
   Since JSON's syntax is borrowed from JavaScript, it is possible to
   use that language's "eval()" function to parse JSON texts.

Corrected Text
--------------
   Since JSON's syntax is borrowed from JavaScript, it is possible to
   use that language's "eval()" function to parse most (but not all)
   JSON texts.

Notes
-----
This wording may be construed as meaning that every compliant JSON text is parseable as JavaScript, which is not the case: <http://timelessrepo.com/json-isnt-a-javascript-subset>. (Actually I would prefer this to be stated clearly elsewhere in the document, e.g. where it says “JSON's design goals were for it to be [...] a subset of JavaScript”.)

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7159 (draft-ietf-json-rfc4627bis-rfc7159bis)
--------------------------------------
Title               : The JavaScript Object Notation (JSON) Data Interchange Format
Publication Date    : March 2014
Author(s)           : T. Bray, Ed.
Category            : PROPOSED STANDARD
Source              : JavaScript Object Notation
Area                : Applications
Stream              : IETF
Verifying Party     : IESG

---

From: Paul Hoffman <[email-masked]>
Date: Thu, 13 Mar 2014 08:25:23 -0700

> "The JavaScript Object Notation (JSON) Data Interchange Format".

The WG chairs request that you approve this errata.

--Matt Miller and Paul Hoffman

---

From: Larry Masinter <[email-masked]>
Date: Thu, 13 Mar 2014 21:31:27 +0000

> The WG chairs request that you approve this errata.

I think the errata would be more useful if it actually explained the \u2028, \u2029 exception, rather than leaving it in a potentially unstable reference
http://timelessrepo.com/json-isnt-a-javascript-subset

Should \u2028 \u2029 characters be disallowed from an "i-json" profile? Since the purpose is a "safe subset"?

---

From: Tim Bray <[email-masked]>
Date: Thu, 13 Mar 2014 14:33:42 -0700

That idea is at least plausible. And I bet a walk through the unicode
separator and white-space definitions might turn up a few more candidates.

On Thu, Mar 13, 2014 at 2:31 PM, Larry Masinter <[email-masked]> wrote:

> I think the errata would be more useful if it actually explained the
> \u2028, \u2029 exception, rather than leaving it in a potentially unstable
> reference

---

From: R S <[email-masked]>
Date: Thu, 13 Mar 2014 17:31:50 -0700

Oh bummer, I had raised this earlier:

<http://www.ietf.org/mail-archive/web/json/current/msg00100.html>

- Rob

On Thu, Mar 13, 2014 at 2:33 PM, Tim Bray <[email-masked]> wrote:

> On Thu, Mar 13, 2014 at 2:31 PM, Larry Masinter <[email-masked]>wrote:
>
> _______________________________________________
> json mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/json
>
>

---

From: Pete Resnick <[email-masked]>
Date: Tue, 25 Mar 2014 23:54:30 -0500

> http://timelessrepo.com/json-isnt-a-javascript-subset

I'm not inclined to use the errata system to document this. I'll approve 
the erratum, and I'll leave it to i-json or otherwise to document the 
difference between JSON and JS if necessary.

pr

-- 
Pete Resnick<http://www.qualcomm.com/~presnick/>
Qualcomm Technologies, Inc. - +1 (858)651-4478