Subject: [Json] I-D Action: draft-ietf-json-i-json-04.txt

From: [email-masked]
Date: Fri, 28 Nov 2014 10:09:53 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the JavaScript Object Notation Working Group of the IETF.

        Title           : The I-JSON Message Format
        Author          : Tim Bray
	Filename        : draft-ietf-json-i-json-04.txt
	Pages           : 6
	Date            : 2014-11-28

Abstract:
   I-JSON is a restricted profile of JSON designed to maximize
   interoperability and increase confidence that software can process it
   successfully with predictable results.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-json-i-json/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-json-i-json-04

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-json-i-json-04

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Tim Bray <[email-masked]>
Date: Fri, 28 Nov 2014 10:12:36 -0800

Real HTML at https://www.tbray.org/tmp/draft-ietf-json-i-json-04.html

On Fri, Nov 28, 2014 at 10:09 AM, <[email-masked]> wrote:

> _______________________________________________
> json mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/json
>

-- 
- Tim Bray (If you’d like to send me a private message, see
https://keybase.io/timbray)

---

From: "Manger, James" <[email-masked]>
Date: Mon, 1 Dec 2014 12:37:40 +1100

“A receiving implementation MAY treat two I-JSON messages as equivalent if they differ only in the order of the object members.”

I don’t think this text is a good addition to I-JSON.
MAY treat as equivalent, implies an implementation may also treat them as not equivalent.
I’m not sure how this helps.
Perhaps it is an oblique warning that x.equals(y) might not give the answer you expect when x & y are I-JSON objects differing only in the order of their members?

Suggestion: drop the “MAY treat .. as equivalent” sentence; keeping the preceding sentence (shown below):

“The order of object members in an I-JSON message does not change the meaning of an I-JSON message.”

I actually like the previous wording (in addition to the “.. does not change the meaning ..” sentence):

“Implementations which generate I-JSON messages MUST NOT assume that the order of object members in those messages is available to software which receives them.”
Though I guess others don’t like requirement language that applies to *designers* of I-JSON messages, but prefer to limit requirement language to cases that can be tested directly with a JSON parser or generator code.

--
James Manger

From: json [mailto:[email-masked]] On Behalf Of Tim Bray
Sent: Saturday, 29 November 2014 5:13 AM

On Fri, Nov 28, 2014 at 10:09 AM, <[email-masked]<mailto:[email-masked]>> wrote:

---

From: Tim Bray <[email-masked]>
Date: Sun, 30 Nov 2014 18:42:16 -0800

I agree.  When this was suggested it didn’t bother me but as I was putting
it into the draft I found myself thinking “and how does this help anyone?”
  I actually thought that maybe we should say “A receiving implementation
SHOULD/MUST treat as equivalent…” but just dropping it is better.  I’m OK
with either the “does not change the meaning” or the “MUST NOT assume”
wording.

On Sun, Nov 30, 2014 at 5:37 PM, Manger, James <
[email-masked]> wrote:

> Perhaps it is an oblique warning that x.equals(y) might not give the
> answer you expect when x & y are I-JSON objects differing only in the order
> of their members?
>
>
>
> Though I guess others don’t like requirement language that applies to *
> *designers** of I-JSON messages, but prefer to limit requirement language
> to cases that can be tested directly with a JSON parser or generator code.
>
>
>
> --
>
> James Manger
>
>
>
> *From:* json [mailto:[email-masked]] *On Behalf Of *Tim Bray
> *Sent:* Saturday, 29 November 2014 5:13 AM
>