Subject: [Json] JCR -04

From: Andrew Newton <[email-masked]>
Date: Tue, 2 Dec 2014 16:06:26 -0500

Based on the discussion that took place here, JCR has been updated to -04.
It includes syntax changes and a revised ABNF.

Name: draft-newton-json-content-rules
Revision: 04
Title: A Language for Rules Describing JSON Content
Document date: 2014-12-02
Group: Individual Submission
Pages: 28
URL:
http://www.ietf.org/internet-drafts/draft-newton-json-content-rules-04.txt
Status:
https://datatracker.ietf.org/doc/draft-newton-json-content-rules/
Htmlized:
http://tools.ietf.org/html/draft-newton-json-content-rules-04
Diff:
http://www.ietf.org/rfcdiff?url2=draft-newton-json-content-rules-04

Also, a proof-of-concept JCR parser is here:
http://stash-projects.arin.net/projects/JCR/repos/jcr-validator/browse

-andy

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 3 Dec 2014 07:26:28 +0100

Thanks for getting rid of the alternative syntax, and for reinstating the ABNF.

I’m not a big fan of the new name “pedantic”.  You don’t have to be pedantic to want to close a specific structure to future extension.  Calling these structures “closed” is probably closer (Java fans will want to call them “final” :-).

(The text for language-compatible-members still uses the name "ignore-unknown-members”.
I don’t like that concept too much, anyway…  Too many languages with different rules to choose from.)

Grüße, Carsten

---

From: Erik Wilde <[email-masked]>
Date: Wed, 03 Dec 2014 09:45:29 +0100

hello andrew.

On 2014-12-02, 22:06, Andrew Newton wrote:
> Name:draft-newton-json-content-rules
> Revision:04
> Title:A Language for Rules Describing JSON Content
> Document date:2014-12-02
> Group:Individual Submission
> Htmlized: http://tools.ietf.org/html/draft-newton-json-content-rules-04

some reference to JSON Schema probably would be helpful. as there is no 
formal spec (i guess), pointing to the URI http://json-schema.org/ might 
be the best thing that's possible.

cheers,

dret.

-- 
erik wilde | mailto:[email-masked]  -  tel:+1-510-2061079 |
            | UC Berkeley  -  School of Information (ISchool) |
            | http://dret.net/netdret http://twitter.com/dret |

---

From: Andrew Newton <[email-masked]>
Date: Wed, 3 Dec 2014 10:58:14 -0500

On Wed, Dec 3, 2014 at 1:26 AM, Carsten Bormann <[email-masked]> wrote:

> I’m not a big fan of the new name “pedantic”.  You don’t have to be
> pedantic to want to close a specific structure to future extension.
> Calling these structures “closed” is probably closer (Java fans will want
> to call them “final” :-).
>
>
I don't have a strong opinion on the name. "closed-rules" is fine by me.

> different rules to choose from.)
Well, it will not be possible for every programming language under the sun,
but it is possible to get the most widely used ones that have dynamic
methods and variables.

-andy

---

From: Andrew Newton <[email-masked]>
Date: Wed, 3 Dec 2014 10:59:01 -0500

> be the best thing that's possible.

I can do that.

-andy